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Getting Ready for Installation
Before you connect and run your new benchtop router, you should:

1. Check your shipment to make sure you received everything you need.

2. Register your benchtop router so you are covered by your warranty.

3. Prepare a workspace for your benchtop router and controller.

4. Unpack and set up your benchtop router.

5. Install the interface card into the computer.

Once all of these procedures are complete, you can connect the benchtop
router and controller box, then install the Control Program.

Check Your Shipment
The first thing you should do after receiving your benchtop router is inspect
the packaging for any visible signs of damage. If there is damage to the
outside of the packaging, contact the shipping company as well as Light
Machines Corp. After checking the packaging, locate the packing slip. This
slip lists all of the items you should have received with your benchtop router.
Check all of the items on the list. If any item is missing, contact Light Ma-
chines' Customer Service Department (800-221-2763).

Register Your Benchtop Router
You’ll find a registration card in the small box with the documentation and
software disks. Clearly print all the requested information and return this
card to Light Machines Corporation.
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IMPORTANT!

Be sure to keep the pallet and
all of the original cartons in
which the  benchtop router was
shipped. Should any
components need to be
returned to the factory, re-pack
them exactly as they were
received.

Light Machines will not be
responsible for any damage
caused during shipping when
components are not returned in
the original cartons.

CAUTION

The router weighs
approximately 300pounds (170
kg), so be very careful when
lifting it.

Prepare Your Work Place
Make sure you have all the items on hand necessary to perform the installa-
tion. To install the benchtop router, you must have:

w A sturdy bench on which you’ll place the benchtop router and your
computer. Placing the bench against a wall provides more stability.
Make sure the wall has a 120VAC, 15 amp polarized outlet.

w A personal computer running Windows 95 or Windows NT version
3.51 (or greater).  See page A-10 for a complete list of the necessary
computer equipment.

w Your PC Owner’s Manual or equivalent documentation.

Unpack the Benchtop Router
1. Position the pallet near the bench on which you’ll set the benchtop router.

The bench should be located against a wall for maximum support.

2. Remove the staples that attach the bottom of the cardboard container to
the pallet.

3. Lift the cardboard container off of the pallet.

4. Inspect the benchtop router chassis for visible signs of damage such as a
broken shield, a dent in the chassis or damaged cables.

If any damage is noted, or if you find any discrepancies between the
packing slip and the items received, call Light Machines’ Customer
Service Department (800-221-2763).

5. Using a 9/16" wrench, remove the four bolts holding the two 2x4 braces
holding the router on the pallet. Keep the bolts and other packaging ma-
terials in case you need to return the router to the factory.

Set Up the Benchtop Router
1. Using the four handles, carefully lift the benchtop router off of the pallet

and onto the table.

2. Once on the table, position the benchtop router correctly for machining.

3. Remove the protective paper from the safety shield.

Note:
We recommend the use of a
voltage surge protector and line
filter for your computer system.
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Note:
The Interface Card is factory set to
operate in the address range
reserved for Bisync cards on the PC
I/O address map "03A0 hex ".  If
another expansion card is already
installed to operate at this address,
contact Light Machines� Technical
Support Department for installation
assistance.

Hardware Installation
The following paragraphs review the procedures for installing the hardware
components of the benchtop router. You should already have your computer
system set up in according to the directions in the computer owner’s guide.

The first step is to install the Interface Card in your personal computer.

WARNING

Do not connect power to the benchtop router or the computer
until instructed to do so in the following procedures.

Installing the Interface Card in the PC
The following paragraphs describe the procedure for installing the Interface
Card in the chassis of your PC. You should have already set up your PC ac-
cording to the instructions in your Owner’s Manual. The Interface Card can
be installed in any slot designated for expansion card use. Refer to your computer
owner’s manual to determine particular expansion card restrictions.

WARNING

Do not plug the power cord from the PC chassis into an AC
outlet until all installation procedures have been completed
and the chassis cover has been closed.
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Opening the PC Chassis
To install the Interface Card, you must remove the cover of the personal
computer. Refer to the installation instructions supplied with your computer
for details on removing the cover. Generally, the cover is secured by four
screws through the rear panel; however, some personal computers may have
push latches, or screws in different locations.

WARNING

Disconnect power from your personal computer before opening
its chassis cover!

Turn off the power switch and remove the power cord to assure that
no electrical potential is present when the cover is removed.

Set the cover aside and locate the slot where the card is to be mounted. Remove
the blank slot cover (if any). Removing the slot cover requires removing a screw
at the top rail of the rear panel. You may choose to discard the cover, but save the
screw for installing the Interface Card.

Unpacking the Interface Card
The card is shipped inside an anti-static envelope. Be careful not to create
any static discharge when removing the card from the envelope; touch a
grounded surface such as the PC enclosure first. Slide the card out of the
envelope and inspect it for signs of damage, such as bent or broken compo-
nents or a warped circuit card. If damage is noted, contact Light Machines
Corporation immediately.

Inserting the Interface Card
The following procedures describe how to insert and secure the Interface Card
in the computer.

1. Grasp the Interface Card at the front and back.

2. Position the card above the bus connector at the chosen slot. The inter-
face connector on the end of the card should face the rear panel of the
computer chassis.
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3. Slide the card into the bus slot. The connector on the card should protrude
from the rear panel of the computer. Carefully wiggle the card back and
forth to assure its tightness in the bus. Components on the Interface
Card should not touch adjacent cards or other components.

4. Secure the card to the top rail of the rear panel with the screw you saved
when removing the blank slot cover.

5. Make note of which slot the Interface Card is plugged into. Do not get
it mixed up with the parallel port which uses the same type of connector.

Checking Your Installation
After installing the Interface Card, replace the computer chassis cover. Connect
the computer power cord and turn the computer on. The computer should
perform an internal check, and run the operating system .

If the PC fails to start-up, turn off the power, open the chassis and check
your installation to be sure that the Interface Card is located in an appropriate
slot and is properly seated.

When the Windows program is running, select shut down from the start
menu, turn off the power, and install the other hardware components.

Connecting the Benchtop Router
The following paragraphs review the procedures for connecting your com-
puter to the benchtop router controller box. The diagram on the following
page has been provided as a visual aid for the recommended connections.

WARNING

Do not connect power to the Benchtop Router until instructed to
do so in the following procedures.

Never connect or disconnect the cables with the power on! This
will cause damage to the Controller Box drive components.

Operate the Benchtop Router with all cables firmly secured.
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 Benchtop Router System Interconnection Diagram
(rear view of system)

 Benchtop CNC Router

Computer (with LMC Interface Card installed)

Controller Box

120V, 60Hz AC Outlet

Benchtop Router
Power Cord

9 Pin Cable

25 Pin Cable

Controller BoxPower Cord

Interface Connections
There are four connections that must be made in order to operate the
Benchtop Router; two interface connections and two power cords. The inter-
face cables are long enough to allow the computer to be located up to five
feet away from the  router. Make sure the router is placed on a stable, flat
surface and leveled properly.

1. Route the interface cables from the router to the computer.

2. Insert the 9-pin plug into the 9-pin receptacle protruding from the LMC
Interface Card in the rear of the computer.

3. Connect the end of the cable marked COMPUTER to the 25-pin connector
protruding from the interface card in the rear of the computer. Be sure you
are plugging the cable into the interface card connector, not the parallel port.

4. Make sure all connectors are secured with screw locks.



User's Guide: Section AA-8

Hardware Connections
Both the Benchtop Router and the Controller Box must be plugged into
grounded 120VAC, 60Hz, 15A polarized outlets. These  outlets must be ca-
pable of supplying up to 12 amps of power to the machine and controller box.

Locate the power cord for the Controller Box and the power cord for the
Router. Insert the plug ends of these cords into a grounded, three-hole,
120VAC, 60Hz wall outlet.

International users should connect to a grounded 220VAC, 50Hz, 8A polar-
ized outlet.

Optional Connections
You can attach a 120VAC accessory to your machine. Plug the accessory’s power
cord into the receptacle end of another accessory port adapter cable. Insert
the plug end of the cable into the receptacle labelled ACC 1 on the rear of
the Controller Box; the current draw for such accessories, however, is limited
to 3 amps.

A 9-pin male connector (labeled TTL I/O) is provided on the rear panel of
the Controller Box for interfacing to an I/O device such as a robot. See Reference
Guide: Section L of this manual for details on interfacing with robots.

CAUTION

Do not allow the AC power
cords to cross the interface
cables. The power cords can
create noise problems with the
signal lines in the interface
cables.

International Users:
If you need to change the plug on
the end of the electrical cord to
accommodate 220V, 50 Hz service,
the wiring is color coded as follows:

Line: brown
Neutral: blue
Ground: green w/ yellow stripe

Note:
Remove the protective cap from
the plug end of the Accessory Port
Adapter Cable before inserting it
into the accessory connector on the
Controller Box.

To connect an accessory to the
Controller Box use the Accessory
Port Adapter Cable

MOTOR DRIVES    MAIN

3A                  12A

ACC 2             ACC 1          SPINDLE

3A                  3A                   5A

COMPUTER                  TTL I/O                               A & B AXES                                   C AXIS

ONLY OPERATE
WITH ALL CABLING

SECURELY FASTENED
BETWEEN THE MACHINE

TOOL AND THIS BOX

WARNING!
DO NOT OPEN

NO USER SERVICEABLE
PARTS INSIDE

120VAC, 60Hz, 15A

120VAC, 5A    

120VAC, 3A

SPINDLE

ACC1

ACC2

120VAC, 3A

fuse fusefu
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Computer System Requirements
The Control Program runs on a 586/120MHz personal computer. The
computer must have:

w Windows 95 or Windows NT 3.51 or higher. (Windows NT users: see
the readme file for the latest information regarding available accessories.)

w 8 MB RAM minimum for Windows 95 (16 MB is recommended for
best performance). 16 MB RAM minimum for Windows NT.

w A 3.5" floppy drive.

w A hard drive with at least 5MB of available space.

w An available expansion slot.

w A VGA graphics controller and monitor.

w A Windows-compatible mouse.

Software Installation
The  Control Program is shipped on two 3.5", 1.4 MB disks. The control pro-
gram must be installed on a hard drive running either Windows 95, or Windows
NT version 3.51 or higher. You must have at least 5 MB of free space on your
hard drive to perform this installation. (See above for system requirements.)

Installing the Control Program
The following instructions assume that your hard drive is drive C, and your
floppy drive is drive A.

1. Turn on the computer. Wait for it to go through its internal checks and
for it to complete the start up process.

2. When your Windows desktop appears, insert the  disk in the computer
floppy drive.

3. Using the Windows Explorer, (Start Menu>Programs>Windows Ex-
plorer) open the floppy drive. Note: If you are installing on Windows
NT, use either the File Manager to access the floppy drive, or select
“Run” from the Program Manager.

4. Double click on Setup.EXE to start the installation.

5. The Welcome screen appears warning you to exit all other running
programs. If no other programs are running, click Next.

CAUTION

The  master disks are shipped
write-protected (3.5" disks
have the write-protect window
open) to prevent accidental
destruction of the software.
Never remove the write
protection! Create and use a
working copy of the disks.
Always store disks in a safe
place away from heat, sunlight
and static.

CAUTION

Make sure you read all the
safety instructions in this
guide before you attempt to
run the Control Program with
the benchtop router for the
first time.
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6. The next screen is the destination directory for the control program. If
you would like it put somewhere other than the default, click on Browse.
Otherwise, click Next.

7. A window showing the progress of the installation will appear, and when
ready, will prompt you to install the second disk. After the installation is
complete, a message will appear asking if you would like to view the
Readme file. It is suggested that you do view this file. It contains
important information about the software and the machine that may not
be included in the manual.

8. After reading the Readme file, remove the disk from the floppy drive. In
Windows 95, you may run the control program by double clicking the
program icon. From Windows NT, you will need to reboot the system.

Uninstalling the Control Program
In the event you need to remove the control program from your hard drive,
there is an uninstall program included on the software disks. This uninstall
program was copied onto your hard drive when you installed the control
program.

To uninstall the control program software, just double click the Uninstall
icon in the control program folder. A message will appear asking if you are
sure you want to remove the program and all its files. Click on Yes to
uninstall, or Cancel to exit the Uninstall program.

The Setup Program
The Control Program software automatically sets most variables for you. If
you need to access the Setup Program, see the Reference Guide: Section E in
this manual.

Note:
Using the Uninstall program will
not delete any NC files that you
may have created or used with the
software.
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Technical Support
Should you require technical assistance, you should contact your local Light
Machines dealer. If you are unable to resolve your problem through your local
dealer, technical support is available by phone, fax or email from 8:15 A.M.
to 5:00 P.M. EST.

Before Calling
Make sure you have the following information gathered before contacting
our Technical Support group.

w The product serial number.
w The name of the owner of the product.
w The specifications of your computer (e.g. hard drive size, clock speed, etc.).
w Notes on any Control Program error messages.

When you call, make sure you have access to both your benchtop router and
your computer. This will allow our technical support representatives to walk
through the problem with you. Our technical support numbers are:

U. S. (800) 221-2763
Canada (800) 637-4829

Fax (603) 625-2137
email support@lmcorp.com

WWW Site http://www.lmcorp.com/lmcorp

Warranty
Light Machines' products (excluding software) carry a one-year limited
warranty from date of purchase. Defective products may be returned for
repair or replacement according to the conditions outlined in the Terms
and Conditions of Sale agreement. If you need to return a product, call
Light Machines and a Technical Support representative will issue you a
Return Materials Authorization number (RMA). You must write the
RMA and your return address on the outside of the product carton or
crate. Failure to do so can result in a delay in the return of your product.

IMPORTANT!

Be sure to keep the pallet and all of
the original cartons in which the
Benchtop Router was shipped.
Should any components need to be
returned to the factory, pack them for
shipping exactly as they were
received.

Light Machines will not be
responsible for any damage incurred
during shipping when components
are not returned in the original
packing materials.
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The Benchtop CNC Router
The Benchtop CNC Router is a three-axis wood router you can run directly
from your personal computer.

The Windows-based control program, which you install on your computer,
accepts standard EIA RS-274D, ISO, and Fanuc G&M code CNC programs.

If used with Light Machines’ spectraCAM software, it’s easy to create designs di-
rectly from drawings produced with CAD programs, such as AutoCAD, that
generate DXF files. Linear, circular and helical interpolation are available on all
three axes.

Features
Some of the Benchtop CNC Router’s features include:

u A 1.75 horsepower motor

u Spindle speeds from 10,000 to 25,000 RPM

u Rapid traverse rates up to 100 ipm

u EIA RS-274D standard G&M code programming

u Aluminum machine base

u Feed rate and spindle speed override functions

u A built-in full-screen NC program editor

u An on-line help utility

Machine Specifications

Axis Travel
X Axis 22.50" (571mm)

Y Axis 24.00" (610mm)

Z Axis 4.00" (100mm)

Open Height 4.75" (120mm)

Router Work Area
Table Size 24" x 32" (610mm x 812mm)

Table load capacity 100 lbs. (45 kg)
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Spindle
Drive motor 1.75 hp (1300 watts)

Speed Range 10,000 - 25,000 RPM

Spindle Nose 1/2"

Collet Capacity 1/4" and 1/2"

Feed Motors
Linear Feed Rate 0.1 - 60 ipm (2 - 1525mm/min)

Circular Feed Rate 0.1 - 40 ipm (2 -1015mm/min)

Rapid Feed Rate 100 ipm (2540mm/min)

Power Requirements
120 VAC +10% - 15%  (U.S. only)

47-63 Hz single phase, 3 wire

15 Amps / 1.8 KVA

Dimensions
Width 32.5" (825mm)

Depth 47.0" (1194mm)

Height 34.0" (864mm)

Weight (Approximate)
Net 420 lbs (190 kg)

Shipping 520 lbs (236 kg)

The Accessory Kit
The Accessory Kit included with the Benchtop Router contains all the tools
and hardware necessary for installation and maintenance.
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The Router Components
There are, of course, more components on the Benchtop CNC Router than
those shown here, but to begin, you need only be concerned with the major
components.

A 1 3/4 hp Spindle Motor supplies spindle speeds from 10,000 to 25,000
RPM. The Enclosure helps protect the operator from flying chips, and helps
keep the area clean. The enclosure door interlock switch prevents the router
from operating with the door open.

The X, Y and Z motion of the machine is performed by Drive Motors on
each axis. There are also limit switches to prevent the machine from traveling
beyond the limits on each axis.

The mechanical clamps on the Hold Down Table keep the stock firmly in
place during a cutting operation.

� Enclosure Door

� Spindle Motor

� Hold Down Table

� Interlock Switch

�

�

�

�
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The Front Panel
The Front Panel provides the operating controls shown here.

You can’t miss the most important control on the router; the Emergency Stop
button. When pressed, this bright red palm button immediately halts router
operation. To resume operation, twist the button and pull it back out. It is
important that this button be pressed before performing any manual opera-
tions, like changing the stock or the tooling.

The Spindle Speed Override knob is used to establish the spindle speed. On
the CNC Router, the minimum and maximum positions on the knob are
equivalent to 50% to 150% of the programmed RPM.

The Rear Panel
On the rear panel of the router is the Controller Box. The Controller Box
houses the power- and interface-related controls for the router. The power
switch and keylock switch are on the front panel of the box. The Key Lock
switch keeps unauthorized persons from turning on the router. Once the Key
Lock is in the unlocked position, the Power switch can be turned on. The Power
switch lights up when power is on.

On the rear panel are the power and interface connectors, and the fuses. The
box has five fuses for main power, the spindle motor, the stepper motors,
and the two accessory outlets (labeled ACC 1 and ACC 2). The values for
these fuses are clearly printed next to the fuse receptacles. Do not use fuses
with amperage ratings other than those shown.

The interface connectors are used for communication between the controller
box, the router, and your computer. All connections between the router and
controller box are  made at the factory. The only connections you will make
are from the router and controller box to the computer, and the two power
cords. Refer to Section A  for correct installation procedures.

MOTOR DRIVES    MAIN

3A                  12A

ACC 2             ACC 1          SPINDLE

3A                  3A                   5A

COMPUTER                  TTL I/O                               A & B AXES                                   C AXIS

ONLY OPERATE
WITH ALL CABLING

SECURELY FASTENED
BETWEEN THE MACHINE

TOOL AND THIS BOX

WARNING!
DO NOT OPEN

NO USER SERVICEABLE
PARTS INSIDE

120VAC, 60Hz, 15A

120VAC, 5A    

120VAC, 3A

SPINDLE

ACC1

ACC2

120VAC, 3A

fuse fusefu
se fuse fusefu
se

fuse fusefu
sefuse fusefu
se fuse fusefu
se
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Maintaining the Benchtop Router
Performing preventative maintenance on your Benchtop CNC Router en-
sures a longer, trouble-free life for the machine. We provide instructions for
preventative maintenance in the following paragraphs.

Cleaning and Lubrication
Because dust and wood chips find their way into the base area that houses
the Y axis ballscrews, it makes sense to perform cleaning and lubrication at
the same time.

Ballscrews
The Benchtop Router uses pre-loaded ballscrews on the X and Y axes. The
screws are lubricated at the factory with a special long-life, waterproof lubri-
cant. The ballscrews should be lubricated every 6-8 weeks. The lubricant
(part number M2006) is available from Light Machines Corporation.

The Z axis has a leadscrew that needs no lubrication. Lubricating the Z axis
leadscrew may cause damage.

The X axis ballscrew is easy to lubricate. Press the Emergency Stop button to
remove power to the router. Simply reach inside the enclosure, wipe the dirt
off, and apply grease to the exposed ballscrew. Because of the constant expo-
sure to dirt and sawdust, it should be cleaned and lubricated once a month.
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If you purchased the Optional Router Stand (ACC-5598), lubricating the Y
axis ballscrew is easy. Reach underneath the router and access the ballscrew
through the holes in the machine base. Be careful of the dust building up in
the area beneath the Hold Down Table. The dust can cause the Y axis
ballscrew to bind, stopping movement on the Y axis. Using a small vacuum,
reach through the holes used to access the ballscrew and remove any sawdust
in that area. It is a good idea to check for dust buildup every time you lubri-
cate the ballscrew. After cleaning the base area, apply a thin film of lubricant
along the length of each of the ballscrew.

Y Axis Ballscrew

Z Axis Leadscrew X Axis Ballscrew

Hold Down Table

Spindle Head

Holes for access to
Y axis ballscrews

Note:
The router is shown here with the
enclosure removed for easy
identification. It is not necessary
to remove the enclosure to
perform maintenance.
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If your machine is on a bench where you cannot access the underside of the
machine, you will need to follow this procedure:

1. Jog the router head to the rear of the machine and the top of the Z axis,
just before the limits are  tripped.

2. Press the Emergency Stop button and disconnect the power cord to the
router.

3. Using the handles at the front and rear of the router, raise the machine
up high enough to access the holes in the bottom of the base.

4. Set blocks under all 4 corners of the machine. Be sure that: a) the base
is high enough to safely reach under the machine; b) the router is resting
solidly on the blocks at all 4 corners.

5. Reach up through the holes in the base to vacuum out the dust, and
then use a small brush to apply lubricant to the ballscrew.

6. After cleaning and lubrication, lower the machine back to the benchtop
and reconnect power.

The Dust Collection System
If you purchased the optional Dust Collection System (ACC-5734), you will
need to empty the canister at the end of each day. You should also verify that
the collector is turned on before running a program on the router. The
power switch for the collection system is located on the top of the unit.

Some sawdust will escape the Dust Collection System. Be careful of the dust
building up in the area beneath the Hold Down Table. The dust can cause
the Y axis ballscrew to bind, stopping movement on the Y axis. Using a small
vacuum, reach through the holes used to access the ballscrew and remove
any sawdust in that area. It is a good idea to check for dust buildup every
time you lubricate the ballscrew.

CAUTION

Lift the Benchtop Router very
carefully. Be sure that the
machine is resting completely
on the blocks before reaching
underneath. The Benchtop
Router weighs approximately
300 lbs (135kgs).
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Maintaining the Controller Box
The Controller Box requires no special maintenance, except that it should be
kept in a relatively dust-free environment.

If you are having problems with the AC Outlet function, or if the stepper
motors are not running, you may need to change a fuse in the Controller
Box. A blown fuse can occur if you overload one of the AC outlets. To
change a fuse:

1. Turn the power off, and disconnect the power cords to the Controller
Box and the Benchtop CNC Router.

WARNING

Changing fuses with the AC power connected can cause electric
shock!

Always disconnect the main AC power before servicing the
Controller Box or router.

2. The fuse holders are externally mounted on the rear panel of the Con-
troller Box and are labelled to correspond with each AC outlet. Locate
the correct fuse holder.

3. Remove the fuse by turning the fuse cap counterclockwise while pressing
slightly inward. The fuse is removed with the cap.

4. Visually inspect the fuse. If the fuse element appears broken, it is blown.
You can also use an ohm meter to check continuity across the  fuse.

5. Replace the blown fuse with a standard slow-blow fuse of the appropriate
rating. Three-amp (3A) fuses are used for the motor drives, ACC 1, and
ACC 2. A five-amp (5A) fuse is used for the spindle, and a twelve-amp
(12A) fuse is used for main AC power.

6. Replace the fuse holder cap by pushing inward and turning clockwise.

7. Reconnect power.



User's Guide: Section BB-10

Maintaining the PC in a Shop Environment
There are a few general guidelines for maintaining your personal computer
and software in a shop environment. See your owner’s manual for mainte-
nance procedures that are specific to your computer.

Caring for the Computer
Follow these general rules for computer care.

u Keep the computer and peripherals (mouse, keyboard, external drive,
printer) out of direct sunlight and away from sources of heat and in a
relatively clean environment.

u Keep liquids (soda, coffee, cutting fluid, grease) away from the computer
and peripherals.

u Keep oil, grease, wood chips and excess dust away from the computer,
keyboard and floppy disks.

u Use grounded, three-prong outlets for the computer and peripherals.
Take precautions against current overload. Use a line-surge suppression unit
to help alleviate this problem.

u Don’t block the vent holes in the computer or drives; they are required
for air circulation.
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Caring for Floppy Disks
Floppy disks are simple to use, but require a few precautions to maintain
their integrity.

u Don’t touch the magnetic disk (the shiny, record-like part inside the
disk jacket). Dust, dirt, or grease from your hand can ruin any part of
the disk that you touch, or  possibly destroy the entire disk.

u Keep disks in a disk box or special disk container instead of spreading
them out on your work space.

u Handle disks gently, don’t bend or crease them.

u Don’t write on disk labels with a ball point pen. If you must write on
the label, always write very lightly with a felt tip pen.

u Keep disks in a clean, cool environment away from excess amounts of
dust, heat, or sun.

u Beware of getting machining fluids on the disks. If you spill a liquid  on
a disk, it is almost certain that the disk and all the data on it can never
be used again.

u Keep disks away from all magnetic sources including telephones, high-
voltage power sources, and mill motors.

u Make backup copies of all NC program disks any time you update them.

u Print copies of all NC programs in case of disk failure or lost disks.

No matter how cautious you are, disks will go bad. If this happens while you
are editing a program, the program will be lost. The solution to this disaster
is simple—make backup copies.
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Benchtop Router Options
The Benchtop Router has the following available options:

Dust Collection System (ACC-5734)

Router Support Stand (ACC-5598)

spectraCAM Milling for Windows (CAM-6721)
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Starting the Control Program
To start the Control Program:

From Windows 95 select Start >Programs >BenchRouter  >BenchRouter.EXE.
You can also create a Windows 95 shortcut by opening the BenchRouter direc-
tory and dragging BenchRouter.EXE onto your desktop.

From Windows NT double-click the BenchRouter icon in the BenchRouter Group.

You should have the controller box connected and powered up before starting
the control software, unless you are going to be working in the Simulate Mode.

Starting the Control Program in Simulate Mode
If this dialog box appears when you start the Control Program, the interface
card that came with your router has not been properly installed.

If you do not have the interface card installed you can still edit and verify
NC part programs without the router by running the Control Program in
Simulate Mode.

To start the Control Program in Simulate Mode, select Cancel.

When the next dialog box appears, select Simulate.
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If You Need Help...
You can access online help by using the commands under the Help Menu, or
by pressing F1.

For more information on many of the functions and screens in the Control
Program software, you can also see Reference Guide: Section E, Control Pro-
gram Reference.
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Exploring the Control Program Screen
You should become familiar with the main parts of the Control Program
screen before you begin using the Control Program to run NC part pro-
grams. The following are the default components that make up the screen.

Menu Bar
The Menu Bar contains all of the menu commands for the Control Program. For
an explanation of each menu and its relative commands, see the Reference
Guide: Section E.

Standard Tool Bar
The Standard Tool Bar provides easy access to the most often used Control
Program commands.

Title Bar

Position Readout

Machine Info
Panel

Verify Window

Message Bar

Outputs Tool Bar

Menu Bar

Standard Tool Bar

Inputs Tool Bar

Status Bar

Edit Window
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Tool Function

New File Begin a new NC part program file.

Open File Open an existing NC part program file.

Save File Save current NC part program file to disk or drive.

Cut NC Code Cut selected code from program and place on clipboard.

Copy NC Code Copy selected code to clipboard.

Paste NC Code Paste code from clipboard to cursor position in program.

Print File Send program to printer.

Help Access Help program.

Context Help Obtain help on selected object.

Jog Control Access Jog Control Panel.

Operator Panel Access Operator Control Panel.

3-D Verification Access 3-D tool path verification.

Run (green) Run the current NC part program.

Pause (yellow) Pause the currently running NC part program.

Stop (red) Halt the currently running NC part program.



User�s Guide: Section CC-6

Outputs Tool Bar
The Outputs Tool Bar is an active tool bar. It provides switches to supply
power to the spindle, and the Accessory outlets on the Controller Box.
Switches for Robotic outputs 1 and 2 are also provided. Power is on when
the buttons are depressed.

Tool Function

Spindle Output Provides power to the spindle.

Acc1 Provides power to the Acc1 outlet on the Controller Box

Acc2 Provides power to the Acc2 outlet on the Controller Box

Robot 1 Output Provides power to the TTL I/O connector on the Controller

Box for Robotic Output 1 (see Reference Guide: Section L).

Robot 2 Output Provides power to the TTL I/O connector on the Controller

Box for Robotic Output 2 (see Reference Guide: Section L).
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Inputs Tool Bar
The Inputs Tool Bar is an inactive tool bar. It provides information only on
the state of the Emergency Stop, the Safety Shield, and the positive and
negative limit switches. Indicators for Robotic inputs 1 and 2 are also pro-
vided. An input is active (on) when the button is depressed.

Tool Function

E-Stop Indicates when the Emergency Stop is pressed.

Safety Shield Indicates when the Safety Shield is open.

Positive Limit Indicates when the Positive Limit switch  is on.

Negative Limit Indicates when the Negative Limit switch  is on.

Robot 1 Input Indicates when Robotic Input 1 (see Reference Guide:

Section L)  is on.

Robot 2 Input Indicates when Robotic Input 2 (see Reference Guide:

Section L) is on.
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Edit Window
Whenever you open an NC part program file it appears in its own edit
window. These windows have the same characteristics as other Windows 95
windows (scroll bars, minimize/maximize buttons, etc.). You can have
multiple edit windows open at a time, the number of which depends on
available memory.

By default, each new window is locked; you can not edit a locked window.
To unlock the window, use the Lock command under the Edit Menu.

Here is what the edit window for the
NC program Router1.NC looks like.

IMPORTANT

Always verify NC programs after
editing to ensure that your
changes will not cause a tool
crash!
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Status Bar
The left side of the Status Bar provides information about the currently selected
function. The right side of the status bar provides information on:

w Whether or not the router is homed

w Whether or not the Caps Lock key is activated

w Whether or not the Num Lock key is activated

w The line on which the cursor is located, and total lines in the program

w Whether or not the current NC part program is locked

w Whether or not the current NC file has been modified

w The current time according to your computer

When the indicator is dimmed, the function is in the off condition.

Current function Home state

Cap Lock state

Num Lock state

Current  Line: Total Lines
File Lock state

File modify state

Current time
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Position Readout
The Position Readout provides information on the current X, Y and Z coor-
dinates of the tool position. The units of measure in the Position Readout
are determined by the Units command under the Setup Menu.

Tips:

wIf you wish, you can move the
Position Readout to another part of
the screen. Hold the Control key
down, then click and drag the
Position Readout. Once you release
the Control key and the mouse key,
the Position Readout will stay in the
new position. If you move it back to
the docking area, it will
automatically dock.

wIf you want it to remain floating,
press the right mouse button in the
window, and uncheck �dockable.�
The window can only be resized
when it is undockable.

wYou can double-click on the
Position Readout to bring up the Go
To Position dialog box.

wFor more information on moving
and resizing windows, see the
Control Program Reference section
of this manual.

Machine Info Panel
The Machine Info Panel provides information on the current tool, tool
diameter, feed rate, spindle speed, number of  passes made, coordinate
system in use, as well as the current block and total number of blocks in
the program.

When a part program is running,
the Info Panel also provides
dynamic display of the elapsed
machining time and highlights the
block of code that is currently being
executed.

Elapsed time indicator

Current, previous and next block

Tips:

wIf you wish, you can move the
Machine Info Panel to another part
of the screen. Hold the Control key
down, then click and drag the Info
Panel. Once you release the Control
key and the mouse key, the
Machine Info Panel will stay in the
new position. If you move it back to
the docking area, it will
automatically dock.

wIf you want it to remain floating,
press the right mouse button in the
window, and uncheck �dockable.�
The window can only be resized
when it is undockable.

wFor more information on moving
and resizing windows, see the
Control Program Reference section
of this manual.
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Verify Window
The Verify Window displays a simulation of your part program when you
select the Verify command from the Program Menu, or when you click the
Verify Program button on the Standard Tool Bar.

Tool path verification can be performed in centerline view or solid view.
Centerline view is based on the centerline of the tool. Solid view is a solid
representation of the tool and workpiece.

Tips:

wIf you wish, you can move the
Verify Window to another part of
the screen. Hold the Control key
down, then click and drag the Verify
Window. Once you release the
Control key and the mouse key, the
Verify Window will stay in the new
position. If you move it back to the
docking area, it will automatically
dock.

wIf you want it to remain floating,
press the right mouse button in the
window, and uncheck �dockable.�
The window can only be resized
when it is undockable.

wYou can double-click on the Verify
Window to bring up the Verify
Setup dialog box.

wFor more information on moving
and resizing windows, see the
Control Program Reference section
of this manual.

Centerline View

Solid View
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Safely Running the Benchtop Router
Like any other power tool, the Benchtop Router is a potentially dangerous
machine if operated in a careless manner. The importance of safely operating
the Benchtop Router, including the need for protection against personal in-
jury and the prevention of damage to the equipment, can not be stressed
enough. You will find more information on safe machining in the Reference
Guide: Section J.

Safety Rules
The following safety rules should be practiced by all operators of the Benchtop
Router.

Remove Adjusting Keys and Wrenches
Make a habit of checking that keys and adjusting wrenches are removed from
the Router before operating the machine.

Do Not Force a Tool
Select the feed rate and depth of cut best suited to the design, construction
and purpose of the cutting tool. It is always better to take too light a cut
than too heavy a cut.

Use the Right Tool
Select the type of cutting tool best suited to the operation. Don’t force a tool
or attachment to do a job it wasn’t designed to do.

Secure the Workpiece
Be certain that you have firmly secured the workpiece on the hold down
table and the cutting tool in the spindle before turning on the spindle motor.

Tighten All Holding, Locking and Driving Devices
Tighten the work holders and tool holders. Do not over-tighten these devices.
Over-tightening may damage threads or warp parts, thereby reducing accu-
racy and effectiveness.
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Note:
You should use the Emergency Stop
button to disconnect power to the Router
when changing tools, or when mounting
or removing a workpiece.

Place a Pause command and a Tool
Change command (M06) in your part
program. Once the pause is executed,
push in the Emergency Stop button and
open the Router shield.

When you are finished with the changes,
close the shield. Pull out the Emergency
Stop button, then press Enter on the
computer keyboard to resume running
the program.

Making Emergency Stops
Before you run the Benchtop Router for the first time, you should know how
to stop the machine should an emergency situation arise. There are a number
of ways an emergency stop can be initiated on the Router: by pressing the
Emergency Stop button, by simultaneously pressing the Control and Space Bar
keys on the computer keyboard, by activating one of the limit switches, or by ac-
tivating the safety shield interlock switch.

Stopping with the Emergency Stop Button
There is an Emergency Stop button located on the front panel of the Router;
it has an oversized red cap. Before power can be applied to the Router, the
Emergency Stop button must be pulled fully out from the front panel. The
Emergency Stop button disables the spindle even if the computer is off.

In the event that an error occurs, such as a tool crashing into the workpiece, you
can immediately kill power to the Router by pushing in the Emergency Stop
button. Pushing in the Emergency Stop button terminates the part program.
Wait until the Router has completely stopped moving before opening the
safety shield.

When the tool crash or other error has been cleared and the Emergency Stop but-
ton is released (pulled back out), press Enter on the keyboard to close the error
dialog box that appeared when the Emergency Stop button was pressed. Edit the
part program to remove the cause of the tool crash before running the program
again. You may need to reinitialize (reset the point of origin for all axes) the
Router using the Set Position command from the Setup Menu, and you may
need to home the machine again.

The Emergency Stop button should be your first target when a critical error oc-
curs. You do not need to use it in situations where safety or reaction time is not
an issue. For example, if you start to run a program but notice that the tool is
moving towards the wrong corner of the workpiece, use a software stop to halt
the program and reset the origin of the workpiece.

Stopping with the Computer Keyboard
The execution of the part program can be interrupted by pressing keys on
the computer keyboard. To stop the part program with the keyboard, press
the Control key and Space Bar simultaneously. The cutting stops immedi-
ately and the cutting tool remains in position.
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To restart the program from a keyboard-generated stop, select the Run/Con-
tinue command from the Program Menu. In the Start At Line box, enter the
number of the last line executed, then click on the Run Program button.
(When you stopped the program, the last line executed is displayed on the
Machine Info Panel, and the cursor is placed on that line in the file.)

Stopping with a Limit Switch
The Benchtop Router is equipped with limit switches to sense the end of
travel on each axis. If the table travel exceeds the end of travel on any axis, a
limit switch is activated and shuts down machine operation.

Once a limit switch is activated, the tool must be jogged away from it using
the Jog Control keypad (selected from the View Menu).

To move the cross slide away from the limit switch, you must jog it in the
opposite direction. Each axis has a positive and a negative limit. If a positive
limit is hit, you must jog away from it in a negative direction. If a negative
limit is hit, you must jog away from it in a positive direction. If both a posi-
tive and a negative limit are hit, you must jog away in a negative direction.

If the cross slide comes close enough to the end of travel on any axis to activate a
limit switch, the following procedure must be followed to restore normal operation.

1. Select Jog Control from the Standard Tool Bar.

2. Press the appropriate jog key on the jog keypad, to move the cross slide
away from the triggered limit switch.

3. Check your initial machine set up to make sure it was performed correctly.

Stopping with the Safety Interlock Switch
Opening the enclosure door activates a safety interlock switch which interrupts
the NC program and stops machine motion. The cutting stops immediately
and the cutting tool remains in position. To restart the program, select Run/
Continue  from the Program Menu to begin the operation again. However,
this is not recommended as the proper method of stopping the machine in
an emergency situation. Use the Emergency Stop button.

Note:
Never open the Enclosure Door
while a program is running.
Always push the Emergency
Stop button in before making
any adjustment to the Router
or workpiece.
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Running a Sample NC Program
When you installed the Control Program, an NC part program file named
ROUTER1.NC, was copied into the BenchRouter directory along with the
other files. This program is meant to cut a 5.5" x 5.5" piece of wood. You
will be using this file to create your first workpiece on the Router.

WARNING

Do not attempt to operate the Benchtop Router without
reviewing all of the safety precautions set forth in  Section J.

Open ROUTER1.NC
1. Select the Open command from the File Menu, or click on the Open

button on the Standard Tool Bar. The Open dialog box appears.

2. Double-click on the filename , or select the filename then select the
Open button. The edit window for Router1.NC appears.
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Adjust the Verify Settings
After loading the NC program, you need to adjust the Verify Settings for the
stock you are about to cut. To view the Verify Setup dialog box, double click on
the Verify window. You may also select the Program Menu and choose Verify
from the pull down menu, or Select Verify from the Standard Toolbar and
choose Verify Settings. The Verify Setup dialog box appears.

Adjust the View
1. Select View.

2. Select either Solid or Centerline (for a solid representation or a centerline
representation of the tool and workpiece).

3. Select Isometric for a three dimensional view of the part.

The Verify Setup dialog box allows
you to alter the viewpoint of the
tool and workpiece in the Verify
Window.

The View panel allows you to:

w Alter the Style (Solid or
Centerline)

w Zoom in, zoom out or fill the
window by selecting All

w Look at the workpiece in two or
three dimensions

You can also alter the view of the
part by adjusting the sliders on the
Preview box.
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Adjust the Stock
1. Select the Stock tab.

2. Enter the stock Dimensions for the ROUTER1.NC program. The stock
dimensions are X=5.5", Y=5.5" and Z=0.5".

3. Set the Initial Tool Position to X=0, Y=0 and Z=0.5

4. Set the point of Origin to zero on all three axes.

5. Select OK. The dialog box will close, and you should notice a change in
the shape of the workpiece in the Verify Window.

The Stock panel allows you to:

w Enter the dimensions of the
workpiece

w Set the initial position of the
tool

w Set the point of origin for the
workpiece
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Define the Tool
You will be using an 1/4" router bit for this program. You will be using the
parameters for this particular bit for the tool path verification as well. To define
the tool parameters, first add the tool to the tool library, then select the tool
for verification.

Add the Tool to the Library
1. Select Setup Library from the Tools Menu. The Setup Tools dialog box

appears. There is no 1/4" Router bit defined, so  we will need to create one.

2. In the Tool Library scroll box, scroll down to tool 2, which is undefined
at this point. Highlight Tool 2 by clicking on it with your mouse.

3. In the Tool Type pull-down list, select End Mill.

4. Enter "Router Bit" in the Description box.

5. In the Material Type pull-down list, select Carbide.

6. Enter 0.25 in the Diameter box.

To define a new tool, you first have
to select an undefined tool, as we
have here, then select a Tool Type.

Note: You can also enter fractions
and let the program calculate the
decimal equivalent.
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Select the Tool for Verification
1. Select Tool from the Tools Menu. The Select Tool for Use dialog

box appears.

2. Select Tool 2 from the pull-down list.

3. Click on the Select Tool button.

Here is the newly defined tool, an
1/4" Carbide Router Bit that has
four teeth.

These are the same tool
parameters you will use when
actually run the Router1.NC
program.

7. Click on the Apply button. You have just defined a new tool in the li-
brary. From now on, whenever you need an 1/4" Carbide Router Bit, it
will be there.

8. Click on OK to exit the Tool Library.
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Installing a Tool
There are two wrenches included in the Accessory Kit shipped with the
router. The collet wrenches are used for installation and removal of tools. To
install a tool into the spindle:

1. Using the Jog Control Panel, jog the spindle head high enough away
from the table to allow you to access the collet.

2. Press the Emergency Stop button, and open the enclosure door.

3. Remove the brush from the spindle. There is a single thumbscrew on the
front of the brush. Loosen this screw and swing the brush down. Pull the
brush forward slightly and then down again to remove it.

4. Using the collet wrenches, loosen the collet nut.

5. Install the tool into the collet, and hand tighten the collet nut.

6. Using the wrenches, tighten the collet nut. Do not overtighten! Over-
tightening the collet nut will cause damage to the nut.

7. Replace the brush around the spindle head.

8. Close the door and release the Emergency Stop button.

9. From the Tools menu, choose Select Tool.

10. Choose the tool number and description that correspond to the tool you
installed in the Router. If the tool you installed is not already defined in
the list, you must define the tool (see Define the Tool).

11. Choose Select Tool to close the window.
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Verify ROUTER1.NC
Tool path verification allows you to check for programming errors before
actually running the part program on the Router.

1. Select Verify from the Program Menu. The Verify Program dialog box
appears. The default starting line for the program is Line 1. When veri-
fying a program for the first time, you should begin at the first block.

2. Click on the Verify Program button, then watch the Verify Window.
You will see ROUTER1.NC executed on the graphic workpiece.
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Dry Run the NC Program
Before you run your part program for the first time, you should perform a
dry run (run the program with no stock mounted). This will ensure that all
the movements of the Router make sense and that the tool is in no danger of
striking any fixtures or crashing into the table. Although you should dry run
the program with no stock mounted, you should set the point of origin us-
ing the workpiece, and then remove it.

Begin with the Emergency Stop button pressed in, and the spindle speed
turned all the way down. The work holding devices should be mounted to
the table and the tool should be mounted in the spindle.

1. Mount the workpiece on the table.

2. Close the enclosure door and  pull out the Emergency Stop button.

3. Select Jog Control from the View Menu (or the Standard Toolbar). The
Jog Keypad appears.

4. Use the Jog Keypad to jog the tool to top front left corner of the
workpiece.

5. Select Set Position from the Setup Menu. The Set Position dialog box appears.

6. Enter zero in the X, Y and Z boxes.

To jog the tool:
Click on the appropriate axis
buttons on the Jog Keypad.

The tool moves at the speed and
distance selected using the Speed
and Step buttons.

The Speeds and Steps (distances)
on the Jog Keypad are defined by
the Setup Jog Parameters
command under the Machine
Menu.

To move the tool in a continuous
motion, select Cont. The tool will
continue to move as long as the
axis button is depressed.

Note:
Double-clicking on the Jog Keypad
opens the Jog Parameters dialog
box.
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7. Click on OK. The values in the Position Readout all change to zero.

8. Jog the tool up and away from the workpiece, press the Emergency Stop
button, open the Enclosure Door and remove the workpiece.

9. Return the Enclosure Door to the closed position and pull out the
Emergency Stop button.

10. Put on a pair of safety glasses and complete the Safety Checklist (refer to
Reference Guide: Section J).

11. Select Programs, and choose Run/Continue.

12. The Run Program dialog box appears. Click on the Run Program button.

13. As the part program runs, observe the tool motion in relation to the
table (and eventually the workpiece). Look for signs of a possible tool
crash and be prepared to press the Emergency Stop switch on the
Router. Edit the program as required. When you are satisfied that the
tool motions are correct, you can mount the workpiece.
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Mount the Workpiece
1. Using the Jog Keypad, jog the spindle up and out of the way.

2. Before mounting the workpiece, push the Emergency Stop button in.

3. Mount the workpiece on the hold down table using either the clamps
provided, or a vise.

4. Pull the Emergency Stop button out.

5. Select the Operator Panel and check that the spindle speed is set to 100%.

The workpiece is now correctly mounted.

Run the Program
Before executing the ROUTER1.NC program, check that all safety precau-
tions have been taken. The Router enclosure door should be closed, and you
should be wearing safety glasses.

If anything goes wrong, immediately press the Emergency Stop button on the
Router to stop the operation. A safety checklist has been provided in Section J of
this guide. Post a copy of this checklist near the Router and review it before you
run any NC program.

To run the program:

1. After reviewing the Safety Checklist, select the Run/Continue command
from the Program Menu. The Run Program dialog box appears.
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2. Make sure that the Start Line box is set to line 1 of the program.

3. Click on the Run Settings button. The Run Settings dialog box appears.

To change the Run Settings, click
on an item checkbox. The Run
Settings include:

Single Step    Allows you to run the
NC part program one line at a
time, pausing asfter each line is
executed.

Optional Skip    When off does not
recognize  the optional skip code (/ ).

Optional Stop    When on, will
pause the NC program at any M01
code.

Enable Subprograms    Must be on
if the program uses subprograms.

Arc Centers Incremental    When
off, does not recognize the % code
indicating that the center of an arc
is an incremental value relative to
the start of the arc.

Treat Warnings as Errors    When
on, will halt the NC program at a
warning as though it were an
error.

Restore Unit Mode When Done
When on, restores the original unit
mode (inches or metric) regardless
of the units used in the current NC
program.

Verify While Running    When on,
tool path verification occurs while
the NC program is running on the
Router.

4. Make any changes desired in the Run Settings dialog box, then select OK.

5. Click on the Run Program button to begin running your program.

6. After the stock is cut, press the Emergency Stop button before opening
the Enclosure Door and removing the finished part.
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The Benchtop Router Interface
The Benchtop Router interface (the screen) is composed of several components
that allow you to create NC part programs and interact with the router.

The Benchtop Router interface components include:

u The Message Bar

u Windows

u Toolbars

u Panels

u The Status Bar

u The Menu Bar

Message Bar

Menu Bar

Toolbars

Window

Status Bar

Panels
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Using the Message Bar
The Message Bar is located directly beneath the Menu Bar. When an NC
program is running or being verified, the Message Bar displays the name of
the NC file currently being run, or the most recent operator message. When
a program is running, the Message Bar also displays control buttons (Go or
Stop). When there is no program running, the Message Bar displays the
Control Program copyright notice.

Using Windows
Windows are used to display information. Some windows can be docked or
they can be floating windows. Windows are activated or hidden using the
commands under the View Menu.

The following windows are available:

u Program Edit Windows

u Verify Window

u Machine Info Window

u Position Window

Program Edit Windows
When you open an existing NC part program file, or create a new one, the
program appears in a program edit window. Program edit windows have all
of the features common to other windows, including a title bar which dis-
plays the program file name and controls for minimizing, maximizing, and
closing the window.

Program edit windows appear in the Edit Area (the large central area) of the
screen. The Edit Area is fixed in position; you cannot close it or move it.

When other windows, panels, and toolbars are closed, the space that their
docking areas occupy is given to the Edit Area.

When other windows, panels, and toolbars are open, the space that their
docking areas occupy is taken from the Edit Area.

The Edit Area can contain multiple program windows. The Windows Menu
has several commands for managing program windows. You may select a
particular window from a list of all current program windows, identified by
file names.
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Verify Window
The Verify Window can be opened and
closed by selecting the Verify Window
command from the View Menu.

The Verify Window displays a simula-
tion of your NC program (tool path
verification) when you select the Verify
command from the Program Menu, or
when you click the Verify Program but-
ton on the Standard Toolbar.

Tool path verification can be performed in centerline view or solid view.
Centerline view is based on the centerline of the tool.

Solid view is a solid representation of the tool and workpiece.

Machine Info Window
The information displayed in the Machine Info Window varies with the par-
ticular operation being performed:

When the machine is idle, the Machine Info Window displaysthe following
information:

u Current tool number and diameter,

u Feed rate and spindle speed,

u Number of passes made for the current program

u Coordinate system being used

u Current block number, and the number of blocks in the program.

The passes, current block, and total number of blocks refer to the last pro-
gram verified or run.

Tips:

�If you wish, you can move the Verify
Window to another part of the
screen. Hold the Ctrl key down,
then click and drag the Verify
Window.  If you hold the Ctrl key,
the window will not dock, so you
can place it anywhere on the
screen.  If you release the Ctrl key,
the window will try to dock to the
main window, depending on where
you drop the window. To prevent
the window from ever docking,
right-click on the window and un-
check the Dockable command.

� Pressing the right mouse key while
in the Verify window displays a pop-
up menu with Verify-related
commands.

� When the Verify Window is floating
(not docked) you can resize it just
like any other window.

� You can double-click on the Verify
Window to bring up the Verify
Setup dialog box.

Tips:

� If you wish, you can move the
Machine Info Window to another
part of the screen. Hold the Ctrl key
down, then click and drag the
Machine Info Window. Once you
release the Ctrl key, the Machine
Info Window becomes a floating
window which you can place
anywhere on the screen.

� When the Machine Info Window is
floating (not docked) you can resize
it just like any other window.
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Note:
When running the control program in
Simulate mode, the Goto command
will not move the machine to the
specified coordinates. It will simulate
movement, showing the tool moving
to those coordinates in the Position
Window.

When a program is running, the Machine Info Window becomes a dynamic
display. In addition to updating the previously mentioned information, each
line of code (as it is executed) is displayed along with the previous and next
lines of code. Also, a clock provides the elapsed run time for the program.

When a program is being verified, the Machine Info Window displays the
current line of code, plus the previous and next lines. The elapsed time is not
indicated.

The Position Window
This is a dynamic display. When a program is running or being verified, the
current position of the tool is indicated here.

If you double-click on this window, the Goto Position dialog box appears,
allowing you to move the tool to specific coordinates.
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Using Tool Bars
Toolbars carry buttons that correspond to frequently used menu commands.
You can click on these buttons to quickly select the associated menu com-
mand. Toolbars also operate Outputs and display the state of Inputs. Toolbars
can be placed anywhere on your screen, and can be hidden if you do not use
them often or want the additional space for program windows. Toolbars are
revealed and hidden using the Toolbars command under the View Menu.

The toolbars include:

Standard Toolbar

Outputs Toolbar

Inputs Toolbar

Standard Toolbar

The Standard Toolbar provides quick-access buttons for the following commands:

Command: Used to:

New File Create a new program edit window

Open File Open an existing NC program file

Save File Save an NC program file

Cut Cut text from a program

Copy Copy text from a program

Paste Paste text into a program

Print Print an NC program

Help Access Help

Context Help This button can help you instantly find information
on the objects you see on the screen. For instance,
click on the Context Help button, then click on a
menu item, toolbar button, window or other screen
element. The Help file for that particular item appears.
Note that toolbars, windows, and panels must be
docked for Context Help to work.

Jog Control Panel Show or hide the Jog Control Panel

Note:
Context-sensitive means the results of
your action are dependent on the item
you click, or on the operation you are
currently performing.
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Operator Panel Show or hide the Operator Panel

Verify Clicking on this button performs the same opera-
tion as selecting the Verify command under the
Program Menu.

Run Run the current NC part program

Pause Pause the currently running NC part program

Stop Immediately halt the currently running NC program

Inputs Toolbar
The Inputs Toolbar isn’t really a toolbar in the sense that you can not use it
to interact with the various Control Program inputs. Actually, it is a moni-
toring device that keeps track of the state of the various system inputs.

The state of each input is indicated by the position of its button. If a button
is depressed, the input is “on” or “high.” If a button is not depressed, the in-
put is “off” or “low.” You can also check the condition of an input by click-
ing on it or by holding the mouse over the input button. The state of the in-
put is displayed on the Status Bar at the bottom of the screen.

The inputs on the Inputs Toolbar include:

u The Emergency Stop condition. This input is in the “on” condition
(depressed) if the Emergency Stop button on the Router is pushed in.

u The Enclosure Door condition. This input is in the “on” condition
(depressed) if the Enclosure Door on the Router is open.

u The Positive Limit condition. This input is in the “on” condition
(depressed) if one of the positive axis limits has been hit.

u The Negative Limit condition. This input is in the “on” condition
(depressed) if one of the negative axis limits has been hit.

u The Robot Input 1 condition. This input is in the “high” condition (de-
pressed) if the secondary robotic input on the TTL I/O connector on the
Controller Box is currently in a high state. Refer to Section K of this
manual for more information on robotic interfacing.

u The Robot Input 2 condition. This input is in the “high” condition
(depressed) if the robotic input on the TTL I/O connector on the Con-
troller Box is currently in a high state. Refer to Section K of this manual
for more information on robotic interfacing.
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Outputs Toolbar
The Outputs Toolbar provides quick-access buttons for controlling the
system outputs.

The state of each output is indicated by the position of its button. If a button is
depressed, the output is “on” or “high.” If a button is not depressed, the
output is “off” or “low.” You can also check the condition of an output by
holding the mouse over the output button. Clicking on the button will
change the state of the output. The name of the output is displayed in a tool
tip, and the state of the output is displayed on the Status Bar at the bottom
of the screen.

The output controls on the Outputs Toolbar include:

u The Spindle control. This button turns the spindle on and off.

u The ACC1 control. This button turns the Accessory 1 output on and off.

u The ACC2 control. This button turns the Accessory 2 output on and off.

u The Robot Output 1 control. This button toggles Robotic Output 1 be-
tween high and low conditions. When this button is depressed, it places
Robotic Output 1 (on the TTL I/O connector on the Controller Box) in
the “high” condition. When this button is not depressed, Robotic Output
1 is in the “low” condition. Refer to Section K of this manual for more
information on robotic interfacing.

u The Robot Output 2 control. This button toggles Robotic Output 2 be-
tween high and low conditions. When this button is depressed, it places
Robotic Output 2 (on the TTL I/O connector on the Controller Box) in
the “high” condition. When this button is not depressed, Robotic Output
2 is in the “low” condition. Refer to Section K of this manual for more
information on robotic interfacing.
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Panels
Use the Jog Control Panel and the Operator Panel to control router operation.

Jog Control Panel
The Jog Control Panel is accessed by selecting the Jog Control command
under the View Menu, or by clicking on the Jog Control button on the
Standard Toolbar. The Jog Control Panel allows you to manually move (jog)
the spindle on the router. You may also use the numeric keypad on the com-
puter keyboard to jog the machine.

Each axis on the machine is represented by buttons. The X and Y axes are
represented by the crosspad. The crosspad follows the Cartesian coordinate
system standard; -X to +X is left to right, while -Y to +Y is bottom to top.
The Z axis is represented by two buttons, one for positive motion and one
for negative. Pressing any of the axis buttons moves the tool in the indicated
direction, as long as the system is not in Simulate Mode.

Jogging occurs in specific increments of speed and distance. The speed and
distance values are selected on this panel as well. You can alter the speed and
distance parameters for jogging by selecting the Jog Settings command under
the Setup Menu, or by double clicking on the Jog Control Panel.

Tips:

� If you wish, you can move the Jog
Control Panel to another part of the
screen. Hold the Ctrl key down,
then click and drag the Jog Control
Panel. Once you release the Ctrl
key, the Jog Control Panel becomes
a floating window which you can
place anywhere on the screen.

� Double-clicking on the Jog Control
Panel opens the Jog Settings dialog
box.

To jog the router head:

1. Define the Speeds and Steps (distances) for jogging by selecting the Jog
Settings command under the Setup Menu.

2. Click on the Axis button on the Jog Keypad to move the tool in the de-
sired direction. The tool moves at the speed and distance indicated by
the Speed and Step buttons.

Step (Distance) Control

X Axis Control

Speed Control

Positive Z  Axis Control

Y Axis Control

Negative Z Axis Control
Continuous Feed Control

To move the tool in a continuous motion, select
Cont. The tool will continue to move as long as the
axis button is depressed.
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The Operator Panel controls include:

u Optional Skip, when on, allows you to execute or ignore any optional
skips ( / codes) you have embedded in the NC program.

u Optional Stop, when on, allows you to execute or ignore any optional
stops (M01 codes) you have embedded in the NC program.

u Single Step causes the NC program to pause after each block is ex-
ecuted. This allows you to check each step of the cutting operation.
Single Step is particularly useful after changing the workpiece size.

u Stop, when pressed, immediately halts the currently running NC pro-
gram. This button works the same as the Ctrl + Space Bar combination.

u Cycle Start begins running the current NC program from the beginning
or from a paused condition.

u Feedhold pauses the currently running NC program. To continue run-
ning the program from a Feedhold, press the Feedhold button again or
press the Cycle Start button.

u Feed Rate Override overrides the programmed feed rate.

u Spindle Speed Override overrides the programmed spindle speed.

Tip:
If you wish, you can move the
Operator Panel to another part of the
screen. Hold the Ctrl key down, then
click and drag the Operator Panel.
Once you release the Ctrl key, the
Operator Panel becomes a floating
window which you can place anywhere
on the screen.

Operator Panel
The Operator Panel provides controls that are used while running an NC
program on the router.

Optional Skip

Optional Stop

Single Step

Feed Rate Override

Stop

Cycle Start

Feedhold

Spindle Override
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Status Bar
The Status Bar displays miscellaneous information about the Router and the
computer. The left side of the Status Bar is reserved for operator messages
such as the one displayed here.

If any of the following are grayed-out, the feature is considered off.

u The Machine Homed state: Black if the machine is currently homed.

u The Caps Lock key state: Black if the Caps Lock feature is on. Some NC
programmers prefer to type their programs in capital letters. When the
Caps Lock feature is on anything you type will be displayed in capital
letters. Press the Shift key to type lower case letters.

u The Num Lock key state: Black if the Num Lock feature is on. Some
NC programmers prefer to use the numeric keypad on the keyboard  to
enter figures. The Num Lock feature must be on to do this.

u Current Line : Total Lines: Displays the line the cursor is currently on,
and the total number of lines in the program.

u The File Locking state: Black if the NC program file is locked.

u The File Modified state: Black if the NC program has been modified
since being opened.

u The Current Time (according to your computer).
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Menu Bar
The Menu Bar is located at the very top of the screen. It lists the categories
of commands into which the Control Program operations are grouped.

The available menus are:

u The File Menu

u The Edit Menu

u The View Menu

u The Program Menu

u The Tools Menu

u The Setup Menu

u The Window Menu

u The Help Menu

File Menu
The File Menu provides typical file management commands and the Exit
command.

Command: Used to:

New Create a new program window.

Open Open an existing file.

Close Close an open program window.

Save Save a program.

Save As Save a program under a different filename or location.

Print Print an open NC program.

Print Setup Set up your printer for printing.

Recently opened files Open one of the eight most recently used files.

Exit Exit the Control Program.

New Command
Use the New command under the File Menu to create a new program
edit window.

You can create a new program edit window at any time. The number of program
edit windows that you have open at one time is limited by the amount of
memory on your computer.
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To create a new program window, select New from the File Menu, or press
Ctrl+N.

A new program window is created. The filename on the Title Bar is “Untitled,”
indicating that this is a new program. The program will remain untitled until
you save it. You should save your new programs before they are run or verified.

Open Command
Use the Open command under the File Menu to open an existing NC program.
The number of program edit windows that you have open at one time is limited
by the amount of memory on your computer.

To open an existing NC program:

1. Select Open from the File Menu, or press Ctrl+O. The File Open dialog
box appears.

2. In the dialog box, locate and highlight the desired NC file.

3. Click OK or press Enter. The selected NC program file is opened. The
Title Bar displays the name of the file.

To select a file that is already open:

u If the open file has changed since it was opened, you are prompted to re-
load the original version of the file or to cancel the opening procedure.

u If the open file has not changed since it was opened, it becomes the ac-
tive Program Edit Window.

Close Command
You can close a program window that is not in use at any time. Unless you
have already done so, you will be prompted to save any changes made to the
program file.

To close a program window:

1. Make sure the program window you want to close is selected.

2. Select one of several ways to close the open window:

u Select the Close command from the File Menu.

u Single-click the icon on the far left of the Title Bar and select Close
from the drop-down menu. (If the Edit window is maximized, the
icon will be at the far left of the Menu Bar.)

u Double-click the icon on the far left of the Title Bar. (If the Edit
window is maximized, the icon will be at the far left of the Menu Bar.)

u Click on the Close button on the far right of the Title Bar. (If the Edit
window is maximized, the icon will be at the far right of the Menu Bar.)

u Press Ctrl+F4.

Note:
The title bar displays the name of the
NC program file. It is located across the
top of each Program Edit Window.
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3. If there are unsaved changes to the current program, the File Save dialog
box appears, prompting you to save the changes. Click one of the but-
tons in the dialog box:

u Click Yes to save the changes.

u Click No to discard the changes.

u Click Cancel to exit the dialog box without saving the changes or
closing the program window.

Save Command
Use the Save command under the File Menu to save the current program as
an NC file.

If the current NC program was previously saved, selecting Save saves the
changes to the same file. If the current program is new (and still has the
name “Untitled”), selecting Save brings up the Save As dialog box, in which
you name, choose a location for, and save the new program.

To save a program, select Save from the File menu, or press Ctrl+S. The current
program is saved to a file. If this is a new program, the Save File As dialog box
appears. Choose a name and location for the new file.

Save As ... Command
Use the Save As command under the File Menu to save the current program
to an NC file using a new name or location.

Save As Dialog Box

The Save As dialog box is the same in the Control Program as in other Win-
dows applications.

To use the Save As dialog box:

1. Select a destination for the file using the Save in:, Up one level and Cre-
ate new folder buttons.

2. Enter a filename in the File Name: field.

3. Select a file type in the Save as type: field.

4. Click OK or press Enter to save the file.

5. Click Cancel or press Esc to cancel and exit the dialog box.

Tip:
If you enable the AutoSave, your work
will be saved automatically at regular
intervals. Use of the AutoSave feature
is recommended; if AutoSave is not
enabled, you should save your files
frequently as you work.

Note:
When you name a file, consider
whether this file will be used on older
systems running DOS or Windows 3.1
before you take advantage of
Windows 95 or NT long file names.
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Print Command
Use the Print command under the File menu to print the current NC program.

To print the program:

1. There are several ways to print an NC program:

u Click the Print button on the toolbar.

u Select the Print command from the File Menu.

u Press Ctrl+P.

2. The Print dialog box appears. Choose the desired print options in the
dialog box. Clicking Setup opens the Print Setup dialog box.

3. Click OK to print, or click Cancel to exit the Print dialog box without
printing the NC program.

You can print to any printer that is supported by Windows. See your printer
manual or Windows documentation for more information on installing and using
printers with Windows.

Print Setup Command
Use the Print Setup command under the File Menu to select a printer. The
Print Setup dialog box allows you to establish parameters for printing your
NC part programs.

To choose print settings:

1. Select Print Setup from the File Menu. The Print Setup dialog box appears.

2. Select the desired print settings, including:

u The destination printer.

u The size of the paper.

u The paper tray.

u The orientation of the paper.

3. Click OK to print, or click Cancel to exit the Print dialog box without
setting the printing parameters.
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Opening a Recent Program
You can use the numeric (1, 2, 3, … 8) commands under the File menu to
open any of the eight most recently opened files.

The names and paths of the eight most recent files appear as file 1 (the file
last opened) through file 8 (the eighth most recent).

To open one of the eight most recently opened programs, select 1, 2, 3, 4, 5,
6, 7 or 8 from the File menu. The recent program you selected is opened.
The Title Bar displays the name of the program file.

Exit Command
Use the Exit command under the File Menu to exit the Control Program.
You should always exit the Control Program before you exit Windows.

To exit the Control Program:

Select the Exit command from the File Menu.

u Single-click the icon on the far left of the Control Program Title Bar. Se-
lect Close from the drop-down menu.

u Double-click the icon on the far left of the Control Program Title Bar.

u Click on the Close button on the far right of the Title Bar.

u Press Alt+F4.

If there are unsaved changes to any program window, a dialog box appears
for each unsaved program window, prompting you to save the changes.

u Click Yes to save the changes and exit.

u Click No to ignore the changes and exit.

u Click Cancel or press Esc to cancel the Exit command and return to the
Control Program.
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Edit Menu
The Edit Menu provides typical text editing commands. Before you can edit
the text in an NC program, you must select it.

Command: Used to:

Undo Undo the most recent editing command.

Redo Redoes the last Undo editing command.

Cut Cut selected text to the Windows clipboard.

Copy Copy selected text to the Windows clipboard.

Paste Paste text from the Windows clipboard into the
current NC program.

Clear Delete selected text.

Delete Line Delete the line the cursor is currently on.

Find Locate a sequence of characters in an NC program.

Replace Replace one sequence of characters with another,
one or more times.

Goto Line Jump to a particular line in the NC program.

Renumber Modify or insert N codes in an NC program.

Lock Lock or unlock the Program Edit Window to pre-
vent or allow modification to the NC program.

Select Font Change the font currently being used.

Undo Command
The Undo command reverses the most recent editing action taken. It is use-
ful for recovering from accidental deletion or inclusion of a block of text.

To undo the last change select Undo from the Edit menu, or press Ctrl+Z.

u If your last editing action was to delete selected text, the text is restored.

u If your last editing action was to delete a character, the character is restored.

u If your last editing action was to paste text, the text is removed.

u If your last editing action was to type a character, the character is removed.

u If Undo is grayed-out in the Edit menu, no changes can be undone.
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Redo Command
The Redo command redoes the edit command performed before the undo
command. For example, if you deleted a part of the text, and then decided to
undo that deletion, the Redo command performs the original delete again.

Cut Command
Use the Cut command under the Edit Menu to remove text from the NC
program (the text is copied to the Windows clipboard). The text can then be
pasted anywhere in the current program, into another program, or into another
application such as Notepad. The text remains in the Windows clipboard until it
is replaced by another Cut or Copy operation.

To cut text to the Clipboard:

1. Select the text you wish to cut.

2. Select Cut from the Edit Menu, or press Ctrl+X.

Copy Command
Use the Copy command under the Edit Menu to duplicate selected text in
an NC program.

To copy text to the Clipboard:

1. Select the text you wish to copy.

2. Select Copy from the Edit Menu, or press Ctrl+C. The selected text is
copied to the Clipboard.

Paste Command
You can use the Paste command to insert text from the Windows clipboard
into your NC program.

To paste text from the Clipboard:

1. Place the cursor at the point in the NC program where you wish to insert
text that has been previously cut or copied to the Windows clipboard.

2. Select Paste from the Edit menu, or press Ctrl+V. The contents of the
clipboard are inserted into the program. If this menu command is
grayed-out, there is no text on the clipboard to paste.

Selecting Text

Use  the mouse or a Shift+Arrow key
combination to select a portion of your
NC program for cutting, pasting, or
copying.

To select text using the editing keys:

1. Using the arrow keys, position the
cursor at the beginning of the text
to be selected.

2. Press the shift key and hold it
down while using the arrow keys
to move the cursor to the end of
the text to be selected.

3. Release the shift key.

To select text using the mouse:

1. Place the cursor at the beginning
of the text to be selected.

2. Click and hold the left mouse
button.

3. Move the cursor to the other end
of the text to be selected.

4. Release the mouse button.
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Clear Command
Use the Clear command under the Edit Menu to delete selected text from
your NC program. The text is not copied to the Windows clipboard. You
can also use the Delete key on your keyboard to achieve the same effect.

To delete text using the Clear command:

1. Select the text you wish to delete.

2. Select the Clear command from the Edit menu. The selected text is deleted.

Delete Line Command
Use the Delete Line command under the Edit Menu to delete an entire line
of NC code from a program without selecting it first.

To delete a program line using the Delete Line command:

1. Place the cursor anywhere on the line of code you wish to delete.

2. Select the Delete Line command from the Edit Menu, or press F2. The
line of code is deleted.

Find Command
Use the Find command under the Edit Menu to locate a particular sequence
of characters within an NC program.

To use the Find command:

1. Select Find from the Edit Menu, or press Ctrl+F.

2. Enter the character sequence you are looking for in the Find: box.

3. Check off the Match Case box to restrict the search to finding only
those text strings that match the case (upper or lower) of the text that
you entered.

4. Select Up or Down from the Direction box to search through the text
before or after the cursor position, respectively.

5. Click Find Next or press Alt+S to begin the search. Click Cancel or
press ESC to exit the Find dialog box without performing the search.

To find the same character string again, use the Find Next button.
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Replace Command
Use the Replace command under the Edit Menu to replace an existing char-
acter string with a new character string.

To use the Replace command:

1. Select Replace from the Edit menu.

2. Enter the existing character string in the Find What: box.

3. Enter the new character string in the Replace With: box.

4. If you select Match whole word only the program will only find and re-
place text that matches your entry. When you select Match case, it will
find and replace those text strings that match the case (upper or lower)
of the text you entered.

5. Select one of the buttons depending on how you wish to replace text.

u Find Next will find the next occurrence of the text.

u Replace will replace the selected text with the new text.

u Replace All will replace all occurrences of the text with the new text.

u Close will close the dialog box.

Goto Line Command
Use the Goto Line command under the Edit Menu to move the cursor to a
specific line in the NC program. This command is also available using the
Program Edit Window Pop-up Menu.

To use the Goto Line command:

1. Select Goto Line from the Edit
Menu, or press Ctrl+G. The Goto
Line dialog box appears.

2. Enter a line number in the Jump
To Line box and click on OK. The
cursor moves to the specified line.
If the line number entered is larger than the number of lines in the pro-
gram, the cursor moves to the end of the program.
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Renumber Command
Use the Renumber command under the Edit Menu to alter the N codes in
your NC program.

The Renumber command can be
used to:

u Insert N codes in a program that
doesn’t have any.

u Remove N codes from a program.

u Renumber N codes in a program.

u Insert, remove or ignore spaces
between NC commands.

u Remove comments from the program.

Insert N Codes
To insert or renumber the N codes in your program:

1. Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

2. Select Renumber N Codes or press Alt+N.

3. Click on the Start N Code box (or press Alt+T), then enter the number
of the first N code. The default starting block number is N1.

4. Click on the Increment box (or press Alt+I), then enter the increment
you wish to use.

For instance, if you wish to have each N code numbered in increments
of 5, enter 5 in the Start N Code box and enter 5 in the Increment box.
The N code sequence will then be: N5, N10, N15, N20…and so on.

This option is useful if you are renumbering a portion of the program to be
inserted into another program. Using increments greater than 1 allows you
to insert additional numbered lines without having to renumber the whole
program.

5. Select Do It, or press Alt+O, to execute the Renumbering options you
selected. Select Cancel, press Alt+C, or press Esc, to exit the Renumber/
Format Program dialog box without altering the NC program.

Note:
The number of a line in a program and
the number of the corresponding N-
code are only the same if the first N
code in the program is N1 and each N
code thereafter is incremented by 1.
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Note:
The Undo command will not undo the
effects of the Renumber command.
Removed comments must be re-
entered manually. You should save a
copy of the program to another file
using the Save As so you can easily
recover if the effects of using
Renumber are not what you expected.

Renumbering and Subprograms

Although the Renumber command automatically changes P codes used
with (M99) codes, it does not renumber P codes used with M98 codes, nor
does it renumber O codes. Although O codes are not altered, the lines
which they occupy are counted. So, the very next N code is numbered as
though the O code has been renumbered, too.

For instance, N41X
N42X…
O25G…
N44…

In this example, although the O code has not been renumbered, the line it
resides on has been counted. The N code on the following line reflects the
next number in the sequence.

Insert or Remove Spaces
To insert or remove spaces between the NC words in your program:

1. Select Renumber from the Edit Menu. The Renumber/Format Pro-
gram dialog box appears.

2. Choose a Spaces option.

u Insert Spaces inserts a space between each NC word (to the left of
the comment code).

u Remove Spaces removes any spaces between NC words (to the left
of the comment code).

u Ignore Spaces ignores any spaces in the NC program.

3. Select Do It, or press Alt+O, to execute the Spaces options you selected.
Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format
Program dialog box without altering the NC program.
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Remove Comments
To remove comments from your program:

1. Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

2. Select Remove Comments.

3. Select Do It, or press Alt+O, to execute the Remove Comments command.
Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format
Program dialog box without altering the NC program.

Remove N Codes
To remove the N codes from your program:

1. Select Renumber from the Edit Menu. The Renumber/Format Program
dialog box appears.

2. Select Remove N Codes or press Alt+R.

3. Select Do It, or press Alt+O, to execute the Remove N Codes command.
Select Cancel, press Alt+C, or press Esc, to exit the Renumber/Format
Program dialog box without altering the NC program.

Lock Command
Use the Lock command under the Edit Menu to prevent or allow changes to
your NC programs. If a check mark appears next to this command, the current
NC program is locked.

When an NC program is unlocked, it can be modified by the commands on the
Edit Menu. When an NC program is locked, the program cannot be changed by
any commands. By default, when you open a file it is automatically locked to
prevent accidental changes. You can change this in the Preferences dialog box.

If you have multiple program edit windows open, each is individually locked
or unlocked. The state of the currently selected NC program can be easily
checked by looking at the Lock Indicator on the Status Bar, or by the color
of the edit window background. Locked files have a gray background.

To use the Lock command to lock or unlock your NC program, select Lock
from the Edit Menu, press Ctrl+L, or double-click the Lock Indicator on
the Status Bar.

Note:
The Undo command will not undo the
effects of the Remove Comments
command. Removed comments must
be re-entered manually. You should
save a copy of the program to another
file using the Save As so that you can
easily recover if the effects of using
Renumber are not what you expected.

IMPORTANT

None of the Renumber actions
can be undone!
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Note:
The Undo command does not undo a
font settings change.

Select Font Command
Use the Select Font command under the Edit Menu to change the font set-
tings for open NC programs. Font Settings are intended for viewing and
printing purposes only. They do not affect the NC program in any way and
are not stored within the program file. All open program windows use the
same font settings.

To use the Select Font command:

1. Select the Select Font command from the Edit Menu.

2. Select a font from the Font list.

3. Select a font size from the Size list.

4. Click OK to change the font, or click Cancel or press Esc to exit the
Font dialog box without changing the fonts.

Font Settings
The font settings control the font and font size used in the program edit
window. The fonts listed are the fonts already installed on your system.

View Menu
The View Menu commands control the display of windows and toolbars.

Command: Used to:

Position Open or close the Machine Position Window.

Machine Info Open or close the Machine Info Window.

Jog Control Open or close the Jog Control Panel.

Operator Panel Open or close the Operator Panel.

Verify Window Open or close the Verify Window.

Toolbars Open or close one of the toolbars.

Position Command
Use the Position command on the View Menu to open or close the Position Window.

To open or close the Position window, select Position from the View Menu.
A check mark appears next to the Position command when the Position
Window is open.
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Machine Info Command
Use the Machine Info command on the View Menu to open or close the
Machine Info window.

To open or close the Machine Info window, select Machine Info from the
View Menu. A check mark appears next to the Machine Info command
when the Machine Info Window is open.

Jog Control Command
Use the Jog Control command on the View Menu to open or close the Jog Con-
trol Panel. You can also use the Jog Control button on the Standard Toolbar.

To open or close the Jog Control window, select Jog Control from the View
Menu. A check mark appears next to the Jog Control command when the
Jog Control Panel is open.

Operator Panel Command
Use the Operator Panel command on the View Menu to open or close the
Operator Panel.

To open or close the Operator Panel, select Operator Panel from the View
Menu. A check mark appears next to the Operator Panel command when
the Operator Panel is open.

Verify Window Command
Use the Verify Window command on the View Menu to open or close the
Verify Window.

To open or close the Verify Window, select Verify Window from the View
Menu. A check mark appears next to the Verify Window command when
the Verify Window is open.

Toolbars Command
Use the Toolbars command on the View Menu to show or hide the Toolbars.

To show or hide a toolbar:

1. Select Toolbars from the View Menu. The list of available toolbars is
displayed. Toolbars that are visible have a check mark beside them.

2. Select the toolbar that you wish to show or hide.
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Program Menu
The Program Menu commands allow you to Run, Verify, or Stop an NC
program.

Command: Used to:

Run/Continue Start running or resume running the current NC
program.

Verify Verify the current NC program.

Estimate Runtime Estimate the runtime of the current NC program.

Pause Pause the currently running NC program.

Feedhold Stop movement of all axes.

Stop Immediately halt the currently running NC program.

Run/Continue Command
The Run/Continue command under the Program Menu runs the current
NC program on the Router. When you select Run/Continue from the Pro-
gram Menu, the Run Program dialog box appears.

The Run Program dialog box allows you to select an NC program to run, to
set the line from which to begin running the program, and to access the Run
Settings and Verify Settings dialog boxes.

1. Select an NC Program.

If you have more than one NC program open, use the Program drop-
down list, or press Alt+P, to select the program you wish to run.

2. Select a starting line.

When you are running an NC program for the first time, it is wise to
start the program from the first line. When you start at a line other than
one, the control program parses through the program to the specified
start point. As it parses, it performs operations such as turning the
spindle on, but it will not execute a Dwell or Pause command, and it
will not move the tool.
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CAUTION

Always wear safety glasses and
close the safety shield before
running an NC program on the
router. Always observe set up
and safety precautions.

To specify a starting line, click on the Start at Line box, or press Alt+L,
and enter the line number.

3. Set the Run Settings

To bring up the Run Settings dialog box click on the Run Settings but-
ton, or press Alt+U.

4. Set the Verification Settings

To bring up the Verify Settings dialog box click on the Verify Set-
tings button, or press Alt+E.

5. Run the Program

To start running the program, click on the Run Program button, or
press Alt+R. To cancel running the program, click on the Cancel but-
ton, or press Esc.

While a program is running, the Machine Info Window and the Message
Bar keep you informed by providing information on:

u The name of the NC program.

u Which block is currently being executed.

u How many blocks are in the program.

u Which tool is being used.

u The number of passes made.

u The tool diameter.

u The spindle speed.

u Operator messages such as which block paused the program or the error
that caused the program to stop.

Verify Command
The Verify command allows you to view tool path verifications of your NC
programs. When you select Verify from the Program Menu, the Verify Pro-
gram dialog box appears.

Note:
If you are verifying a part program for
the first time, you should begin the
verification at line one.



E-28 Reference Guide: Section E

Note:
The Calculated Distance is the total
distance that the tool and the
workpiece move in relation to each
other. Every linear and rapid motion
(no arcs) has a length (length=Sqrt
(dx*dx+dy*dy+dz*dz). These
lengths are added together, yielding
the total distance. The feed rate of
each segment is divided into the length
to calculate the �ideal� time for each
segment (assuming zero-
communications overhead and infinite
acceleration and deceleration). These
times are added together to yield the
total estimated time.

This dialog box allows you to select a program to verify from a pull-down list
of currently open NC part programs. Prior to verifying the part program,
you may wish to alter the Run Settings, alter the Verification Settings, or se-
lect a starting line in the program. The default starting line is line one.

Begin the verification by pressing the Verify Program button. If the Verify
Window is not already open, it will open automatically.

Tool path verification is displayed in the Verify Window. The workpiece and
tool are displayed according to the choices you made in the Verify Settings
dialog box.

Estimate Runtime Command
Use the Estimate Runtime command to calculate the approximate amount of
time the router requires to run your program, and the approximate distance the
machine travels while running.

The Estimate Runtime command accounts for Dwell times and subprograms
when calculating estimated run time, but it can not account for stops that
have indefinite length of stop time. These program stops include:

u Pause (G05/M00)

u Chain (M20)

u Skip (G31)

u Wait for input high/low (G25/G26)

u Write to file (M22)

u Rerun (M47)

The Estimate Runtime command treats M47 Rewind codes as M2 End of
Program codes.

This command also verifies the syntax of your NC programs while calculat-
ing the estimated run time. If an error is found, the Estimate Run Time
command alerts you with a dialog box, and places the cursor near the error.
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Pause Command
Use the Pause command to pause a running NC program. Pause may also be
used during tool path verification. The pause is not immediate; it takes effect
after the current NC block has been executed.

To use the Pause command, select Pause from the Program menu, or click
the Pause button on the Standard Toolbar.

To resume running a program after a Pause, press F5, click the Run button
on the Standard Toolbar, or click the Go button on the Message Bar.

Feedhold Command
The Feedhold command is very similar to the Pause command. It is used to pause a
running NC program. The differences between a Pause and a Feedhold are:

u A Feedhold pause the NC program immediately; it does not wait until
the current block is executed.

u Feedhold does not work during tool path verification.

To use the Feedhold command, select Feedhold from the Program menu.

To resume running a program after a Feedhold, press F5, click the Run but-
ton on the Standard Toolbar, or click the Go button on the Message Bar.

Stop Command
You can use the Stop command under the Setup Menu to halt a running NC
program. The Router immediately halts cutting and the current tool position
is stored by the computer.

To use the Stop command:

1. Select Stop from the Program Menu, press Ctrl+Space, or click the Stop
(red) button on the Standard Toolbar.

2. A message box appears. Clear the box by clicking OK or pressing Enter.
You are automatically returned to the Edit mode.

To restart a program after a Stop performed through the Control Program:

1. Manually jog the tool so it is above the workpiece to avoid a tool crash.

2. Select the Run/Continue command to restart the NC program. You will
not have to reset the initial tool position (assuming the first block of
your program moves the tool to the start position).

Note:
An NC program can also be stopped by
pressing the Emergency Stop Button
on the front panel of the Router, or by
tripping a limit switch.
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Tools Menu
The Tools Menu commands allow you to select tools, set up and use a tool
library.

Command: Used to:

Setup Library Define tools used with the router.

Setup Tool Wizard Aid in establishing tool lengths for use with mul-
tiple tool programs.

Select Tool Select a tool for use on the router.

Setup Library Command
Use the Setup Library command under the Tools Menu to assign parameters
to multiple types of tools used on the router. When you select the Setup Li-
brary command, the Setup Tool Library dialog box appears.

You can create a new tool two ways:

u Use the Copy and Paste buttons to copy an existing tool in the Tool Library
box and paste it into the Tool Library box under an unassigned tool num-
ber. Assigned tool numbers are displayed with a tool icon. Unassigned tool
numbers have no tool icon.

u Manually create a tool using the features available in the Setup Tool Library
dialog box.
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To create a new tool:

1. Select an unassigned tool number from the Tool Library list.

2. Select a tool type, such as End Mill, from the Tool Type drop-down menu.

3. Enter a name for the tool in the Description field.

4. Enter the number of teeth (Num Teeth) on the tool.

5. Enter the Material Type from which the tool is made.

6. There is a secondary library for tool materials. You can use this library to
create new materials or edit existing materials. To do this, click on the
Edit Tool Materials button.

a) Enter a material Name.

b) Select a Material Class.

c) Enter a Multiplier. This should be set to “1” for now. This will be
used when integrating with CAM for calculating feed rates and
spindle speeds when generating tool paths.

d) Click on the Add button.

e) Click on the Delete button to remove tool materials you no longer need.

f) Press Enter or click on OK to accept the new material. Click on
Cancel to exit the Tool Material Type dialog box without changing
the material library.

7. Enter a tool Diameter.

8. Enter a tool Height/Offset value. You may also click on the Current Z
button to establish the current Z axis position of the tool as the
Height/Offset.

9. Enter a Diameter Offset. The Diameter Offset is the amount of devia-
tion from the actual cutter diameter to the programmed cutter diameter.
This parameter is very important when using tool diameter cutter com-
pensation. For example, a 0.125” diameter end mill may be specified for
a job. When loading tools, the diameter of the end mill may actually
measure 0.1248”. The deviation in diameter is the Diameter Offset.

10. Apply the new parameters to the selected tool number by clicking the
Apply button.

11. Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool library.
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To alter an existing tool:

1. Select an existing tool from the Tool Library list.

2. Make the desired changes to the tool parameters, then click on the
Apply button.

3. Press Enter or click on OK to accept the new tool information. Click on
Cancel to exit the Tool Library dialog box without changing the tool library.

Setup Tool Wizard Command
Use the Setup Tool Wizard as an aid in establishing tool heights for use with
multiple tool programs.

To use the Setup Tool Wizard:

1. Select Setup Tool Wizard from the Tools Menu. This starts the Wizard.

2. Follow the Wizard’s instructions very carefully!

Select Tool Command
Use the Select Tool command under the Tools Menu to select a tool for use
on the router.

To select a tool:

1. Select the Select Tool command from the Tools Menu. The Select Tool
for Use dialog box appears.

2. Select a tool from the drop-down Tool list. The tool parameters appear
in the window to the right of the list.

3. Select an action to exit the dialog box:

u Click Select Tool button if the tool is already in the mounted spindle.

u Click Insert Tool to perform a tool change cycle. The router moves
to its tool change position (maximum Z axis height) and you are
prompted to insert a tool into the spindle. After you insert the tool
and press F5, the router returns to its original position.

u Click Cancel to exit the Select Tool for Use dialog box without
selecting a tool.
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Setup Menu
The Setup Menu commands control the parameters for setting up tool posi-
tioning, jogging, running and verifying programs, coordinate systems, tool
offsets, etc.

Command: Used to:

Set Position Establish the X, Y and Z position of the tool.

Zero Position Set the current tool position to X0, Y0, Z0.

Jog Settings Establish speed and distance parameters for jogging
the tool.

Run Settings Establish options for running an NC part program.

Verify Settings Establish options for verifying an NC part program.

Verify Type Select centerline or solid view for tool path verifica-
tion.

Set/Check Home Establish or check a fixed known position on the
machine.

Goto Position Automatically move the tool to a specific set of co-
ordinates on the router.

Units Select Inch or Metric units of measure.

Coordinate Systems Define multiple coordinate systems or select a
new coordinate system.

Offsets Modify the table of Offset values used for certain
NC codes.

Spindle Specify a spindle speed if you have not used an S
code in your NC program.

Backlash Define the amount of play in the Router turning
screws.

Soft Limits Establish software limits for each axis that are dif-
ferent than the actual fixed hardware limits on the
router.

Preferences Establish defaults for saving files and security features.
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Set Position Command
Use the Set Position command under the Setup Menu to set new X, Y and Z
positions for the tool. This command establishes a Work Coordinate Sys-
tem in relationship to the Machine Coordinate System. Setting the X, Y and
Z coordinates for the tool also defines the zero point of the coordinate system
for absolute motion.

This command is also available under the Position Window Pop-up Menu.

To set a new position:

1. Move the tool to the desired position.

2. Select Set Position from the
Setup Menu.

3. Enter a new X position.

4. Enter a new Y position.

5. Enter a new Z position.

6. Press Enter or click on OK.

The new position is displayed in the Position Window.

Zero Position Command
Use the Zero Position command under the Setup Menu to reset the point of
origin (0,0,0) at any position on the router. Since the tool length and the
workpiece position on the cross slide may vary from one tooling set up to an-
other, the zero position must be initialized each time set up is changed.

This command is also available under the Position Window Pop-up Menu.

To set the zero point:

1. Move the tool to the point on the workpiece you intend to establish as
the zero point.

2. Select Zero Position from the Setup Menu. The new position (0,0,0) is
displayed in the Position Window.

Note:
This command sets the position of the
tip of the tool to the specified values. It
takes the tool�s defined height into
account.
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To set jog parameters:

1. Select Jog Settings from the Setup Menu.

2. Enter the desired jog speeds and distances.

3. Select OK or press Enter. The new values are applied to the Jog Control Panel.

Jog Speed

The jog speed is the rate at which the tool moves along the X, Y, or Z axes.
Select the speed by pressing the appropriate button. The speed can be Slow,
Medium or Fast.

Default Values for Speed

1 ipm for Slow
12 ipm for Medium
50 ipm for Fast
These feed rates can be set as high as 50 inches per minute.

Jog Distance (Steps)

Distance values determine how far the tool moves each time a key is pressed.
Referred to as Steps, the distance is selected by pressing the A, B or C buttons.
The distance can be set at a low value (for instance 0.0005 inch) to move the
tool for a precise cut, or at a high value (e.g. 0.5 inches) to position a tool.

Default Values for Steps

0.001 inch for Step A
0.01 inch for Step B
0.1 inch for Step C

Jog Settings Command
Use the Jog Settings command to enter speed and distance values for the Jog
Control Panel. This command is also available through the Jog Control
Panel Pop-up Menu.

Note:
Pressing the Continuous (Cont.) button
moves the tool continuously as long as
the axis button is depressed. Once the
axis button is released, the tool stops.
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Run Settings Command
Use the Run Settings dialog box to set or clear options for running your NC
program. The available options are:

u Single Step

u Optional Skip

u Optional Stop

u Enable Subprograms

u Arc Centers Incremental

u Treat Warnings as Errors

u Restore Unit Mode When Done

u Verify While Running

Single Step

This option inserts a Pause after each block of the NC program. To move on
to the next block in the program, you can:

u Click the Run button on the Standard Toolbar.

u Click the GO button on the Message Bar.

u Press F5.

u Press Enter.

u Select Run/Continue from the Program menu.

Optional Skip

Use this option to enable or disable the optional skip code. The optional skip
code allows you to skip blocks of code as the NC program is run.

Make sure to check off the Optional Skip box in the Run Settings dialog box
or activate the Optional Skip button on the Operator Panel. Then place a
forward slash ( / ) in front of each line in the NC program you want to skip.

With Optional Skip off, each skip code is ignored and each block of code is
executed. With Optional Skip on, each skip code is recognized and each
block of code that has been tagged with a skip code is skipped.

To execute particular blocks every nth pass, place a number after the op-
tional skip. For example:  /5G28; Home every fifth pass
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Optional Stop

This enables or disables the optional stop code (M01). The optional stop
code allows you to place an optional stop in your NC program. To activate
the optional stop, select the Optional Stop box in the Run Settings dialog
box or activate the Optional Stop button on the Operator Panel. Place an
M01 on the line of code where you would like to pause.

With the Optional Stop option on, the M01 works like an M00 or a G05.
With Optional Stop off, the M01 code is ignored, and the other codes on
the line are executed as usual.

Enable Subprograms

Use this option to enable or disable the use of subprograms. With this option
disabled, M98 commands generate an error. Running or verifying a program
with subprograms enabled takes longer to start because the software parses
the entire file for subprogram information. This extra delay should only be
noticeable with large programs.

Arc Centers Incremental

Use this checkbox to specify the default mode for programming arc centers. If
this box is checked, the default mode is the Fanuc mode, in which arc centers are
always incremental. If this box isn’t checked, the default mode is EIA-274,
in which arc centers follow the general programming mode: absolute when
the mode is absolute, and incremental when the mode is incremental.

Treat Warnings as Errors

This command is used for special applications where you don’t want any un-
expected pauses in the program execution. For example, a warning is displayed
and the program pauses, waiting for your input before it continues.

When this item is checked, any warning will halt the program, performing a
Program Stop. When motion is stopped, all outputs are turned off.

Restore Unit Mode When Done

If you normally work in one unit mode (inch or metric) but would like to
run a program in another mode without disrupting your default settings,
check this box.

Select a specific unit mode by using one of the G20/G21 or G70/G71
commands at the beginning of your NC program. Once the NC program is
executed, your default unit mode will be restored.

For instance, if you normally work in Inch Mode, but have a particular pro-
gram you would like to run in Metric Mode, check the Restore Unit Mode
When Done box. Place a G21 code at the beginning of your program, then
run it. When the program is finished, the default for your system will still be
Inch Mode.

Note:
The NC program itself can override the
default by placing the Incremental Arc
Centers (%) or Absolute Arc Centers
($) codes in the first line of the file.
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Verify While Running

If this box is checked, the Verify window will display the program verifica-
tion while the program is running. The verification does not show exactly
what is happening on the router. There is a delay between each tool motion.
You will see each tool motion on the screen, but the verification screen will
pause until the machine finishes the motion and the next program block is
read.

Verify Settings Command
Use the Verify Setup dialog box to control the appearance of the tool path
verification. You  can also access this dialog box using the Verify Window
Pop-up Menu.

The Verify Settings dialog box is tabbed, with the settings organized into
three panels: View Panel, Stock Panel and Options Panel.

View Panel

The View panel allows you to control the view style and zoom factor. It also
offers a selection of preset views.

Style

Use these radio buttons to select between Solid and Centerline views of the stock.
Solid View is a solid three-dimensional view of the workpiece and tool.
Centerline View is a view that depicts the centerline of the tool, instead of a
solid model of the tool. The workpiece is shown in wireframe.
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Zoom

Use these buttons to control the size of the stock in the Verify Window. You
can click on the buttons or use Alt key combinations (Alt++, Alt+-, and Alt+A).
Each mouse click or key combination used zooms by an increment of one.

Button Function

+ Zoom in on the stock.

- Zoom away from the stock.

All Fit the stock into the window.

Preset View

Use these buttons to select a perspective, then use the Preview Window to
fine-tune the angle:

Button Function

Front View the stock directly from the front. The stock
appears as a rectangle along the X, Z axes.

Top View the stock directly from above. The stock ap-
pears as a rectangle along the X, Y axes.

Isometric View the stock at an angle, in three dimensions.

Stock Panel

All stock values are interpreted according to the Units Mode in effect at the
time they are set. To quickly see which Units Mode is currently in effect, check
the Position window.

Stock Dimensions

Use this area to set the dimensions of the stock used in the verification
process. You will see the stock in the Preview Window change as soon as
you enter a dimension.

Origin

Use this area to adjust the verification for different workpiece setups. Most NC
programs set the 0,0,0 point at the top of the front-left corner of the stock. Occa-
sionally, however, you may want to use a different origin (the center of the stock,
for example). In this case, you must enter a different origin to properly verify
your program. The values entered should correspond to the coordinates of the
left corner of the stock relative to the 0,0,0 point for the program.

For instance, if the origin for the program is the center of a 3x2x1 piece of
stock, set the origin to -1.5, -1.0.
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Initial Tool Position

You can select a tool start point using Initial Tool Position. The Initial Tool
Position is only used for verification, not actually running a program. The
position is used when you verify a program; when verifying while running,
the actual position of the tool is used as the initial tool position.

Options Panel

The Verify Options control certain aspects of the solid and centerline
verification display.

Solid Options

Auto-refresh automatically refreshes the solid display of the workpiece if
something changes during verification, such as resizing the verify window,
changing the view, or changing the stock dimensions. When Auto-refresh is
disabled, you will need to manually cause the verify window to update by se-
lecting the Redraw command from the window’s context menu. This setting
only affects refreshing the window when no verification is in progress.

Centerline Options

Auto-refresh automatically refreshes the centerline display of the workpiece if
something changes during verification.

Show Tool controls whether or not the tool is displayed in the Verify Window.

Show Rapid Moves displays the rapid moves made between the end point of one
cut to the start point of another.

The Preview Window

The Preview Window appears in each of the above groups. The Preview
Window shows you approximately what the Verify Window will look like.
The Preview Window always depicts the stock in Centerline view.

In addition to depicting how the Verify Window will look, you can use the
preview box to change the orientation of the stock:

u Use the slider bars on the side of the Preview Window to rotate the stock
along the X, Y plane and along the Z plane. There are two ways to con-
trol the sliders:

1. Select the slider button by clicking on it with the mouse. Hold the
left mouse button down while sliding the button along the bar until
the stock is in the desired position.

2. Select the slider button by tabbing to it. The button will blink to in-
dicate it is selected. Use the arrow keys on the keyboard to move the
slider button along the bar until the stock is in the desired position.

u Use the mouse to rotate the stock in all planes simultaneously. “Grab”
the stock by clicking and holding it with the mouse. Move the stock
with the mouse until the stock is in the desired position.
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Buttons

The OK button at the bottom of the dialog box applies the changes you
have made and closes the dialog box.

The Cancel button closes the dialog box without applying any of the
changes you have made.

The Help button brings up the Help topic.

Verify Type Command
The Verify Type allows you to choose between a solid view and a centerline
view in the Verify Window.

Set/Check Home Command
Use the Set/Check Home command under the Setup Menu to establish or
check a fixed known position on the machine. This command is also avail-
able through the Jog Control Panel Pop-Up Menu.

Home

This option moves the router head to the ends of travel along each axis and
sets the Machine Coordinate System to X0, Y0, Z0.

Quick Home

This option is for homing when you have lost position slightly, or when you
start the machine at the beginning of the day and the machine hasn’t moved.
Using this option, the Control Program assumes that it is close to being
homed (that it knows approximately what the machine position is). The ma-
chine rapids to a short distance from the limits before homing; this is much
faster than feeding in at the normal slow rate. The Quick-Home feature is
useful for homing the machine after hitting a limit, or after pressing the
Emergency Stop while the machine is moving at a high speed.

Check Home

This option checks the reference point, identical to using a G27 code. It
compares the reported position against zero to see if any position has been lost.
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Goto Position Command
The Goto Position command opens the Goto Position dialog box. Use the
Goto Position dialog box to move the tool to a particular coordinate position
on the router.

This command is also available under the Position Window Pop-Up Menu
and Jog Control Panel Pop-up Menu.

To use the Goto Position command:

1. Enter the coordinates for the new
tool position.

2. Enter the feed rate at which you
would like the tool to travel.

3. Click on the Go button. The tool
moves to the new position at the
defined feed rate.

Units Command
Use the Units command under the Setup Menu to select the unit of measure for
the application. When you select the Units command, a fly-out menu appears al-
lowing you the option of using Inch (standard) or Metric measurement.

Coordinate Systems Command
Use the Coordinate Systems command under the Setup Menu to define multiple
coordinate systems for machining more than one workpiece. This is often
done for production runs of the same part.  This command is also available
under the Position Window Pop-up Menu. For an overview of Coordinate
Systems, see page H-27.

To select an existing coordinate system:

1. Select Coordinate Systems from the Setup Menu.

2. Select an existing coordinate system from the fly-out menu. The coordi-
nate systems available, CS1 through CS6, are equivalent to using the
codes G54 through G59 in your NC program.

3. OR select the Work Coordinates command to cancel the Coordinate
System offsets and return to Work Coordinates.

To define a new coordinate system:

1. Select Coordinate Systems from the Setup Menu.

2. Select Setup from the fly-out menu.

3. Select a coordinate system, then enter and apply the offsets.

Note:
If you would like the tool to travel at
the Rapid feed rate, click on the Go
Rapid button instead.
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a) Select a CS from the System box.

The system titled “Work CS” contains the current values for the
work coordinate system. This is like adding a G92 code to your NC
program. You can change the default for the work coordinate system
by entering new values in the Offsets boxes. These values are an off-
set from the true origin of a coordinate system and affect all coordi-
nate systems.

b) Select the offsets for a user coordinate system by:

u Entering X, Y and Z offset values in the Offsets boxes.

u Clicking the Current Pos button to establish offset values based
on the current tool position.

u Selecting a Marker in the Preview Area for the coordinate sys-
tem and dragging it to the desired position.

u Copying offsets from one CS to another using the Copy Offsets
and Paste Offsets buttons.

c) Make the currently selected CS the active CS by selecting the Make
Active button.

d) Apply the coordinates or exit the dialog box:

u The OK button applies the changes you have made and closes
the dialog box.

u The Cancel button closes the dialog box without applying any
of the changes you have made since clicking the Apply button.

u The Apply button applies the changes you have made to the
selected CS (you can still cancel changes once they have been
applied by selecting the Cancel button).

Important Note:

Machine coordinates are established by
Homing the system to establish a point
of origin at the ends of travel on the
Router. Once established, these
coordinates remain fixed. Each time
you turn on the router, the current
machine position is stored as the
machine coordinate system X0, Y0, Z0.

Work coordinates are different. When
you use the Set Position command to
set a point of origin on the workpiece,
you are actually entering a position
that is offset from the fixed machine
position. The same thing occurs when
you use a G92 code.

Work Coordinates are not fixed; they
can be established anywhere on the
system by using either the Set Position
command or the G92 code.

Within the Work Coordinates you can
set separate coordinate systems using
the codes G54 through G59, or the
Setup Coordinate Systems dialog box.

If you reset the Work Coordinates
either with a G92 code or in the dialog
box, the G54-G59 Coordinate System
offsets will change accordingly.

If you Home the machine while using
Coordinate systems, the offsets will not
be affected.
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To enter a compensation offset:

1. Select Offsets from the Setup Menu.

2. Click on an Offset Number (the numbers 1 through 199 are available).
This number only acts as a designation (a name) for the offset.

3. Enter an Offset Value in the Value box, or select the Current Z button
to use the current Z position ( also useful for defining tool heights if you
are using G43 or G44 to specify tool heights).

4. Press Enter or click on OK. The Offset Value has been associated with
the Offset Number. The next time you open the Offsets table, you will
see the new offset.

The Offset Table

The Offset Table stores up to 200 values which are used in several operations
including tool offset adjustment, cutter compensation, and tool length com-
pensation to ensure uniform application of an offset value. The numbers are
stored as unit-less values; their interpretation depends on the Units currently
in effect.

Set the values in the Offset Table using the Offsets command under the Setup
Menu. The Offsets are stored in the LMR.INI file when running with a ma-
chine, and in TESTCTL.INI when running in simulation mode.

Offsets Command
Use the Offsets command under the Setup Menu to compensate for varia-
tions in the cutting tools being used. The offset values are used for tool
length offset, cutter compensation, and tool offset adjustment NC codes. For
information on setting tool length offsets for multiple tool programming, see
the Tool Setup Wizard in this section.
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Also in this dialog box:

u Reset the spindle override value to 100% by clicking on the Reset Override
to 100% button.

u Change the On/Off state of the spindle using the On and Off buttons
in the Spindle State area.

u Disable spindle operation by selecting the Disable option. This is useful
if you have a device mounted in the spindle that cannot withstand being
rotated, such as a wired probe.

u Select Done to close the dialog box.

Spindle Command
Use the Spindle command under the Setup Menu to specify a spindle speed
if you have not used an S code in your NC program.

To specify a spindle speed:

1. Select the Spindle command from the Setup Menu. The Spindle Setup
dialog box appears.

2. Select a spindle speed by entering a value in the RPM box, or by using
the slider and arrow buttons.

Note:
This feature does not override an S
code in the NC program.
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Backlash Command
Use the Backlash command under the Setup Menu to define the amount of
play in the Router turning screws. The system default is set at a backlash
value of 0.0 on all three axes, with a feed rate of 10 ipm

To establish new backlash parameters:

1. Select Backlash from the Setup Menu.

2. Enter the desired backlash
distances and feed rate.

3. Press Enter or click on OK to accept
the new backlash parameters, or
click on Cancel to exit the Setup
Backlash dialog box without setting
new backlash parameters.

Soft Limits Command
Use the Soft Limits command under the Setup Menu to establish software
limits for each axis. The limits that are different than the actual fixed hard-
ware limits on the router. Soft limits can confine the tool travel to an area
smaller than the normal maximum travel.

The Router shuts down if it trips a soft limit, just as it does when it trips one
of the limit switches. This is helpful when working with devices such as ro-
bots, or when you have installed fixtures within the normal work area that
you don’t want the tool to hit.

To establish software limits on the router:

1. Select Soft Limits from the Setup
Menu.

2. Enter the coordinates that define
the software perimeter you wish to
establish.

3. Click on the Enable Soft Limits op-
tion to enable soft limits. Use this
option to turn soft limits on or off as
you need to use them.

4. Press Enter or click on OK to accept the new soft limit parameters, or
click on Cancel to exit the Setup Soft Limits dialog box without setting
new soft limit parameters.

IMPORTANT!

Soft limits are defined in
relation to the machine
coordinates; therefore, you
must home the Router before
using soft limits. Soft limits are
not enforced if the Router has
not been homed.

Note:
You should not specify too slow of a
backlash feed rate or you will notice
delays each time an axis with backlash
changes direction.

Note:
You must be within the Soft Limit
range in order to Enable the Soft
Limits.  If you are outside of the Soft
Limit range and Soft Limits are
enabled when you close the dialog
box, you will be instructed to jog the
machine to within the Soft Limits.
After you do so, you can open the Soft
Limits dialog box and enable them.
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Preferences Command
Use the Preferences command under the Setup Menu to establish defaults for
saving files and setting security features.

To alter the system preferences:

1. Select the Preferences command from the Setup Menu.

2. Select either the Editor preferences tab or the Security preferences tab.

Editor Preferences

The Editor preferences allow you to automatically save your NC program
files at regular intervals, and establish a default directory in which to store
your files. When you select the Editor tab in the Preferences dialog box, the
Editor panel appears.

To select AutoSave features:

u Select Save when idle and enter a value in the Every:___ minutes box to
save your NC programs automatically at the specified time increment.

u Select Save Before Running to save changes to your NC program prior
to running it for the first time with the changes.

u Select Prompt Before AutoSaving if you wish to be prompted by the
Control Program before it automatically saves the NC program at the
specified time increment.

To select File Default features:

u Enter an Extension for your NC part program files. The default is “NC.”

u Select Lock Files When Opened to have your NC programs locked by de-
fault. Deselect this feature to have your NC programs unlocked by default.

u Select the Set button to specify a target directory in which to save your
NC program files. The default directory appears in the Directory box.
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The Hilite Comments box will highlight comments in the NC program in a
different color.

The Quick Run/Verify by Default box suppresses the messages and dialog
boxes that appear asking for the file name and starting line when you run a
program.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on
Cancel to exit the Preferences dialog box without setting new Editor or
Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.

Security Preferences

The Security preferences allow you to control which features others may use.
When you select the Security tab in the Preferences dialog box, the Security
panel appears.

The Security preferences panel offers two modes, User and Administrator.
Administrator Mode allows a supervisor, such as a teacher in a classroom, to
turn commands on or off using the Allowed Commands list. User Mode
does not have access to this feature.

To secure the software using Administrator Mode:

1. Set the Default Mode to User. (This will not change the current mode.)

2. Use the Change Password button to create a password. The default
password is blank - no password.

3. Select the Allowed Commands. Double-click on the listed commands to
enable or disable them. If the commands are enabled, they are marked
with an X. A description of each selected command is displayed on the
right side of the panel.

4. Use the Change Mode button to change to User Mode.

5. Select OK or press Enter to exit the Preferences dialog box.

The software is now running in User Mode. The next time you open the
Preferences dialog box, the Security preference panel is displayed in User
Mode. In this mode it is not possible to turn commands on or off.

To return to Administrator Mode:

1. Use the Change Mode button to toggle the Mode from User to Admin-
istrator. A dialog box appears, prompting you to enter your password.

2. Enter your password and press Enter or click on OK.
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To change your password:

1. Click on the Change Password button.

2. Enter your current password.

3. Enter the new password.

4. Enter your new password again to verify that it is correct.

To exit the Preferences dialog box:

Press Enter or click on OK to accept the new preference settings, or click on
Cancel to exit the Preferences dialog box without setting new Editor or
Security preferences.

To access Help for this panel:

Select the Help button to access the Help files for this panel.

Window Menu
The Window Menu commands allow you to manipulate the arrangement of
the Program Edit Windows.

Command: Used to:

Cascade Layer the open edit windows.

Tile Tile the open edit windows.

Arrange Icons Arrange any minimized edit windows along the
bottom of the edit area.

Window List Display and select between the currently open NC
programs by their file names.

Cascade Command
Similar to the standard Windows/Cascade command. Places the open Pro-
gram Edit Windows in a layered format, cascading down to the right with
the currently selected window on top.

Tile Command
Similar to the standard Windows/Tile command. Places the open Program
Edit Windows in a tiled format, filling the Edit Area from top to bottom.

Arrange Icons Command
When you minimize a Program Edit Window, it becomes a small icon. The
Arrange command under the Window Menu arranges these icons along the
bottom of the edit area.
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Window List Command
Lists the currently open Program Edit Windows. The currently selected window
is designated with a check mark. You may select any window by clicking on the
window itself, or by selecting the window name from this list.

Help Menu
The Help Menu commands allow you to navigate through the Help files, to
save or restore parameters set throughout the current session, and provides
handy tips and other information about the Control Program.

Command: Used to:

Help Display Help for the current task or command.

Index List Help topics.

Using Help Display instructions about how to use Help.

Save Settings Saves the current machine and application settings.

Restore Settings Resets the machine and application settings from
defaults.

Tip of the Day Display a Tip of the Day.

About BenchRouter... Display program information, version number and
copyrights.

Help Command
Use the Help command to access the Help contents. You can also press the
F1 key to get information about the currently highlighted command on a
drop-down or pop-up menu.

Index Command
Use the Help Index command access an index of available Help topics.

Using Help Command
Use the Using Help command to obtain information on how to use the
Help utility.

Save Settings Command
The Save Settings command allows you to retain current library, security,
screen and control settings as defaults.
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u Click on a particular setting(s) to tag it, then click on the Save button to
save the selected items and exit the dialog box.

u Click on the Save All button to save all settings without having to select
each one.

u Click on the Cancel button to exit the Save Defaults dialog box without
changing the existing defaults.

Restore Settings Command
The Restore Settings command allows you to restore all or some of the cur-
rent settings to the defaults you set using the Save Settings command (User
Defaults) or to the factory set defaults.

u Click on a particular setting(s) to tag it, then click on a Restore From
option. Click the Restore button to restore the selected item(s) and exit
the dialog box.

u Click on the Restore All button to restore all settings without having to
select each one.

u Click on the Cancel button to exit the Restore Defaults dialog box with-
out changing the existing defaults.

Tip of the Day Command
This command brings up information about the operation of the router, tips
and tricks for using the Control Program and NC programming ideas.

About BenchRouter ... Command
This command simply brings up an information box. Included is informa-
tion on the Control Program version number, the release date, and copyright
information.
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Selecting Commands
There are a few different ways to select commands in the Control Program.
Use the method that is most convenient for you.

Select a Command Using Pop-Up Menus
Clicking the right mouse button on certain windows or panels brings up a
pop-up menu. Each pop-up menu is  context-sensitive. Commands which
cannot be performed at that time are grayed out.

To select a pop-up menu command:

1. Position the cursor on the window or panel.

2. Click and hold down the right mouse button. The context-sensitive
menu appears.

3. Highlight a command by moving the mouse pointer over it, then release
the right mouse button.

The following windows have pop-up menus:

u Program Edit Window

u Position Window

u Verify Window

u Jog Control Panel

The Machine Info Window and Operator Panel only provide the Dockable
and Hide commands on their Pop-up menus.

Program Edit Window Pop-up Menu
The Program Edit Window Pop-Up Menu contains different combinations
of the following commands, depending on whether the file is running or be-
ing verified, and whether or not text is selected.

Cut Command
Cut is the same as selecting the Cut command from the Edit Menu.

Copy Command
Copy is the same as selecting the Copy command from the Edit Menu.

Paste  Command
Paste is the same as selecting the Paste command from the Edit Menu.
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Clear Command
Clear is the same as selecting the Clear command from the Edit Menu.

Goto Line Command
Goto Line is the same as selecting the Goto Line command from the Edit Menu.

Renumber Command
The Renumber command is the same as selecting Renumber from the Edit menu.
A dialog box appears that allows you to alter the N codes in the NC program.

Save Command
Saves the current program.

QuickRun Command

The QuickRun command is a shortcut that runs the currently selected NC
part program. When you click the right mouse button on this command, the
program behaves as though you had selected the Run/Continue Command
from the Program Menu with the following exceptions:

u You do not have the option of selecting a starting line.

u You do not have the option of changing any settings.

QuickVerify Command

The QuickVerify command is a shortcut that verifies the currently selected
NC part program. When you click the right mouse button on this command,
the program behaves as though you had selected the Verify Command from
the Program Menu with the following exceptions:

u You do not have the option of selecting a starting line.

u You do not have the option of changing any settings.

Estimate Runtime

This command performs the same function as the Estimate Runtime command
under the Program Menu.

Position Window Pop-up Menu
The Position Window Pop-Up Menu contains these commands:

Inch Command

Automatically switches the units of measure for the application to inch units.

Metric Command

Automatically switches the units of measure for the application to metric units.
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Coordinate Systems Command

Produces a fly-out menu that allows you to set up and select coordinate systems.

Set Position Command

Opens the Set Position dialog box.

Zero Position Command

Sets the current tool position to zero on all axes.

Goto Command

Opens the Goto Position dialog box.

Dockable Command

The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

Hide Command

The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

Verify Window Pop-up Menu
The Verify Window Pop-Up Menu contains these commands:

Solid Command

Switches the verification to a solid view.

Centerline Command

Switches the verification to a centerline view.

Redraw Command

This command repeats the most recent tool path verification simulation.

Stop Redraw Command

This command will  interrupt a redraw currently in progress.

Reset Command

This command resets the Verify Window; it clears the tool path lines and re-
sets the tool to the starting position.
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Dockable Command

The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

Hide Command

The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

Jog Control Panel Pop-up Menu
The Jog Control Panel Pop-Up Menu contains these commands:

Setup Command

This command opens the Jog Settings dialog box.

Goto Command

This command opens the Goto Position dialog box.

Set/Check Home Command

This command opens Machine Home/Reference Point dialog box.

Dockable Command

The Dockable command toggles the window between being a dockable win-
dow and being undockable. See Docking and Floating Windows for more
information.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.

Hide Command

The Hide command closes the window. To open the window again, select it
from the View Menu.

This command is available on all pop-up menus for the windows and panels
available under the View Menu.
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Select a Command Using Hot Keys
Some menu commands have one or more key designations next to them;
those are the hot keys for that command. Pressing the hot key(s) selects the
corresponding command.

To select a command using hot key, press the hot key for the desired com-
mand. For example, press Ctrl+S to save your program. Here’s a list of the
available hot keys:

Key(s): Menu/Command:

Ctrl+C Edit Menu/Copy

Ctrl+F Edit Menu/Find

Ctrl+G Edit Menu/Goto Line

Ctrl+H Setup Menu/Set/Check Home

Ctrl+L Edit Menu/Lock

Ctrl+N File Menu/New

Ctrl+O File Menu/Open

Ctrl+P File Menu/Print

Ctrl+R Setup Menu/Run Settings

Ctrl+S File Menu/Save

Ctrl+Space Program Menu/Stop

Ctrl+T Tools Menu/Setup Library

Ctrl+V Edit Menu/Paste

Ctrl+X Edit Menu/Cut

Ctrl+Y Edit Menu/Redo

Ctrl+Z Edit Menu/Undo

Ctrl+Shift+Z Setup Menu/Zero Position

F1 Help Menu/Help

F2 Edit Menu/Delete line

F5 Program Menu/Run/Continue

F6 Program Menu/Verify

F8 Setup Menu/Goto Position

Ctrl+KeyPad+ Increase Feed rate Override

Ctrl+KeyPad- Decrease Feed rate Override

Ctrl+Backspace Edit Menu/Undo
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Shift+Delete Edit Menu/Cut

Shift+F1 Help Menu/Context Help

F4 Activate Jog Control

Ctrl+F5 QuickRun

Ctrl+F6 QuickVerify

Ctrl+TAB Next Edit Window

Ctrl+Insert Edit Menu/Copy

Shift+Insert Edit Menu/Paste

Pause Edit Menu/Pause

Select a Command Using Toolbars
The Tool Bars contain buttons that correspond to frequently used menu
commands. Clicking a button on a toolbar is equivalent to selecting the
same command from a menu, and is usually quicker. The Benchtop Router
Control Program provides Standard, Input, and Output toolbars. Use the
commands under the View Menu to control whether each tool bar is dis-
played or hidden.



E-58 Reference Guide: Section E

Positioning Screen Components
The Benchtop Router interface is easily configured and optimized by open-
ing, closing, resizing, and repositioning the screen components.

Positioning Toolbars
You can reposition any of the toolbars (Standard, Inputs, or Outputs) simply
by dragging them off their docking areas. Once away from the docking area,
the toolbar becomes a floating window, which can be treated the same as any
other window (e.g., move it, resize it, close it). To move the toolbar, click on
the toolbar background (the area around the buttons) and drag.

Positioning Information Areas
The information areas (Position, Machine Info, Jog Control, Operator Panel)
are initially docked on the docking area on the right side of the screen. If these
items are moved away from the docking area, they become floating windows or
panels until they are moved back to the docking area.

The Verify window is initially not dockable.

To move an information area (create a floating window):

1. Press the Ctrl key.

2. Click on the information area with the left mouse button.

3. Hold and drag the area off the docking area.

4. Release the Ctrl key.

5. When the floating window is over its new location, release the mouse button. You
can move and close the window as you would any other window.

To return a floating window to its docking area (the window must be dockable):

1. Click on the title bar of the floating window.

2. Drag the area back to the docking area.

3. Release the mouse button.

More information about dockable and undockable windows is provided in this
section.

Note:
The Docking Area is the gray portion
of the screen where toolbars, windows
and information areas are placed as
stationary objects.
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Positioning Program Edit Windows
Program Edit Windows can be moved, resized or closed just like any other
window. The only restriction is that the Edit Windows can not be moved
out of the edit area. For instance, you can not move an Edit Window to a
docking area.

Saving the Window Positions
After arranging the application’s windows on the screen, you can save their
positions. Use the Save Settings command on the Help menu to save the
window positions (and any other selected items). To restore your saved win-
dow positions, or to restore the default window positions (the factory preset
positions), use the Restore Settings command on the Help menu.

The Control Program automatically stores the current window positions when
you exit the software, and automatically restores them the next time you run it.
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Docking and Floating Windows and Toolbars
Windows and Toolbars can behave in two ways; they can be placed in a sta-
tionary state, docked, or they can be in a free-floating state, and moveable.

Docked Screen Components
A docked screen component is fixed in place, unlike a floating component
which can be placed anywhere on the screen. When a screen component is
docked, the window frame and title disappear.

Floating Screen Components
A floating screen component can be moved to any position on the screen,
unlike a docked screen component, which is fixed in place. When a screen
component is floating it has a window frame and title.

To select the Docking/Floating state of a toolbar:

u Click on the background area of the toolbar and drag it away to float it.

u Click on the background or the title bar of the toolbar and drag it to the docking
area to dock it.

To select the Docking/Floating state of a window:

1. Position the mouse pointer over the window you would like to dock/float.

2. Click the right mouse button.

3. Select Dockable from the drop-down menu.

When the Dockable command is checked, the window can be dragged to a
docking area and docked. Dockable windows can not be resized.

When the Dockable command is not checked, the window will float and can
not be docked. Some floating windows can be resized.



E-61Control Program Reference

The Setup Program
The Setup Program allows you to set program and hardware defaults. In order
to access the Setup Program, you must first exit the Benchtop Router pro-
gram. Locate the Benchtop Router folder on your hard drive, (default install
is in the C:\>Windows\Programs folder) and double click the Setup Icon. The
program will start and you will see the Welcome screen. You may choose
from the file tabs to view the defaults for each category.

The Setup Program provides defaults under the following categories:

u Welcome

u Interface Card

u General

Welcome Panel
This panel provides one option, Units Default. This option sets the default unit
of measure for the Control Program and the Setup Program. When running
the Control Software, you can change the default using the Units command
under the Setup Menu.
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Note:
Increasing the maximum number or
depth of subprograms requires slightly
more memory.  Unless you use NC
programs with complex subprograms,
you should not need to change these
values.

Interface Card Panel
This panel allows you to change the Interface Card Address. Once you have
installed the Interface Card and software, and performed the initial Setup,
this address should not change. The only time you might consider changing
the address is if there is a hardware conflict.

General Panel
This panel allows to you alter several software defaults.

u Run Offline starts the Control Program in Simulate Mode without
checking for a machine connection.

u Decimal Places for Inch Values controls the display of values in dialog
boxes. When in Metric mode, the software displays 1 less than the speci-
fied number of decimal places.

u NC Programming Settings controls several programming options:

u The maximum number of subprograms.

u The maximum depth of subprograms; the number of nested subprograms.

u The default L-factor; the angle at which a line segment approximates
a portion of an arc.

u The default feed rate; used when no feed rate is specified in the NC
program.
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Offset Table
The Offset Table stores 200 values which are used in several operations including
tool offset adjustment, cutter compensation, and tool length compensation to
ensure uniform application of an offset value. The numbers are stored as
unit-less values; their interpretation depends on the Unit mode currently in
effect. Offset zero is always 0.0 and cannot be modified. Using Offset zero
for most compensations cancels that compensation.

Set the values in the Offset Table using the Offset command under the
Setup Menu. The Offsets are stored separately for the machine, and for
Simulation Mode.

Working in Simulation Mode
Simulation mode is provided to allow the Control Program to be used when
your computer is not connected to the router. This is primarily to support the
off-line development of NC programs.

NC program verification and running is supported in Simulation Mode.
Programs will run in approximately the same amount of time that they
would if a machine were attached (excluding stops that have indefinite
length of stop time, see Estimate Runtime).

The principal difference between Simulation Mode and Normal Mode is,
since no machine is available to send and receive data, there are no Inputs
and Outputs. The Inputs and Outputs buttons on the toolbars are inoperable.
If your program contains commands to wait for certain input values that are
not the default, the events will never occur. If the values are the default, the
wait will occur immediately.

Note:
There are two Offset Tables, one for
Simulate Mode, and one for Normal
Mode. If your off-line NC program
development includes using values
from the offset table, you must ensure
that they are present in the Normal
Mode offset table in the same
positions as in the Simulation Mode
offset table.
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The Elements of an NC Part Program
Part programs generally incorporate two types of instructions: those which
define the tool path (such as X, Y and Z axis coordinates), and those which
specify machine operations (such as turning the spindle on or off). Each in-
struction is coded in a form the computer can understand.

An NC program is composed of blocks (lines) of code. The maximum number
of blocks per program is limited by the memory (RAM) on your computer.
You can, if necessary, chain programs together to form very large part programs.

Each block contains a string of words. An NC word is a code made up of an
alphabetic character (called an address character) and a number (called a pa-
rameter or value). There are many categories of address characters used in
NC part programs for the Benchtop Router (see Categories of NC Code).

Each block of NC code specifies the movement of the cutting tool on the
Machining Center and a variety of conditions that support it. For example, a
block of NC code might read:

N1G90G01X.5Y1.5Z0F1

If the machine is currently set for inch units, the individual words in this
block translate as:

N1 This is the block sequence number for the program. Block 1 is the
first block in the program.

G90 This indicates absolute coordinates are used to define tool position.

G01 This specifies linear interpolation.

X.5 This specifies the X axis destination position as 0.5".

Y1.5 This specifies the Y axis destination position as 1.5".

Z0 This specifies the Z axis destination position as 0". The cutting tool
will move to the absolute coordinate position (0.5,1.5,0).

F1 This specifies a feed rate of 1 inch per minute, the speed at which
the tool will advance to the specified coordinate points.
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Categories of NC Code
There are many categories of NC code used for programming the Benchtop
Router. Here is a list of the NC codes (designated by the address character) sup-
ported by the router.

Code: Function:

% Incremental Arc Centers (Fanuc).
$ Absolute Arc Centers (EIA-274).
\ Skip.
/ Optional skip.

D Compensation offset value.
F Feed rate in inches per minute; with G04, the number of seconds to

dwell.
G Preparatory codes.
H Input selection number; Tool length offset.
I Arc center, X axis dimension (circular interpolation).
J Arc center, Y axis dimension (circular interpolation).

K Arc center, Z axis dimension (circular interpolation).
L Loop counter; Program cycle (repeat) counter for blocks and subpro-

grams; homing tolerance, arc interpolation control.
M Miscellaneous codes.
N Block number (user reference only).
O Subprogram starting block number.
P Subprogram reference number (with M98 or M99); Uniform scale

multiplier (with G51).
Q Peck depth for pecking canned cycle.
R Arc radius for circular interpolation (with G02 or G03); Starting ref-

erence point for peck drilling (with canned cycle codes); Rotation
angle for coordinate rotation.

S Spindle speed.
T Tool specification.
U Incremental X motion dimension.
V Incremental Y motion dimension.

W Incremental Z motion dimension.
X X axis motion coordinate.
Y Y axis motion coordinate.
Z Z axis motion coordinate.
; Comments.
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Incremental Arc Center (%)
The incremental arc center code selects the Fanuc mode for programming
arc coordinates. This mode is selected for the entire NC program as well as
for any chained programs.

In the Fanuc mode, arc centers are always incremental, regardless of whether
the system is in G90 (absolute) or G91 (incremental) mode. In contrast, arc
center specifications in EIA-274 mode follow the selected programming
mode, absolute or incremental.

You can specify the default arc center mode in the Run Settings dialog box.

This character must stand alone on the first line of the NC program in
which it appears.

Absolute Arc Centers ($)
The absolute arc center code selects the EIA-274 mode of programming arc
coordinates. This mode is selected for the entire NC program as well as for
any chained programs.

In the EIA-274 mode, the mode of programming arc centers follows the selected
programming mode; absolute (G90) or incremental (G91). In contrast, arc cen-
ter specifications in Fanuc mode are always incremental, regardless of whether
the whether the system is in absolute or incremental mode.

You can specify the default arc center mode in the Run Settings dialog box.

This character must stand alone on the first line of the NC program in
which it appears.

Skip (\) and Optional Skip (/)
The Skip and Optional Skip codes allow you to skip particular lines of code
in your program.

To use the Skip code (\):

Place the code at the beginning of the line you wish to skip. When you run
the NC program, the specified line will be skipped.

To use Skip code (\) with a parameter:

Use the Skip code with a parameter to instruct the Control Program to ex-
ecute the line of code every nth pass. Place the code at the beginning of the
line you wish to skip.

Note:
The optional skip (/) code works only
when the Optional Skip parameter from
the Run Settings dialog box is on.
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The syntax is: \n, where n is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place \5
as the first code at the beginning of the block.

To use the Optional Skip code (/):

1. Place the code at the beginning of the line you wish to skip.

2.. Select the Optional Skip option from the Run Settings dialog box or the
Operator Panel.

When you run the NC program, the specified line will be skipped. If you do
not select the Optional Skip option in the Run Settings dialog box, the skip
code is ignored and the line is executed normally.

To use the Optional Skip code (/) with a parameter:

Use the Optional Skip code with a parameter to instruct the Control Program to
execute the line of code every nth pass. Place the code at the beginning of the
line you wish to optionally skip.

The syntax is: /n, where n is the number of passes between executions.

For example, if you want to execute a block of code every 5 passes, place /5
as the first code at the beginning of the block.

Compensation Offset Value (D Code)
The D code is used to select a value from the Control Program’s Offset
Table. For example, D1 selects entry number 1 from the Offset Table. Se-
lecting offset 0 (D0) cancels cutter compensation.

Use the D code with:

u Cutter compensation codes to specify the tool radius.

u Tool offset adjust codes to specify a consistent increase or decrease in the
commanded movement.

Use the Offsets command under the Setup Menu to view and manage the
Offsets Table.
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Feed Rate (F Code)
Use the F code to:

u Specify the rate of speed at which the tool moves (feed rate) in inches per
minute (ipm). For example, F3 equals 3 ipm.

The feed rate should be set to a low value (up to 50 ipm) for cutting op-
erations. Feed rate values are in millimeters per minute (mpm) when us-
ing metric units. The Control Program limits the programmed feed rate
so it doesn’t exceed the maximum allowed by the machining center.

u Specify the number of seconds to dwell when used with the G04 code.

Preparatory Codes (G Codes)
G codes take effect before a motion is specified. They contain information
such as the type of cut to be made, whether absolute or incremental dimen-
sioning is being used, whether to pause for operator intervention, and so on.

More than one G code from different groups can appear in each NC block.
However, you may not place more than one G code from the same group in
the same block.

The G codes supported by the Control Program fall into the following
groups:

u The Interpolation Group

u The Units Group

u The Plane Selection Group

u The Wait Group

u The Canned Cycle Group

u The Programming Mode Group

u The Preset Position Group

u The Compensation Functions Group

u The Coordinate System Group

u The Polar Programming Group
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The Interpolation Group
The Interpolation Group allows you to specify the type of motion for inter-
polation. These G codes are retained until superseded in the NC program by
another code from the Interpolation Group.

The supported interpolation G codes are:

G00 Rapid traverse
G01 Linear interpolation (default)
G02 Circular interpolation (clockwise)
G03 Circular interpolation (counterclockwise)

The Units Group
By default, an NC program is interpreted using the units of measure (inch or
metric) specified using the Units command on the Setup Menu.

The codes in the Units group, G70 (inch) and G71 (metric), are used to
override the Units command for the entire program.

If the code is placed at the beginning of the program before any tool motions
are made, that unit of measure is assumed for the entire program. Otherwise,
it affects the rest of the program following the code. You can use these codes
to switch between inch and metric modes throughout your program at your
convenience.

The Fanuc equivalents, G20 (inch) and G21 (metric), can also be used.

The Plane Selection Group
This group of codes allows you to select different planes for circular interpo-
lation. G17 is the Control Program default.

The supported Plane Selection Group codes are:

G17 Select the X,Y plane for circular interpolation. The arc center
coordinates are given by I for the X axis and J for the Y axis.

G18 Select the X,Z plane for circular interpolation. The arc center
coordinates are given by I for the X axis and K for the Z axis.

G19 Select the Y,Z plane for circular interpolation. The arc center
coordinates are given by J for the Y axis and K for the Z axis.
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The Wait Group
Wait Group codes apply only to the block in which they appear. The program
does not continue until the wait conditions are satisfied.

The supported Wait Group codes are:

G04 Dwell (wait): Pause between motions on all axes for the number of
seconds specified by the F code, then continue the program. Be-
cause the F code is used to specify the number of seconds, you can-
not also specify a new feed rate in the same block.
Example: G04F10;Wait for 10 seconds

G05 Pause: Used for operator intervention. Stop motion on all axes un-
til the operator manually resumes program execution using the
Run/Continue command.

G25 Wait until TTL input #1 (Robot 1 or user input 5) goes high before
executing the operations on this block. Used for robot synchroniza-
tion (see Section K  for more information). Use the H code to
specify an input other than the default, H5.

G26 Wait until TTL input #1 (Robot 1 or user input 5) goes low before
executing the operations on this block. Used for robot synchroniza-
tion (see Section K for more information). Use the H code to
specify an input other than the default, H5.

G31 Linear move to specified coordinate; used with H code to specify both
input number and the High or Low condition for stop (designated by
the operator input , + or -). The move occurs until an input is trig-
gered or until the specified end point is reached. The move stops short
if specified input goes High (if H is positive) or Low (if H is negative).
The default is input 5 (Robot 1) High.
You can have the control program go to a specified block (N Code
number) if the input meets the required condition. Use a P code to
specify the destination, as with the M99 code.
For example,  G31X5Y5H6P50000  instructs:
u Move (using the current programming mode) to the X5 and Y5.

u If input 6 (Robot 2) goes low during the move, stop the mo-
tion and  jump to block number 50000.

u If input 6 (Robot 2) doesn’t go low, complete the move and
continue with the next block in the program.

G35 Wait until TTL input #2 (Robot 2 or user input 6) goes high before
executing the operations on this block. Used for robot synchroniza-
tion (see Section K for more information).  This is the same as us-
ing the codes G25 H6.

G36 Wait until TTL input #2 (Robot 2 or user input 6)  goes low before
executing the operations on this block. Used for robot synchronization
(see Section K for more information).  This is the same as using the
codes G26 H6.
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The Canned Cycle Group
Canned cycle codes allow you to perform a number of tool motions by speci-
fying just one code. Canned Cycle codes are typically used for repetitive op-
erations to reduce the amount of data required in an NC program. Canned
cycle codes are retained until superseded in the program by another canned
cycle code.

The supported Canned Cycle codes are:

G80 Canned cycle cancel
G81 Canned cycle drilling
G82 Canned cycle straight drilling with dwell
G83 Canned cycle peck drilling
G85 Canned cycle boring
G86 Canned cycle boring with spindle off (dwell optional)
G89 Canned cycle boring with dwell
Refer to Section G  for more information on these functions.

The Programming Mode Group
Programming mode G codes select the programming mode, absolute (G90)
or incremental (G91). These codes remain in effect until superseded by each
other. The default code on program start up is G90.

With absolute programming, all X, Y and Z coordinates are relative to origin
of the current coordinate system. With incremental programming, each mo-
tion to a new coordinate is relative to the previous coordinate.

The supported Programming Mode codes are:

G90 Absolute programming mode
G91 Incremental programming mode

The Preset Position Group
The preset position G codes move the tool to a predetermined position, or
affect how future motions will be interpreted.

The supported Preset Position codes are:

G27 Check reference point: This code moves the machine to its home
position and compares the reported position against zero to see if
any position has been lost. The difference between the reported po-
sition and zero is compared to a tolerance value specified using the
Setup Program. Use the L code in this block to override the toler-
ance value from the Setup Program.

G28 Set reference point: This code moves the machine to its home position
and sets the machine position to 0,0,0. The G28 code performs an au-
tomatic calibration of the axes.
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G92 Set position: This code works like the Set Position command under
the Setup Menu. The X, Y and Z coordinates following a G92
code define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle  complete.
G99 Rapid move to point R (surface of material or other reference

point) after canned cycle complete.

The Compensation Functions Group
Use the cutter compensation NC codes to automatically compensate for the
variations in a cutting tool’s radius and length. Refer to Reference Guide:
Section H for more information on using cutter compensation.

The supported Compensation codes are:

G39 Corner offset circular interpolation.
G40 Cancel cutter compensation.
G41 Left cutter compensation: Enables cutter compensation to the left

of programmed tool path.
G42 Right cutter compensation: Enables cutter compensation to the

right of programmed tool path.
G43 Tool length offset: Shifts Z axis in a positive direction by a value in

the Offset Table, specified by an H code.
G44 Tool length offset: Shifts Z axis in a negative direction by a value

in the Offset Table, specified by an H code.
G45 Tool offset adjust: Increases the movement amount by the value

stored in the offset value memory.
G46 Tool offset adjust: Decreases the movement amount by the value

stored in the offset value memory.
G47 Tool offset adjust: Increases the movement amount by twice the

value stored in the offset value memory. Refer to the User’s Guide
for more information.

G48 Tool offset adjust: Decreases the movement amount by twice the
value stored in the offset value memory.

G49 Cancels tool length offset.
G50 Cancels scaling.
G51 Invokes scaling.
G68 Invokes rotation.
G69 Cancels rotation.
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The Coordinate System Group
Use the coordinate system codes to establish multiple coordinate systems on
one or more workpieces to create multiple parts.

For instance, you can run a part program using a typical coordinate system
(with the point of origin on the surface of the front left corner of the
workpiece), then select another coordinate system which has its origin at a
different point on the surface of the workpiece.

There are seven coordinate system codes. One of these codes (G53) is used to
rapid to specified machine coordinates. The other six codes allow you to
make up to six individual parts on the same workpiece by specifying different
work coordinate systems for each part.

The coordinate system codes are G54 through G59, referring to coordinate
systems 1 through 6 respectively. These coordinate systems may be set
through the Coordinate Systems command on the Setup Menu.

The Polar Programming Group
The polar programming codes allow you to perform polar programming op-
erations, based on polar coordinates. The polar coordinates are defined by X
(radius) and Y (angle in degrees) when programming for the X, Y plane. Re-
fer to Section H for more information on using polar programming.

The supported Polar Programming codes are:

G15 Polar programming ON
G16 Polar programming OFF
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Input Selection Number/Tool Length Offset (H Code)
The H code has multiple uses. It can be used to specify inputs, input state
changes, outputs, and  offset amounts.

H Code Inputs

H1 Emergency Stop
H2 Safety Shield
H3 +Limit
H4 -Limit
H5 Robot 1
H6 Robot 2

H Code Outputs

H1 Spindle
H2 Acc1
H3 Acc2
H4 Robot 1
H5 Robot 2

Use the H code in conjunction with:

u The wait codes G25 and G26, to specify the input number.  If the H code is
NOT used with these G codes, input 5 is assumed.

u The wait code G31, to specify input change to high or low. If the H code is
NOT used with this G code, input 5 High is assumed.

u The tool length offset codes G43 and G44, to specify the amount of Z axis
shift. The Offset Table you use for Tool Length Offset H values is the same
table you use for Cutter Compensation and Tool Offset Adjust D values.

u The transmit codes M25 and M26 for interfacing with robots or other exter-
nal devices, to specify the output number. If the H code is not used with
these M codes, output 4 (Robot 1)  is assumed.

X Axis Coordinate of Center Point (I Code)
In absolute programming mode (G90), the I code specifies the X axis coordi-
nate of the center point of an arc or circle when using circular interpolation.
In incremental mode (G91), the I code specifies the X axis distance from the
start point of motion to the center point of the arc for circular interpolation.
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If no I code is specified, the system uses the current X axis location as the X
axis center of the arc. If in Fanuc mode, all arc centers are incremental.

The I code is also used with the G51 code to specify the scale factor for the X axis
when performing scaling functions, including scaling each axis and mirror scal-
ing. Refer to Reference Guide: Section H for more information on using scaling.

Y Axis Coordinate of Center Point (J Code)
In absolute programming mode (G90), the J code specifies the Y axis coordinate
of the center point of an arc or circle when using circular interpolation. In incre-
mental mode (G91), the J code specifies the Y axis distance from the start point
of motion to the center point of the arc for circular interpolation.

If no J code is specified, the system uses the current Y axis location as the Y
axis center of the arc. If in Fanuc mode, all arc centers are incremental.

The J code is also used with the G51 code to specify the scale factor for the Y axis
when performing scaling functions, including scaling each axis and mirror scal-
ing. Refer to Reference Guide: Section H for more information on using scaling.

Z Axis Coordinate of Center Point (K Code)
In absolute programming mode (G90), the K code specifies the Z axis coordinate
of the center point of an arc or a circle when using circular interpolation. In in-
cremental mode (G91), the K code specifies the Z axis distance from the start
point of motion to the center point of the arc for circular interpolation.

If no K code is specified, the system uses the current Z axis location as the
center of the arc. If in Fanuc mode, all arc centers are incremental.

The K code is also used with the G51 code to specify the scale factor for the Z
axis when performing scaling functions, including scaling each axis and mirror
scaling. Refer to Reference Guide: Section H for more information on using scaling.

Angle of Arc Resolution, Loop Counter (L Code)
The L code specifies the angle of arc resolution in circular interpolation pro-
gramming. When the system executes a circular motion, it actually splits the
arc into a series of line segments to approximate the circle. The L code speci-
fies the angle in degrees which a line segment approximates a portion of the
arc. The smaller the angle, the smoother the cut. A negative value for L will
generate a normalized L factor (degrees x radius {in inches}) so larger radii have
smaller degree values. For example, with the default L factor of -1:
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u An arc with a radius of 1 inch will have line segments approximating ev-
ery 1 degree of the arc.

u An arc with a radius of .5 inches will have line segments approximating every 2
degrees of the arc (Degrees = -L/R, or Degrees = -(-1) / .5, which is 2).

u Note that the line segments generated by a normalized L code are always ap-
proximately the same length regardless of the arc’s radius (The length of the
arc segment being represented by each line segment is exactly the same).

The default setting for the Router is -1, and typically this will work quite
well. You may notice the Router hesitating on arcs if the resolution is too
fine. The L code can be a fraction of a degree (such as L.5), but it must be large
enough so the Router will move at least the minimum motion (.0005") on each
of the straight line motions.

Use the L code with:

u The M98 code as a loop counter for subprograms.

u The M47 code as a program cycle counter, to repeat a program a finite
number of times.

u The G27 code to specify tolerance with homing commands (this is an
LMC-specific NC language extension). The difference between the cur-
rent position and 0 is compared to a tolerance value specified using the
Setup Program; use the L code to override this tolerance value.

u An L code that is not used by one of these codes is used as an Arc Reso-
lution factor.

Miscellaneous Codes (M Codes)
M codes control a variety of Router functions while a part program is running.
Only one M code should be specified per NC block. M codes and motion
commands should be placed on separate blocks to avoid confusion over
whether an M code is activated during or after a motion command.

The supported M codes are:

M00 Pause: Allows you to place a pause in your code. Acts like a G05 pause.
M01 Optional Stop: Allows you to place an optional pause in your code.

Place an M01 in the block of code where you would like to pause.
There are switches to activate or deactivate the Optional Stop code in
the Run Settings  dialog box and on the Operator Panel.
With Optional Stop on, the M01 works like a G05 pause.
With Optional Stop off, the M01 code is ignored, and the other
codes on the block are executed as usual.
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M02 End of Program: Takes effect after all motion has stopped; turns
off drive motors, and all outputs, including the spindle and the ac-
cessory outlets.

M03 Spindle Motor On: Activated concurrently with motion specified
in the program block; remains in effect until superseded by M05.

M05 Spindle Motor Off: Activated after the motion specified in the pro-
gram block; remains in effect until superseded by M03.

M06 Tool Change: Pauses all operations, turns off spindle, retracts
spindle for tool change. If you are using an ATC, this performs the
complete tool change cycle.

M08 Accessory #1 On: Turns on ACC 1 accessory AC outlet concur-
rently with the motion specified in the program block; remains in
effect until superseded by M09. This is the same as using the M25
H2 codes.

M09 Accessory #1 Off: Turns off ACC 1 accessory AC outlet after the
motion specified in the program block is completed; remains in ef-
fect until superseded by M08. This is the same as using the M26
H2 codes.

M10 Accessory #2 On: Turns on ACC 2 accessory AC outlet concur-
rently with the motion specified in the program block; remains in
effect until superseded by M11. This is the same as using the M25
H3 codes.

M11 Accessory #2 Off: Turns off ACC 2 accessory AC outlet after the
motion specified in the program block is completed; remains in ef-
fect until superseded by M10. This is the same as using the M26
H2 codes.

M20 Chain to Next Program: This code is used to chain several NC
files together. It appears at the end of a part program and is fol-
lowed on the next line by the file name of another program which
is executed when all motion stops. Here’s an example of a part pro-
gram chain to another program:

N37 Z.2
N38 M20
PROGRAM2.NC; Chain to PROGRAM TWO

If the two programs you are chaining are not in the same directory
on your computer, you must specify the full path name for the
next program file. If the software cannot locate the specified file,
you will be prompted to find it.

M22 Output current position and other information to file.
M25 Set TTL output #1 (Robot 1 or Output 4) On: Used for robot

synchronization (see Section K for more information). Use the H
code to specify an output other than the default, H4.

M26 Set TTL output #1 (Robot 1 or Output 4) Off: Used for robot
synchronization (see Section K for more information). Use the H
code to specify an output other than the default, H4.

Note:
All M codes used to turn on a device,
such as the spindle, execute at the
beginning of the tool motion for that
block of NC code.

All M codes used to turn off a device
execute after the tool motion for that
block is completed.

To avoid confusion, it is sometimes
easier to place M codes in a separate
block from the motion commands.
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M30 End of program: Same as M02.
M35 Set TTL output #2 (Robot 2, or Output 5) On: Used for robot

synchronization (see Section K for more information).
M36 Set TTL output #2 (Robot 2, or Output 5) Off: Used for robot

synchronization (see Section K for more information).
M47 Rewind: Restarts the currently running program; takes effect after

all motion comes to a stop. Typically used with an L code to repeat
a program a set number of times.

M98 Call to subprogram. Use the P code to specify the subprogram
starting block number. Use the L code to specify the number of
times the subroutine is executed. You can nest subprogram calls to
a depth of 20.

M99 Return from Subprogram; Goto
M105 Operator Message (LMC)

M22: Output Current Position to File
The M22 code is used to write information to a file while a program is running.
Typically, this code is used when digitizing to write the current X, Y, and Z ma-
chine coordinates to a file. The proper format for using this code is:
M22(filename) Data to Write to File. The first time the Control Program en-
counters an M22 code, it opens the specified file. You must enclose the name of
the file in parentheses for the Control Program to recognize it. If you do not
specify any DataToWriteToFile text, the default data is output. This default is
the current position, equivalent to specifying ‘X@X Y@Y Z@Z’. Notice that the
@X,@Y,@Z ‘macros’ are replaced by the actual machine position when the data
is written. Each M22 code automatically adds a linefeed to the end of its output
so the next M22 starts on a new line.

If the file name is followed by “,A” (e.g., test.nc,A), the Control Program does
not delete previous information from the file, it appends the information to the
end of the existing information. If the file does not exist, it is created.

If you use more than one M22, only the first occurrence must have the file
name in the parentheses. The remaining M22’s may have empty parentheses,
( ), or may specify a different file.

If you want to generate more than one file at a time, you must include the
filename each time you specify M22. If a filename is not specified, the first
file opened is used.

Example:

. . .; code to move to position

; Open my1.xyz, discard contents, write coordinates

M22(my1.xyz)

. . . ; code to move to next position

; Append to currently open data file

M22( )

Note:
All text on the same block, after the
closing parenthesis, is output to the file,
with all valid macros being replaced as
it is written.
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. . . ; code to move to next position

;Open my2.xyz and append coordinates

M22(my2.xyz,A)

Information about digitizing is provided with the digitizing package. For ad-
ditional information, please call Light Machines Technical Support.

Special codes that can be used with M22 to generate run-time reports.

@X Current X position (in current coordinate system).
@Y Current Y position (in current coordinate system).
@Z Current Z position (in current coordinate system).
~ (tilde) New Line (starts a new line in the file).
@TD Time of Day (12hour)   “11:59:59AM”
@TC Time (elapsed) for cycle   “99:11:59” (0’s trimmed from left)
@TT Time Total (program run)   “99:11:59”
@TA Time Average (per cycle)   “99:11:59” (“??:??” if first part)
@TL Current Tool #.   “5”
@C Cycle # (Current Pass)   “3”
@D Date  “12/31/94”
@FN Current File (w/o path) “Part.NC” (“Untitled.NC” if untitled)
\t TAB
\\ Outputs a single ‘\’ character.
Example:

; Start of file

� ; Process a single part

; Output part time statistics to file c:\Reports\Stats.txt (c:\Reports direc-
tory must exist)

M22 (c:\Reports\Stats.txt,A) Part #@C processed in @TC.

M47 L50 ; We want to process 50 parts.

M99: Return from Subprogram, Goto
The M99 code has two specific uses; it can be used as a command to return
from a subprogram or it can be used as a goto command.

Using M99 with subprograms:

When used in a subprogram, this code returns you to the block following
the last M98 (Call to Subprogram) command. If the M98 used an L code to
specify multiple calls to the subprogram, the M99 will return to the block
containing the M98 until all the specified number of subprogram calls have
been made; then it will proceed to the block following the M98.

You can use the P code plus a block number to override the block returned
to; however, if this feature is used from a nested subprogram call, all return
targets are discarded. The rules for a Goto target block apply to this use as well.
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Using M99 as a Goto command:

This command can be used in the main NC program as a Goto command
to jump to a block on a line before the first subprogram (as denoted by the
O code).You may not jump to a block that is after the first subprogram.

Use the P code to identify the block number being jumped to. Control is
transferred to the first occurrence of this N code; it cannot be used to trans-
fer control between chained programs (see M20).

This command can be used anywhere in the program to change the flow of
program execution. It is good programming practice to place this command
on a line by itself to improve the program’s readability.

M105: Operator Message
This command is used to display messages in the Control Program. It pro-
vides a way to display messages to the operator on the message bar while an
NC program is running. You can also pause the program with a custom
message. This is a non-standard, Light Machines code.

By default, the message is centered, displayed as a Normal Message, and is
persistent (not cleared until the program clears it or until the next message is
displayed).

The correct format for using this code is:

M105(the message);comment

For instance, the following line of code displays a simple message:

M105(End of Roughing Segment);Normal Message; doesn�t pause

Messages can be altered by using the following alternate characters:

^ Displays the message and performs a pause requiring operator interven-
tion to continue.

~ Displays the message as a Warning Message.

\b Beeps when the message is shown.

The format for using the M105 code with an alternate character is:

M105(alternate character plus the message) ;comment

For example:

M105(~WARNING);Warning Message , doesn�t pause

Here are some other examples of how to use this code:

M105( ) ; clears current message
M105(^Please stop and read this!) ; Normal Message, pauses
M105(~^I MEAN IT!) ; Warning Message, pauses
M105(\b\b\b) ; Clears current message, beeps 3 times, and doesn�t pause
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Block Number (N Code)
N codes have two uses:

u To provide destinations for Gotos (M99) elsewhere in the program.

u To clearly show the organization of the code and improve readability.

Using the N code is optional; however, when you do use the N code, it must
be the first character in the block. Other than for the above stated uses, N
codes are ignored by the Control Program. Their presence, absence, or sequential
value does not affect the execution of the NC program in any way (unless the
target of a goto is missing).

You may have N codes on some blocks and not on others. N code sequence
numbers do not have to be in order, but regular sequential order does make it
easier to follow and reference sections of the program. The Control Program can
change the N codes in a program by inserting, removing, or renumbering them.

Subprogram Block Number (O Code)
The O code is used to indicate the start of a subprogram, and must be fol-
lowed by a number which identifies the subprogram. The O code replaces
the N code in the first block of the subprogram.

To call a subprogram, use the M98 code; use the P code to specify which
subprogram to execute. To return from the subprogram, use the M99 code.

Only the first block in the subprogram contains the O code. The remaining
blocks may contain N codes. The O and N code numbers may be used to help
identify and set apart the subprogram to improve readability, for example:

M98 P50000 ;call to first subprogram
�;after first subprogram is finished, M99 code returns to this point
�
M98 P60000 ;call to second subprogram
�;after second subprogram is finished, M99 code returns to this point
�
O50000 ;start of subprogram
N50010 ;first line of subprogram
N50020 ;second line of subprogram
N50030 M99 ; last line of subprogram
�
O60000 ;second subprogram
N60010 ;first line of second subprogram
N60020 ;second line of second subprogram
N60030 M99 ;last line of second subprogram
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Subprogram Reference Number (P Code)
Use the P code with:

u The G31 code to reference a goto target block.

u The G51 code to specify a uniform scaling factor.

u The M98 code to reference a subprogram using the subprogram block number.

u The M99 code to specify a return block number as a goto target.

Peck Depth (Q Code)
The Q code is used with the G83 code in canned cycle peck drilling to specify
the incremental depth of each peck.

Radius of Arc, Drilling Start Location (R Code)
As an alternative to specifying the center point of an arc (I Code, J Code, or
K Code) you can specify the arc radius. Use the same value for the radius in
both absolute and incremental programming modes.

G02 or G03 specifies the direction of motion.

Positive values for R (radius) are specified for arcs up to 180°. Negative val-
ues are used for arcs greater than 180°. Full circle arcs cannot be performed
with an R code. Spit the circle into two arcs, or use center point (I, J, and K)
values for full circles.

Use the R code in canned cycles to specify a Z axis reference point for peck
drilling. The point can be at the material surface or at another reference
point. The R code is also used to specify the rotation angle, in degrees, with
the G68 code.

Spindle Speed (S Code)
Use the S code to set the spindle speed from within the NC program. Spindle
speed is specified by the address character “S” followed by a parameter that repre-
sents the speed in RPMs. For example, S750 is the designation for a spindle
speed of 750 RPM. For the Scode to have an affect, the spindle must be turned
on by the M03 command. If the spindle is off, the spindle speed is stored and
used when the spindle is turned on again within the program. Use the M05
command to turn the spindle off.

Note:
Full circles (360o arcs) cannot be
performed with an R code. Split the arc
into two arcs or use center point (I, J
and K) values for full circles.
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Tool Selection (T Code)
T codes specify the tool offset (number) in the Tool Library in multiple tool
machining operations. Tools are specified by the address character “T” fol-
lowed by a parameter that represents the number of the tool. For example,
T3 is the designation for tool number three.

X Axis Coordinate (X or U Code)
An X code specifies the coordinate of the destination along the X axis. A U
code is used in absolute programming mode (G90) to specify an incremental
X motion.  You cannot use the U code to mix incremental and absolute pro-
gramming in the same block.

Y Axis Coordinate (Y or V Code)
A Y code specifies the coordinate of the destination along the Y axis. A V
code is used in absolute programming mode (G90) to specify an incremental
Y motion. You cannot use the V code to mix incremental and absolute pro-
gramming in the same block.

Z Axis Coordinate (Z or W Code)
A Z code specifies the coordinate of the destination along the Z axis (spindle
axis). A W code is used in absolute programming mode (G90) to specify an
incremental Z motion. You cannot use the W code to mix incremental and
absolute programming in the same block.

Note:
Do not place absolute and incremental
commands in the same block. For
example:

G90X1V1

will not produce the expected motions.

CAUTION

Using multiple tools is an
advanced operation, and
should not be attempted by
persons unfamiliar with using
the Benchtop CNC Router.
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Comment Codes
The Control Program allows you to add comments to your NC blocks. The
Control Program recognizes two comment codes:

u A semicolon “;”

u An open parenthesis “(“

These two comment codes are equivalent. The use of either of these codes
within an NC block indicates that a comment follows.

Comments must follow all other NC codes in the block. Comments are ig-
nored when the part program is executed. Comments can be placed on a
block without any NC codes to document what is occurring within a program.
NC programmers use these comments to annotate their programs.

Here is an example of an NC block with a comment:

X0Y0Z0;MOVE TO ZERO POINT

The comment tells us that the X, Y and Z codes in this block command the
cutting tool to move to the zero point (coordinate 0,0,0).

Comments can be combined with the G05 pause and the M06 Tool Change
codes to display messages to the operator during program execution. Here is
an example of an NC block with a pause coded comment:

G05(ROUGH DIAMETER SHOULD BE 0.5 in.)

When the program pauses, the comment is displayed on the message bar,
telling the operator to verify the diameter of the workpiece before continu-
ing. The M105 code provides a more versatile and powerful message facility.

The Control Program can strip the comments from a program with a single
command; however, comments cannot subsequently be replaced automatically.
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General Programming Suggestions
The following rules should be followed when writing NC part programs.

u The sequence of words (address characters plus parameters) in an NC block
must appear in the following order: /, N (O), G, X (U), Y (V), Z (W), A, I, J, K, R, Q, H, D,
L, F, S, T, M, P, ; A different order may cause unpredictable results.

u In many cases, a word need not be repeated in the next block (line). The
system assumes no change in codes unless a new code appears. This does
not apply to all codes. Some of the codes this does not apply to: N words, I,
J, and K, G04, G05, G25, G26, G92, F used for dwell, M02, M20, M25,
M26, M30, M47, M98 or M99.

u You can use more than one G code in a block; however, you can use
only one G code from any one group in a single block.

u N codes (sequence numbers) are not required in a part program; however,
they can be useful in identifying a block when editing a long NC part
program.

An O code is required to mark the beginning of a subprogram and does
not have to be in sequence with the N codes.

u The first instruction in a part program should move the tool to the start-
ing position. This makes restarts much easier.

u The last block of a program should move the tool back to the starting
position. The tool will then be in position to start cutting another part.

u Part programs should reference the zero point with Z0 at the point
where the tool just touches the work piece. This convention allows for
standardization of programming.

u Before running an NC part program:
a. Look for the typical coding error that places two X codes, two Y

codes, or two Z codes in the same block.
b. Be sure that all required coordinates have been written into appro-

priate blocks.
c. Verify the part program to discover any program errors.
d. Run the part program without mounting stock in the Router to see

if the tool movements are logical.

u The first portion of a part program should turn on the spindle and establish
the feed rate and spindle speed.

u M codes should be placed on separate blocks to avoid confusion over
whether an M code is activated during or after a motion command.

u Double-check all program blocks against your coding sheet to locate and
correct typographical errors.



F-24 Reference Guide: Section F



G-1More CNC Programming

More CNC Programming

Linear Interpolation Programming

Circular Interpolation Programming

Rapid Traverse Programming

Canned Cycle Programming

Subprogram Programming

Reference Guide: Section G



G-2 Reference Guide: Section G

Typical tool movement using linear
interpolation

Linear Interpolation Programming
Linear interpolation is the movement of the tool in a line from its current
position to a coordinate location specified by an NC block. Here’s a typical
block of NC code using linear interpolation:

N5G90G01X.7Y1.2F2

Broken down into individual words:

N5 The block sequence number is 5
G90 Coordinates are given using absolute dimensioning
G01 Linear interpolation is specified
X.7 X axis coordinate of end point = .7

Y1.2 Y axis coordinate of end point = 1.2
F2 Feed rate is 2 inches per minute

The G01 code is required when switching from circular interpolation or
rapid traverse positioning back to linear interpolation. If we assume the cur-
rent position of the tool is X.5, Y.5, the tool movement generated by the
above block is something like this:

An equivalent movement is achieved with incremental dimensioning (G91):

N5G91G01X.2Y.7F2
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Circular Interpolation Programming
Circular interpolation moves the cutting tool along an arc from the starting
point specified in one block, to an end point specified in the next block. The
curvature of motion is determined by the location of the center point (I, J, or
K), which must also be specified in the second NC block.

The direction of rotation from the starting point determines the actual shape
of the arc relative to the spindle axis. A G02 code moves the tool in a clock-
wise (CW) motion from the starting point. A G03 code moves the tool in a
counterclockwise (CCW) motion from the starting point.

Here are two typical blocks of NC code using circular interpolation:

N9G90X1Y0;SET START POINT

N10G03X0Y1I-1J0F2;COUNTERCLOCKWISE TO X0,Y1

The first block defines the starting point. The second block defines the end
point and the center of the arc. Broken down into individual words, the sec-
ond block reads:

N10 The block sequence number is 10
G03 The tool will proceed in a counterclockwise direction from the

starting point to specified (X, Y) coordinates; center point of arc is
specified by (I, J) coordinates

X1 X axis coordinate of end point = 0
Y0 Y axis coordinate of end point = 1
I-1 I coordinate of center point of arc = -1 (relative to start point)
J0 J coordinate of center point of arc = 0 (relative to start point)
F2 Feed rate is 2 inches per minute

G02 (CW) and G03 (CCW) cutting paths

Note:
This block is written for incremental
arc center mode.
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The tool path generated by the preceding block is something like this:

Typical tool movement using circular
interpolation

X

Y

1

1

Start Point
(X1,Y0)

End Point
(X0,Y1)

Tool Motion

Center Point
.5

.5

An equivalent movement is achieved with incremental dimensioning (G91):

N9G91X1Y0;SET START POINT
N10G03X-1Y1I-1J0F2

In this NC block, the X and Y values are the distance the tool is to move
from its current position. In both cases, the I and J values are equal to the X
and Y distance from the start point to the center point.

Circular Interpolation on Other Planes
To perform circular interpolation on a plane other than the X, Y plane, use a
G18 code to select the X, Z plane, or use a G19 code to select the Y, Z
plane. This feature is rarely used in manual part programming, but may be
used by CAM systems to generate surfaces of revolution. The G17 code is
used to return to the X, Y plane. An example of circular interpolation on the
X, Z plane is:

N9X0Z0
N10G90G18G03X0Z1I0K.5F2

In this NC block, the X and Z values are the destination position of the
tool. The I and K values are the incremental location of the center point of
the curvature of motion.
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Helical Interpolation Programming
Helical interpolation is performed when the axis not used in circular interpola-
tion is commanded to move. For example (assuming a start point of 0,0,0):

N10G90G03X0Y1Z1I0J.5F2

This block would cause the Z axis to move at a constant feed to Z1 while the X
and Y axes move in a circular path, resulting in a helical motion. Helical in-
terpolation works with circular motion on the X,Z and Y,Z planes as well.

Here is an example of an NC program using helical interpolation.

G90M03S1500
G0X0Y0Z0.070
G0X2Y2
G1Z-0.5F10
G02X0Y2Z0I-1J0F10
M02

In the example program, the tool
plunges into the workpiece then
makes the helical interpolation move
to the back corner of the stock
(X0Y2Z0).

This program uses incremental arc
centers. Include the % code if you
have changed the Control Program
default to absolute.

Centerline View

Solid View
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Rapid Traverse Programming
On the Benchtop Router, the rapid traverse code (G00) can move the tool at
the maximum available feed rate (50 ipm) to specified coordinates. Rapid
traverse is used to reposition the tool before ending a program, or in preparation
for the next cut.

WARNING

The tool should not be engaged in a cutting operation while
traversing to a new location!

Rapid traverse can be used for all tool positioning motions. This will reduce
the run time for the part program. The G00 code remains in effect until lin-
ear (G01) or circular (G02, G03) interpolation is again specified. Linear or
circular interpolation resumes at the feed rate last specified prior to the rapid
traverse motion(s) unless you specify a new feed rate.

Here’s a sequence of typical NC blocks using rapid traverse:

G90G01X1F2; MOVE IN A STRAIGHT LINE TO X = 1 AT 2 IPM

G00X2; RAPID TRAVERSE TO X=2

X3; RAPID TRAVERSE TO X=3

G01X4; MOVE TO X=4 AT 2 IPM
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Canned Cycle Programming
Canned cycle commands allow you to perform drilling operations by specifying
just a few codes. They are typically used for repetitive operations to reduce
the amount of data required in an NC program. Canned cycle codes are re-
tained until superseded in the program by another canned cycle code.  The
supported canned cycles codes are:

G80 Canned cycle cancel
G81 Straight drilling
G82 Straight drilling with dwell at bottom
G83 Peck drilling
G85 Boring cycle
G86 Boring cycle with spindle off (dwell optional)
G89 Boring cycle with dwell

These codes are used in conjunction with canned cycle codes:

G98 Rapid to initial position after canned cycle complete; this is the sys-
tem default

G99 Rapid to point R after canned cycle complete
Q Specifies the depth of cut. In peck drilling each peck uses the same

Q value. The Q value is always positive. If a negative value is
specified, it is converted to a positive value.

R Used for specifying a starting reference point for peck drilling. The
point can be at the material surface or at another reference point.

Using G80
To cancel a canned cycle, use the G80 code. This code cancels the currently
running canned cycle and resumes normal operation. All other drilling data
is canceled as well. You can also cancel canned cycles by using a G00 or G01
code; a G80 is automatically performed before the G00, G01, G02, or G03.
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If we specified a G99 here instead of a
G98, the tool would rapid to point R
instead of the initial point.

Using G81
The G81 code performs straight drilling operations. By specifying an R value
of zero, the tool will return to the initial point after drilling to point Z. Here
is a sample G81 program.

G0X1Y1Z.1;RAPID TO 1, 1, .1

G81G98Z-.5R0F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL POINT

G80;CANCEL CANNED CYCLE

M2;END PROGRAM

This program will generate tool motions similar to this:

More than one canned cycle can be accomplished by specifying only X and Y
coordinates. For example:

G0X1Y1Z.1;RAPID TO 1, 1, .1

G81G98Z-.5R0F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL POINT

X.5Y1;PECK AT NEW X,Y COORDINATES

X.25Y1;PECK AT NEW X,Y COORDINATES

G80;CANCEL CANNED CYCLE

M2;END PROGRAM
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If we used a G99 with the G82 instead
of a G98, the tool would rapid to point
R instead of the initial point.

Using G82
A G82 works just like a G81, except it is used when you wish to incorporate a
dwell (P code) at the bottom of the hole (point Z). A block of code utilizing
the G82 and P code, and the tool motion it creates are shown below.

G0X1Y1Z.1;RAPID TO 1, 1, .1

G82G98Z-.5R0P5F2;DRILL TO DEPTH OF -.5, RAPID TO INITIAL
POINT AFTER A DWELL OF FIVE SECONDS

G80;CANCEL CANNED CYCLE

M2;END PROGRAM

Using G83
The G83 code is used for peck drilling cycles. By adding a Q depth to the
code block, you can specify drilling increments. For instance, the following
code will peck drill to a depth of -.5 in .1 increments. The tool will rapid
back to point R after each peck drill. Also, before each peck the tool will
rapid to .005 (.13mm) above the start point.

G0X1Y1Z.1;RAPID TO 1, 1, .1

G83G99Z-.5R0Q.1F3;PECK DRILL TO DEPTH OF -.5, RAPID TO R

G80;CANCEL CANNED CYCLE

M2;END PROGRAM
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G99 returns the tool to point R. Use
G98 with the G83 to return the tool to
the initial point at the end of the
canned cycle.

Using G84
A G84 is used for tapping threads. You specify the depth of the tapped hole.
When the tap reaches that depth, it is pulled out in at a rate 1.6 times the
rate of insertion (60% faster). The G84 tells the computer to calculate the
insertion/extraction ratio. You must use a tapping head with a reversing
mechanism when using G84.

G0X1Y1Z.1;RAPID TO 1, 1, .1

G84G98Z-.5R0F2;TAP TO DEPTH OF -.5, RAPID TO INITIAL POINT

G80;CANCEL CANNED CYCLE

M2;END PROGRAM
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If G99 were specified instead of G98,
the tool would not rapid back to the
initial point. It would remain at point
R.

If a dwell is not specified (P code not
used), a G05 pause is executed after
the spindle stops at the bottom of the
hole.

Using G86
A G86 works like a G82 except the spindle stops at the bottom of the hole.
The dwell (optional) allows the spindle to come to a complete stop before the
tool rapids back to the initial point.

G0X1Y1Z.1;RAPID TO 1, 1, .1

G86G98Z-.5R0P5F2;DRILL TO DEPTH OF -.5, SHUT OFF SPINDLE,
RAPID TO INITIAL POINT AFTER A DWELL OF FIVE SECONDS

G80;CANCEL CANNED CYCLE

M2;END PROGRAM

Using G85
A G85 specifies a boring cycle. After the tool plunges, it retracts at the same
feed to point R. This sometimes gives a better surface finish on the hole.
Then the tool rapids to the initial point.

G0X1Y1Z.1;RAPID TO 1, 1, .1

G85G98Z-.5R0F2;BORE TO DEPTH OF -.5, RAPID TO INITIAL POINT
FROM POINT R

G80;CANCEL CANNED CYCLE

M2;END PROGRAM
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Using G89
The G89 code works like the G85 except it utilizes a dwell at the bottom of
the hole.

G0X1Y1Z.1;RAPID TO 1, 1, .1

G89G98Z-.5R0P5F2;BORE TO DEPTH OF -.5, PAUSE FOR FIVE SEC-
ONDS THEN RAPID OUT FROM POINT R

G80;CANCEL CANNED CYCLE

M2;END PROGRAM

If G99 were used with the G86, the
tool would not rapid back to the initial
point. It would go to point R.
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Subprogram Programming
Subprograms are used to execute repetitive routines in an NC program.
Since a subprogram can be called again and again, you don’t have to enter
the same data more than once. This is especially useful if the machining op-
eration you wish to repeat is lengthy or complex. The NC codes used for
subprogramming on the Benchtop Router are:

M98 Call to subprogram.
M99 Return from subprogram.

P Code The P code is used to reference the first block of the subprogram
(which begins with an O code). The P code immediately follows
an M98.

L Code The L code is used as a loop counter when used in
subprogramming. The computer executes the subprogram as many
times as defined by the L code. For instance, if the code is L5, the
subprogram is executed five times. (Optional)

O Code The O code replaces the N code on the first block of a subprogram.

A subprogram is called by an M98 and a P code. When an M98 calls the sub-
program, the main program is interrupted while the subprogram is executed.

The P code references the subprogram’s address (the first block of the sub-
program). The first block of the subprogram uses an O code instead of an N
code for block numbering.

When the M99 is executed, the main portion of the NC program continues
to execute from the block after the subprogram was called.

Subprogram calls can also be nested within other subprograms. This means
that while a subprogram is being executed, it can call another subprogram.
The default number of levels that subprograms can be nested is 20 levels
deep. You can change the default by using the Setup Program (click on the
Setup icon in the BenchRouter program group).

Note:
The L code is also used as a program
cycle counter. For instance, if the last
block of NC code in your program is
M47L10, the program  executes ten
times. After the tenth time, the program
ends.

Note:
You can also perform an M99P "block
number" at the end of the subprogram.
This returns to the main program at the
specified block. It�s like a return with a
go to.
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A Sample NC Subprogram
G05

M03S1000

; SAMPLE OF SUBPROGRAM

; USE 7.25 X 3.00 STOCK FOR VERIFY

G0X1Y1Z.1; RAPID TO 1, 1, .1

M98P1000L4; RUN SUBPROGRAM 1000 FOUR TIMES

G90G0X0Y0Z.1

M2; END OF MAIN PROGRAM

O1000; SUBPROGRAM TO MILL SQUARE AND MOVE TO NEXT
POINT

G90G1Z-.1F2; PLUNGE AT CURRENT LOCATION

G91; INCREMENTAL COORDINATE

X1F5; FIRST MOVE, FEED RATE 5

Y1; SECOND MOVE

X-1; THIRD MOVE

Y-1; FOURTH MOVE

G90G0Z.1; RAPID UP ABOVE WORK

G91X1.5; RAPID TO START OF NEXT SQUARE

M99; RETURN FROM SUBPROGRAM

The M98 calls the subprogram that begins on block
O1000 (referenced by P1000) and tells it to repeat
four times.
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Using Polar Programming
Using polar coordinates allows you to specify a radius and an angle by speci-
fying a G16 code (polar programming on), then X and Y codes. The X code
specifies the radius. The Y code specifies the angle in degrees. A G15 is used
to cancel the polar programming mode. This programming method can be
used in both absolute and incremental programming.

Polar programming is especially useful when writing programs for machining
bolt holes. An L code can be used as a multiplier for the angle value. For in-
stance, this bit of code:

G0X0Y0Z0.07

M03

G16

G91X2Y0

M98P1L12

M2

O1Y30

G81Z-.1R0

G80

M99

combines the use of polar programming with a canned cycle and a subprogram
to drill a hole at 30o increments. The L value was determined by dividing 360 de-
grees by 30.

You can also cut an arc using code similar to:

G16

G91X2Y0

M98P1L360

G15

M2

O1Y1

M99

In polar programming, the center point is the origin if you specify G90 and
the radius (X code). If you specify G91 and the radius (X code), the center
point is the current point. If you specify only the angle (Y code), the center
point is the current center.
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Using the Homing Commands
The Homing commands allow you to establish a point of origin at the ends
of travel on the Benchtop Router. The Benchtop Router uses this point as a
reference for all machine coordinate movements. This allows the machine to
move consistently to the same location.

Using G28
The G28 code “homes” the machine: it moves the Benchtop Router’s head
to the ends of travel along each axis and sets the Machine Coordinate System
to (0,0,0). This zero point is located at the negative limits of the X and Y
axes, and the positive limit of the Z axis. Use G28 to automatically initialize
the machine every time it’s turned on. See the sample NC program below for
one use of the G28 code.

Using G28 in an NC Program
Here is an example of an NC program using Homing Commands (the
Homing Commands and related commands are in bold):

G28; HOMING THE MACHINE

M3S1000; SPINDLE MOTOR ON SPEED 1000

G54; USE COORDINATE SYSTEM ONE

G0X0Y0z0; RAPID TO 0,0,0

G1z-0.070F5; CUTTING THE PIECE

G1X3

G1Y4.25

G1X0

Y0

G0Z0.070

M2

The G28 code homes the machine and sets the Machine Coordinates to
zero. Use a G27 if you want to check the home position, but do not want to
set that position to zero.

The G54 calls up coordinate system one, which contains the offset values
relative to the machine’s home position. These are the values you entered for
coordinate system one in the Offset from Machine Zero dialog box under the
Set Coordinates dialog box. The coordinates in the Position Window on the
screen change to the coordinates of coordinate system one.

G28 sets a machine reference point,
similar to the Set/Check Home
command from the Setup Menu.
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The next line (G0X0Y0Z0) calls for the machine to perform a rapid traverse
motion from the Home position to point 0,0,0 in coordinate system one.

The remaining lines of code instruct the machine to cut a square in a
piece of stock.

Using G28 Before Setting Soft Limits
Remember, Soft Limits are based on Machine Coordinates. You can not use Soft
Limits until you have set the machine to the reference point using the G28 code
or pressing the Home button in the Set or Check Reference Point dialog box (ac-
cess using the Set/Check Home command under the Setup Menu).

Using G27
After you have set a reference point (using either the Set Reference Point button
in the Setup Coordinate System dialog box or a G28 code), you can use the
G27 code to check the actual machine position against the expected machine po-
sition. This command causes the machine to perform a homing-like function,
moving each axis independently from its current position to the reference
point. The Control Program then compares the current position to the one
set by the G28. If the deviation is larger than the threshold you specify using
the L code (i.e. G27L.001), the Control Program reports an error after all
axes are checked. If there is no deviation, the program continues.

G27 also takes an optional position specified by XYZ. This position is called the
intermediate position. You do not need to specify all axes for the intermediate
point, but for each axis that you specify the current coordinate for the intermedi-
ate point is updated to that value. Only axes that have specified coordinates move
when you specify an intermediate point. For example, if the first intermediate
point commanded is G27Z.6, the intermediate point motion is only to move the
Z axis to .6. The machine first moves to the current intermediate point at rapid
traverse, then performs the reference point check.
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Using G29
The G29 code moves the tool at a rapid traverse rate to a coordinate speci-
fied by XYZ. If you have set an intermediate point on one or more axes, the
machine first rapids from the current position to the intermediate point then
continues to the specified destination. If you command a G29 code in Incre-
mental mode, your specified XYZ point is relative to the intermediate point.
If you have not specified an intermediate point, your specified XYZ point is
relative to the current position. Use the G29 code after a G28 command to
return the tool to a position closer to the part. The example below shows the
use of a G28 code and a G29 code.

N1G28X2Y2Z1; INTERMEDIATE POINT THEN HOME

N2G29X4Y1Z1; GO TO G29 POINT

+Y

+X

G29 Point (4,1)

(0,0)

Intermediate Point (2,2)

Reference Point (3.5,4)

(1,1)

In block N1, the tool moves from its
current point to the intermediate
point, then to the reference point.

In block N2, the tool moves from the
reference point, through the
intermediate point, to the point
specified with the G29 code.
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Programmed Tool Path

Compensated Tool Path
(Left)

Tool

Compensated Tool Path
(Right)

Tool

G41 G42

Programmed Tool Path

Using Cutter Compensation
Cutter compensation automatically adjusts the Benchtop Router to compensate
for variations in a cutting tool’s radius. It uses values from the Offset Table
to determine the compensation offset value. Use the following codes for cut-
ter compensation:

G39 Inserts an arc at the corner of compensated path
G40 Cancels cutter compensation
G41 Invokes left cutter compensation
G42 Invokes right cutter compensation

D Compensation offset value (Tool Radius Value)

Determine left and right cutter compensation in relation to the direction of
the tool path. Use left compensation when you need to move the tool to the
left of the programmed tool path. Use right compensation when you need to
move the tool to the right of the programmed tool path.

IMPORTANT!

The Offset Table you use for
Cutter Compensation D values
is the same table you use for
Tool Offset Adjust D values and
Tool Length Offset H values.

Select compensation offset values for D from the Offset Table. You can store
200 offset values in the table. Remember, however, that these offset values
are the same values you use for adjusting tool length offsets.
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Cutter compensation mode begins
when the following are met:

w A G41 or G42 code is commanded.

w The specified offset number is not
0.

w A move in any of the axes in the
offset plane is commanded. The
move is not 0.

w No arc commands are commanded
in the start up block.

Starting Cutter Compensation (G41/G42)
You can start cutter compensation by inserting a G41 (for left compensation)
or G42 (for right compensation) into your NC program. In the example be-
low, left cutter compensation is enabled and the compensation value is equal
to offset value 1 from the Offset Table.

G0X0Y0

G91; INCREMENTAL

G41D1; CUTTER COMP ON

G1X.25Y.25; MOVE TO P1

G1X0Y1; MOVE TO P2

G1X.75Y0; MOVE TO P3

G1X.25Y-.25; MOVE TO P4

G1X0Y-.75; MOVE TO P5

The following illustrations show how the Control Program constructs the
compensated tool path for the NC code above:

Segment 2

Segment 3

Segment 4

Segment 5

Start Point

Tool

P1

P2 P3

P4

P5

1.  This is the programmed tool path
before cutter compensation is enabled.
The tool sits at the start point waiting
for the first motion command.
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D1

Start Point

Tool

Offset Vector (Segment 2)A

Segment 1

Segment 2

Segment 3

Segment 5

Offset Vector (Segment 1)

A1

Offset Vector
(Segment 1)

Segment 4

P1

P2 P3

P4

P5

Offset Vector
(Segment 3)

D1

D1

Start Point

Tool

Offset Vector (Segment 2)A

Segment 1

Segment 2

Segment 3

Segment 5

Offset Vector (Segment 1)

A1

Offset Vector
(Segment 1)

Segment 4

B

P1

P2 P3

P4

P5

2.  Because segment 1 begins before
cutter compensation is enabled, the
start point of segment 1 is on the
original tool path. When cutter
compensation is enabled, the Control
Program creates Offset Vectors
perpendicular to each segment of the
programmed tool path to determine
the compensated tool path.

Point A1 is located at the intersection of
the Offset Vector of segment 2 and a
point offset by the value of D on the
Offset Vector of segment 1. Point A is
located on a path parallel to the tool
path, offset by the value of D.

Note:
Cutter Compensation Startup now
moves to the vector normal
(perpendicular) to the start point of
the first segment specified after
startup, rather than calculating the
intersection between the startup
segment and the first complete
segment. The diagrams shown do not
reflect this change.

Before beginning each motion, the
Control Program looks ahead to the
next motion in the NC code to
determine the compensated end point
of the first motion.

Using this method, the Control
Program determines that point A is
the end point of the first motion. The
tool moves to point A on the
compensated tool path.

3.  The tool moves to the end point of
segment 2 (point B) on the
compensated tool path. Point B is the
intersection of lines drawn
perpendicular to the Offset Vectors of
segments 2 and 3 with an offset value
of D from the programmed tool path.
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Offset Vector
(Segment 3)

Start Point

Tool

A

Segment 1

Segment 2

Segment 3

Segment 5

Segment 4

B C
Offset Vector
(Segment 3)

D

P1

P2 P3

P4

P5

Start Point

Tool

A

Segment 1

Segment 2

Segment 3

Segment 5

Segment 4

B C
Offset Vector
(Segment 3)

D

E

4.  The tool moves to the end point of
segment 3 (point C), which is located
at the intersection of lines drawn
perpendicular to the Offset Vectors of
segments 3 and 4 with an offset value
of D. The tool then begins travel
towards point D, the end point of
segment 4.

5.  The tool moves to the end point of
segment 5 (point E) on the
compensated tool path. Point E is a
point on the compensated path. (See
Canceling Cutter Compensation in this
section for more information.)
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Note:
When specifying an IJK vector, you
must include the G41 or G42 code on
the same line.

Cutter Compensation with IJK Vectors
Any G41 or G42 command can include an IJK vector, which defines the end
point direction vector and the end point offset vector. For example, if, for
segment 3 of the previous illustration, we had specified

G41X.75I1J1

instead of just

X.75

the compensated tool path would look like this:

(D1=.25)

Start Point

Normal Offset 
Vector (Segment 3)

Offset Vector
(Segment 2)

A

Segment 1

Segment 2

Segment 3

Segment 4

B

Offset Vector
(Segment 4)

New Offset Vector
New Direction 
Vector (IJ)C

P1

P2 P3

P4

The IJK Vector represents an incremental direction (the length of the vector
is not important. For example, I1J2<=>I3J6. By default, the end direction
vector is tangent to the segment.
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Setting Cutter Compensation Offsets (D)
Select Setup Offsets from the Setup Menu to set the values referenced by the D
codes (the cutter compensation offset value). The following dialog box appears:

Select an offset from the list to modify. Change its value in the Value Edit
box, or use the Current Z button to use the current Z position.

Note:
You cannot assign a value to offset
number 0. The offset value for offset
number 0 is always zero.
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Changing Offset Values
While cutter compensation is active, you can change offsets by specifying a
new offset number with the D-code. For example:

N1G91

N2G41D1X.25Y.25

N3Y.25

N4X.25D3; USE OFFSET #3

N5Y-.25

�

In this example, the offset number changes from 1 to 3 in line N4. Because
the value of offset 3 is greater than the value of offset 1, the compensated
path moves farther away from the programmed path and is at the new offset
value by the time the tool reaches point C.

In this example: D1=.01 and
D3=.03

B

C

D3=.03D1=.01

Offset Vector

D3=.03

A
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The same situation would occur if you made the offset value negative. For
the example above, changing the D value from .01 to -.01 would produce
the same result as changing from G41 to G42.

Changing Offset Sides
You can change the side of compensation sides during cutter compensation.
For example, you can start cutter compensation to the left then change to
the right while in cutter compensation:

G91

G41D1X.25Y.25; LEFT CC ON

Y.25

G42X.25; RIGHT CC ON

 Y-.25

�

In this example, left cutter compensation is on at point A, but right cutter
compensation begins as the tool moves towards point B. In this case, the off-
set value (D) is the same for both left and right cutter compensation.

B C

D1D1

D1

D1

A
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(X0,Y1)

(D1)

Start point

Tool

Default Offset Vector

Offset Vector

Direction 
(IJK) Vector

Default Endpoint

Using Corner Offset Circular Interpolation (G39)
The G39 code inserts an arc at the corner of a cutter compensated tool path.
The G39 instructs the cutter compensation function to complete the current
segment by moving to its default endpoint (the endpoint of the Offset Vector).
It then creates an arc (with a radius equal to the offset value), starting at the
buffered segment’s default endpoint, and ending at the endpoint of the off-
set vector (IJ). Here is an example of an NC program using G39:

G91

G41D1�

�

Y.25

X.25

G39I0J-1;  CORNER OFFSET
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Canceling Cutter Compensation
Use the G40 code to cancel cutter compensation. G40 is effective for only
one move. There are six methods for cancelling cutter compensation.

1. G40

2. G40XYZ

3. G40XYZIJK

4. D0

5. D0XYZ

6. G41/42D0XYZIJK

With methods 4 through 6 above, setting the offset number to zero has the
same effect as cancelling cutter compensation. However, cutter compensation
is still active.

Methods 1 and 4
With method 1 the G40 code cancels cutter compensation. The cutter moves
from the offset path to the programmed end point. The same occurs with
method 4, where you set the D value to zero.

G91G41D1

�

X.25

Y-.25

Z.2; RETRACT

G40; OR D0

X-.5Y-.25

M2

Center of 
programmed tool path

Start point

G40 
Tool travels to 
programmed path

Center of compensated tool path
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Methods 2 and 5
With methods 2 and 5, the G40 (or the D0) cancels the cutter compensa-
tion, but a subsequent motion (X-.5Y-.25) is included in the program. The
tool moves towards the programmed path in the direction of X-.5Y-.25.

G91G41D1

�

X.25

Y-.25

Z.2;RETRACT

G40X-.5Y-.25

M2

Center of 
programmed tool path

Center of compensated tool path

Start point

G40 
Tool travels along compensated 
path towards X-.5Y-.25

ToolX-.5Y-.25
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Methods 3 and 6
With these methods an IJK vector specifies the direction of movement after
cutter compensation is cancelled.

G91G41D1

�

X.25

Y-.25

Z.2; RETRACT

G40X-.5Y-.25I-.5J-.25

M2

Center of 
programmed tool path

Center of compensated tool path

Start point

IJ Vector

Normal vector to IJK

Default end point
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Note:
If you do not specify any of the
coordinates for the scaling center, the
current position for unspecified axes
becomes the scaling center coordinate.

CAUTION

Using a P Code to scale an
entire piece will affect the Z
axis, which will affect your
programmed depths of cuts. Use
caution when performing
scaling operations.

Using Scaling and Rotation Codes
Scaling codes and rotating codes can be used separately or they can be com-
bined. Each of these functions is described in the following paragraphs.

Scaling
Use the scaling codes to scale one or more axes of a part from a fixed scaling
origin. You can scale the entire piece uniformly, or set different scaling factors
for each axis. Use the following codes for scaling:

G50 Cancels scaling
G51 Invokes scaling

P Uniform scale multiplier

Uniform Scaling
Use a P Code to scale an entire piece uniformly along each axis. When you
specify a value for P, subsequent motions are scaled by that value, starting
from the scaling center. The Control Program measures the distance from
the scaling center to the start and end points of the shape, then multiplies
those values by the P value.

The NC program below creates a half-circle then scales those motions by two to
create a larger, uniformly-scaled half-circle (scaling codes are in bold print):

N0G0Z.5

N1X1Y1.5

N2G1Z-.1F10

N3G2Y.5J-.5

N4G0Z1

N5G51X1Y1Z0P2; SUBSEQUENT MOTIONS SCALED BY 2

N6G0Z.5

N7X1Y1.5

N8G1Z-.1F10

N9G2Y.5J-.5

N10G0Z1

N11G50; CANCEL SCALING

The values for X, Y, and Z in line N5 represent the absolute position of the
scaling center. The P value represents the scale factor. In this example, the
entire part is scaled by two. The G50 in line N11 cancels the scaling.
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In this example, a uniform scaling
factor for all axes produces a shape
scaled from the original.

Scaling Each Axis
You can scale each axis by different magnifications. The following NC program
uses scaling to change the proportions of a motion by scaling each axis sepa-
rately (the scaling codes are in bold print):

N0G0Z.5

N1X1Y1.5

N2G1Z-.1F10

N3G2Y.5J-.5

N4G0Z1

N5G51X1Y1Z0I1.5J1.75K1; SCALING ON

N6G0Z.5

N7X1Y1.5

N8G1Z-.1F10

N9G2Y.5J-.5

N10G0Z1

N11G50; CANCEL SCALING

The values for X, Y, and Z in line 5 represent the absolute position of the
scaling center. The I, J, and K values represent the scale factors for the X, Y,
and Z axes respectively. When scaling each axis individually, you do not use
a P code.

In this example, different scaling
factors for the X and Y axes produce
a shape similar to the one shown
on the right.

When an arc is scaled differently in
the two plane axes (X and Y in
G17), an ellipse results. Because
the Control Program cannot
construct ellipses, it interprets the
shape as an arc followed by a line
segment move to the desired end
point. The Control Program
determines the arc by using the
smaller of the two scale factors to
determine its radius.
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Note:
If you do not specify a scale factor for
an axis, the value of that axis defaults
to a factor of 1

In this example, negative I and J
values create a mirror image of the
original shape.

CAUTION

Performing Z axis mirroring is
an advanced operation. Use
extreme caution when
machining with a negative Z
scaling factor.

Creating Mirror Images with Scaling
You can create mirror images of shapes by specifying negative values for I, J, and
K. The NC program below uses negative I and J values to create a mirror image
of the original shape on the XY plane (the scaling codes are in bold print):

N0G0Z.5

N1X1Y1.5

N2G1Z-.1F10

N3G2Y.5J-.5

N4G0Z1

N5G51X1Y1Z0I-1J-1K1; SCALING ON
N6G0Z.5

N7X1Y1.5

N8G1Z-.1F10

N9G2Y.5J-.5

N10G0Z1

N11G50; CANCEL SCALING

The values for X, Y, and Z in line 5 represent the absolute position of the
scaling center. The I, J, and K values represent the scale factors for the X, Y,
and Z axes respectively. Notice the negative I and J values for mirroring on
the XY plane. Remember that performing Z axis mirroring is an advanced
operation. Use caution when machining with a negative Z scaling factor.
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In this example, G68 rotates a shape
900 from the original.

Rotation Codes
Rotation codes allow you to rotate a programmed shape around a rotation
origin. You can rotate a shape on any plane, one plane at a time. Use the Ro-
tation code to modify an NC program when a work piece has been rotated
from the programmed position on the machine.

G68 Invokes rotation
G69 Cancels rotation

Here is an example of an NC program using Rotation (the Rotation codes
are in bold):

N0G0Z.5

N1X1Y1.5

N2G1Z-.1F10

N3G2Y.5J-.5

N4G0Z1

N5G68X1.583Y1.5R90; ROTATION ON ROTATION ORIGIN XY

N6G0Z.5

N7X1Y1.5

N8G1Z-.1F10

N9G2Y.5J-.5

N10G0Z1

N11G69; CANCEL ROTATION

Rotation Origin
(1.583, 1.5)
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The X and Y values in line N5 are the coordinates of the rotation origin;
the rotation occurs around this point. The R value represents the absolute
value of the rotation angle. The G69 in line N11 cancels the rotation.

Note that positive R values represent counterclockwise rotation angles;
negative R values represent clockwise rotation angles.

+R -R

Counterclockwise
Positive Rotation Value

Clockwise
Negative Rotation Value

Rotation Origin Rotation Origin
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Notice that in this program the P Code
is used to reference the first block of
the subprogram (not shown in this
example). The subprogram contains
the code that creates each part.

IMPORTANT!

When combining the scale and
rotate features, always scale
the part first, before rotating it.

Combining Scaling and Rotation Codes
You can combine scaling and rotation in the same NC program. The portion
of the NC program below combines the scaling and rotation codes necessary
to machine the following part (the actual subprogram to cut the shield
(O100) is not listed here).

N1; DO THE ORIGINAL FIRST

N2M98P100

N3; NOW SCALE BY 1/2 AND ROTATE 90 CCW

N4G51X1.583Y0Z0I.5J.5K1; SCALING ON

N5G68X1.583Y1.5R90; ROTATION ON

N6M98P100; SECOND PART

N7; NOW MIRROR AND SCALE BY 1/2, AND ROTATE 90 CCW

N8G69G50

N9G51X1.583Y0Z0I-.5J.5K1

N10G68X1.583Y1.5R90

N11M98P100; THIRD PART

N12; NOW SCALE BY 1/2 AND ROTATE BY 90 CW

N13G69G50

N14G51X1.583Y0Z0I.5J.5K1

N15G68X1.583Y1.5R-90

N16M98P100; FOURTH PART

N17;END OF PROGRAM

In this example, scaling and rotation
are combined to produce different
sized shapes that are scaled and
rotated from the original.
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Multiple Tool Programming
The Benchtop Router allows you to define up to 20 different tools for use
during router operations.

You will need to define tools and write the tool changes into the NC pro-
gram. For defining tool length, the easiest method is to use the Setup Tool
Wizard under the Tools menu.

Defining tools is explained in the tutorial in Section D of this guide. Pro-
gramming codes, reference tools, offsets, and testing are described below.

Using Multiple Tool Codes
The T code is used in the NC program to offset the cutter so that the NC
program becomes independent of the cutter length, which is set up in Tool
Definitions. This means you can replace a worn tool with a tool of a different
length without changing the NC program, just by entering new offsets. (Any
actual tool change is performed manually.) The T code can be located any-
where within the block of NC code, but it is normally placed after the G code.

When you place T codes in your program for tool changes, you should also
use the M06 code to retract and shut off the spindle. The M06 code is placed
after the T code. This code instructs the router to shut off and retract the spindle
to the top of the vertical column, where it pauses until you manually change the
tool. Pressing the Return key will turn the spindle back on and continue with
the NC program.
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Establishing the Reference Tool
When using multiple tools, a reference tool, normally Tool #1, is set to zero
for the Z axis. This establishes a reference tool position which is used as a
reference point for additional tools. For demonstration purposes, we will use
Tool #1 as the reference tool and Tool #2 as the additional tool.

To set the reference tool:

1. Decide on a reference point (a point on the workpiece, or on a gauge,
where you will jog the tip of each tool).

2. Install a tool into the spindle.

3. From the Tools Menu, choose Select Tool. If the tool is not already defined
in the pull down menu, see page D-8 to define the tool.

4. Choose the tool you are using, then click Select Tool.

5. If you are using a sensor, place it on the hold down table.

6. Using the Jog Control Panel, jog tool #1 to the tip of the sensor until
the lights come on.

7. Select Set Position from the Setup Menu, set the Z axis value to zero,
and click OK.

Tool #1 is now established as the reference tool.

Establishing Tool Offsets
Now that the reference tool is established, additional tools can be assigned
offsets. You can move the tool and accept its current Z axis position as the
offset value, or you can manually enter offset values.

To set the offset for Tool #2:

1. Install tool #2 in the spindle.

2. From the Tools Menu, choose Select Tool. If the tool is not already defined
in the pull down menu, see Section D to define the tool.

3. Choose the tool you are using, then click Select Tool.

4. Jog tool #2 to the tip of the sensor until the sensor lights come on.

5. Select Setup, and then Offsets from the pull down menu.

6. Choose the correct tool (the description that matches the tool you in-
stalled) from the list, and click on the Current Z button at the bottom
of the window. Select OK to save the value.

7. Repeat this process for each additional tool.
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Testing Your Multiple Tool Program
After setting all of the tool offsets, test run your program without a
workpiece mounted and with the spindle speed turned down.

1. After installing Tool #1, close the safety shield, put on your safety
glasses, and complete the safety checklist.

2. Select the Run/Continue command from the Program Menu. Enter zero
as the start line and select Start. Throughout the test, be prepared to
press the emergency stop switch on the Benchtop Router, or the space bar
on the computer keyboard in case of a tool crash. The computer will run
the program until it reaches the M06 code.  If your machine is equipped
with an ATC, the tool change will take place automatically, and you
may ignore steps 3-7. The M06 stops and retracts the spindle.

3. When the spindle has completely stopped and the Pause message appears
on the screen, push in the emergency stop button on the Benchtop Router.

4. Open the safety shield.

5. Remove Tool #1 and install Tool #2, making certain it is securely fas-
tened to the spindle.

6. Close the shield, and pull out the emergency stop button. Press the Re-
turn key on the computer keyboard. The spindle turns on and moves to
the previous position. Operation continues as programmed until the
next M06 code is encountered.

7. At each pause, repeat Steps 3 through 6, installing the appropriate tool
at the appropriate points in the program.

8. Edit the program, if required. When you are satisfied that the program
works correctly, mount the workpiece, set the spindle speed, and run
your multiple tool program.
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Set/Check Home, or G28

Understanding Coordinate Systems
For a beginning user, understanding coordinate systems can be difficult. The
first thing to remember is, before performing most machining operations, you
are required to set the machine to “home” position. This returns the machine
to the machine zero point, and acts as a reference point for all operations. It
is a good idea to home the machine every time you run the control software.

Machine Coordinates
Machine Zero positions the router head at the extreme negative end of travel
on the X and Y axis, and the extreme positive end of travel on the Z axis.
This is a fixed point on the machine, and cannot be changed. The machine
uses this as a reference point for all operations. If the machine is not homed
(set to the machine zero) it can not accurately locate the workpiece on the
hold down table.  The machine is homed by selecting Set/Check Home un-
der the Setup menu, and choosing the Home button; or by using a G28
code in the NC program.

Work Coordinates
Once home is set, you load an NC program into the computer. Your pro-
gram will need a point of origin to start from. Setting a point of origin will
establish the work coordinates. Work coordinates relate to the workpiece,
and are usually set from the top of the front left corner of the workpiece
mounted on the table. Once the stock is mounted on the table, jog the
spindle to the top front left corner of the workpiece. From the Setup Menu,
select Set Position. The tool coordinates appear in the dialog box. Enter
0,0,0 and click on OK to set the current tool position as the point of origin
on the workpiece.

Multiple Coordinate  Systems
For more advanced operations, you can set up multiple coordinate systems.
For example, three or four designs can be cut from the same piece of stock.
First, secure the stock to the hold down table. Then, set the work coordinate
point of origin (0,0,0) at the corner of the stock using the Set Position dialog
box from the Setup Menu. After setting the corner of the stock as the origin,
select Coordinate Systems from the Setup menu. The Setup Coordinate Sys-
tems dialog box appears. Select a “User CS”, enter the coordinates for the
first design, and click on Apply. Repeat this procedure for as many User CS’
as necessary. (For a detailed description of the Setup Coordinate Systems
procedure, see Section E.)

Setting Coordinate Systems
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G44

Tool

Offset Value

Z0

Offset Value

Tool

G43The examples on this page assume
psoitive offset values.

Longer tools need G43 to retract the
spindle from the cross slide, while
shorter tools need G44 to move the
spindle closer to the cross slide.

Using Tool Length Offset Codes
Tool length offsets are included in the Tool Setup procedure in Section E.
When you command a tool change in the program and the tool is loaded, the
offset is automatically read as part of the tool information that was entered
when the tool was defined.

However, if you are programming in Fanuc-compatibe mode, use the tool
length offset codes to adjust the machine for variations in tool lengths. The
tool length offset codes are:

G43 Compensate for a longer tool.
G44 Compensate for a shorter tool.
G49 Cancel tool length offset.

H Specifies the offset number from the offset table. (The Offset Table
you use for Tool Length Offset H values is the same table you use
for Cutter Compensation and Tool Offset Adjust D values.)

The G43 compensates for a longer tool by retracting the spindle away from
the cross slide. The G44 compensates for a shorter tool by moving the spindle
closer to the cross slide.

The T code normally specifies the tool, its diameter (for verify only), and
offset value. When you include a G43 or G44, the computer ignores the T
code offset value and uses the offset you assign to H.

Here is an example of the tool length offset code used in an NC program:

M06G43T2H1

The M06 initiates the tool change cycle. Once the tool change is complete,
the G43 adds the value from the offset table to the Z offset. The T2 refers to
the tool number and the tool diameter, but not the offset value. The H1
represents the offset value set in the Offset Table.

Fanuc mode is entered by placing a %
at the beginning of your program.
This does not affect how the software
interprets T codes.
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5.5
Actual Movement

Commanded Movement

Offset Value

4.0

1.5

5.5

Actual Movement

Commanded Movement

Offset Value

4.0

-1.5

Using Tool Offset Adjust Codes
Use these codes for making critical dimension adjustments to the offset val-
ues. When you specify tool offset adjust codes, you can increase or decrease
the movement distance of the specified axis by the offset value (D). The tool
offset adjust codes are:

G45 Increases the movement amount by the value stored in the offset table
G46 Decreases the movement amount by the value stored in the offset table
G47 Increases the movement amount by twice the value stored in the

offset table
G48 Decreases the movement amount by twice the value stored in the

offset table
D Offset value

You must command a motion for tool offset adjust codes to adjust the offset
values. Following are examples of the motions caused by tool offset adjust codes.

G45
1. The offset value increases the actual movement by 1.5 beyond the com-

manded movement.

2. The negative offset value decreases the actual movement by 1.5 from the
commanded movement. Note that a G45 code with a negative offset
value is the same as a G46 code with a positive value.
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1.0
Actual Movement

Commanded Movement

Double Offset Value

4.0

3.0

7.0
Actual Movement

Commanded Movement

Double Offset Value

4.0

3.0

5.5

Actual Movement

Commanded Movement

Offset Value

4.0

1.5

G46
The G46 code decreases the commanded movement by the offset value. Note
that the G46 code is the same as reversing the positive or negative direction
specified by the offset value of a G45 code.

G47
The G47 code increases the commanded movement by twice the offset value.

G48
The G48 code decreases the commanded movement by twice the offset value.
Note that the G46 code is the same as reversing the positive or negative di-
rection specified by the offset value of a G47 code.
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Safety Rules
The following safety rules should be reviewed and practiced by all operators
of the Benchtop Router.

Wear Safety Glasses
Foresight is better than no sight. During operation any power tool can throw
foreign objects and harmful chemicals into your eyes. Always put on safety
glasses or eye shields before starting up the Router. Safety glasses or shields
should provide full protection at the sides, as well as the front of the eyes.

Know Your Machine Tool
Read this guide carefully before you use the Router and keep it readily acces-
sible for quick reference. Know the intended applications and limitations of
the Router as well as its hazards.

Ground All Tools
The Router has an AC power cord terminated by a three-prong plug. The
power cord should be plugged into a three-hole, grounded receptacle. If a
grounding adapter is used to accommodate a two-prong receptacle, the
adapter wire must be attached to a known ground. Never remove the third
prong from the plug on the AC power cord.

Keep the Safety Shield in Place
The safety shield should remain in place whenever the spindle motor is on.

Remove Adjusting Keys and Wrenches
Make it a habit to check that keys and adjusting wrenches are removed from
the Router before turning on the machine.

Keep the Work Area Clean
Cluttered work areas and bench tops invite accidents.

Avoid a Dangerous Environment
Don’t use the Router in damp or wet locations. Never operate electrical
equipment in the presence of volatile and flammable petroleum-based sol-
vents and lubricants.

Feel free to copy these rules, or the
Safety Checklist, and post them in
your work area for quick
reference.
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Keep Untrained Visitors Away from the Equipment
Children, and visitors unfamiliar with the hazards of rotating machinery,
should always be kept away from the work area.

Prevent Unauthorized Users from Operating the Router
Lock and remove the key from the Router control panel when the system is
not in use.

Do Not Force a Tool
Select the feed rate and depth of cut best suited to the design, construction
and purpose of the cutting tool. It is always better to take too light a cut than
too heavy a cut.

Use the Right Tool
Select the type of cutting tool best suited to the milling operation. Don't
force a tool or attachment to do a job it wasn't designed to do.

Dress Appropriately
Don't wear loose clothing or jewelry which can get caught in moving parts.
Wear a hat, a hairnet, or tie your hair back to keep it away from moving parts.

Secure the Workpiece
Be certain that you have firmly secured the workpiece in the vise and the cut-
ting tool to the collet before turning on the router motor.

Do Not Overreach
Keep your footing and balance at all times so you won’t fall into or grab the
moving machine.

Maintain Cutting Tools In Top Condition
Keep cutting tools sharp and clean. Lubricate and clean Router components
on a regular basis.

Disconnect Tools Before Servicing
Always use the emergency stop switch to disconnect power  and disable the
motor before mounting or removing the workpiece, or changing tools. Do not
rely solely on a programmed Pause command to disable Router operation.
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Avoid Accidental Starting
Make sure the power switch on the control box is off before plugging in the
Router power cord.

Use Recommended Accessories
To avoid stressing the Router and creating a hazardous machining environment,
use only those accessories designed for use with the Benchtop Router, available
through Light Machines Corporation.

Tighten All Holding, Locking and Driving Devices
Tighten the collet. Do not over-tighten tool holding devices. Over-tightening
may damage threads or warp parts, thereby reducing accuracy and effectiveness.

Do Not Operate the Machine Under the Influence of Alcohol
or Drugs
Alcohol or drugs may impair your judgement and reaction time, which
could contribute to an on-the-job accident.

Avoid Distractions While Running the Machine
Use simple common sense and pay attention while operating any piece of
machinery.

Emergency Stops
All operators must be fully aware of how to shut down the machine quickly,
should the need arise.

w In an emergency, you should always use the red Emergency Stop button
on the Router.

w You can also stop it by pressing the Control and Space keys on the com-
puter keyboard, or by clicking on the stop buttons on the screen with
the mouse. In an emergency, always use the Emergency Stop button on
the machine.
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Safety Checklist
Before you enter the work area:

q Put on safety glasses.

q Tie back loose hair and clothing.

q Remove jewelry including rings, bracelets and wristwatches.

Before machining a part:

q Make sure you have the correct tool for the job.

q Secure the tool properly.

q Make sure all tool positions have been properly initialized.

q Verify the NC program on the computer before machining.

q Remove all loose parts and pieces from the machine.

q Remove adjusting keys and wrenches from
the machine.

q Close the safety shield.

q Only operate the machine after being properly trained in its use.

Perform a dry run:

q Set the spindle motor switch to lowest manual speed setting.

q Make certain there is no workpiece in place.

q Run the NC program to make sure all the moves make sense before run-
ning the program with a workpiece in place.

q After completing the dry run, properly secure the workpiece to the ma-
chine.

q Keep fluids away from all electrical connections, electronic or electrical
devices, the computer and nearby electrical outlets.

While machining a part:

q Do not touch moving or rotating parts.

q Press the Emergency Stop button before opening the safety shield.

q Only open the safety shield after the spindle has stopped rotating.

q Press the Emergency Stop button whenever changing tools or mounting
or removing a workpiece.

q Pull the Emergency Stop button out only after closing the safety shield.

q Keep all unauthorized persons away from the work area.

IMPORTANT!

Post copies of this checklist in the
work area. Verify that all items are
checked-off prior to each operation
of the Benchtop Router.
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Lista de Seguridad
Antes de entrar en el área de trabajo:

q Use sus lentes de seguridad.

q Procure recogerse el cabello y no usar ropa floja.

q No use joyería como:  anillos, pulseras y relojes.

Antes de trabajar a máquina una pieza:

q Utilize la herramienta correcta para el trabajo. Asegurela de forma
correcta en el husillo con una boquilla.

q Asegurese que la posición de la herramienta de corte ha sido inicializada
correctamente.

q Remueva todas las partes sueltas y coloquelas lejos de la Fresadora.
Limpie todos los residuos de la Fresadora después de cada corrida.

q Cierre la guarda de seguridad antes de ejecutar cualquier operación en la
Fresadora.

q Corra los programas por primera vez con el motor del husillo apagado y
sin pieza de trabajo. Asegurese que todos los movimientos sean
correctos.

q Asegure la pieza de trabjo a la mesa. Quite las herramientas y llaves an-
tes de cerrar la guarda de seguridad.

q Asegurese que todos los contactos de corriente A.C. esten aterrizados.

q Mantenga los líquidos refrigerantes lejos de la Caja
de Control, Computadora y cualquier Suministro Eléctrico.

Mientras trabaja a máquina una pieza:

q Nunca levante la guarda de seguridad mientras que la Computadora
este ejecutando un programa. Presione siempre primero el botón de
“Paro de Emergencia”.

q Presione siempre el botón de “Paro de Emergencia” cuando se cambie
una herramienta, se coloque o remueva una pieza de trabajo. Jale el
botón de “Paro de Emergencia” después de haber puesto la guarda de
seguridad.

q Mantenga fuera del área de trabjo a toda persona no autorizada.

¡IMPORTANTE!

Pegue copias en el área de trabajo.
Verifique que todos los puntos esten
checados antes de cada puesta en
marcha de la máquina.
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G and M Codes

G Codes by Group

M Codes by Group

Reference Guide: Section J



Reference Guide: Section JJ-2

G00 Rapid traverse

G01 Linear interpolation

G02 Circular interpolation (clockwise)

G03 Circular interpolation (counterclockwise)

G90 Absolute coordinate programming (Fanuc uses U,W):  All X, Y and Z axes
coordinates are relative to a (0,0) location on a mill.

G91 Incremental coordinate programming: Each command is relative to the one
before it in the program.

G20 (Fanuc) Inch: Used to instruct the mill that inches are the unit of measure
for the part program

G21 (Fanuc) Metric: Used to instruct the mill that millimeters are the unit of
measure for the part program.

G70 Inch: Used to instruct the mill that inches are the unit of measure for the
part program.

G71 Metric: Used to instruct the mill that millimeters are the unit of measure for
the part program.

G04 Dwell (wait): Equals the value of the feed rate (F code) in seconds (used
primarily for robotic operations). G04 excludes motion commands with a
new feed rate on the same line (block).

G05 Pause: Used for operator intervention. The order of action for the pause and
dwell codes in one NC block is G05, G04 (pause, dwell).

G25 Wait for robot input to be high: Used in conjunction with H code, which
specifies input number. Used for robot synchronization (see Section K).

G26 Wait for robot input to be low: Used in conjunction with H code,
which specifies input number. Used for robot synchronization (see Section
K.

G31 Linear to specified coordinate.Stop short if specified input goes High (if H is
positive) or Low (if H is negative).

G15 Polar programming cancel.

Interpolation
Group

Programming
Mode Group

Units
Group

Wait
Group

G Codes by Group
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  G16 Begin polar programming.

G53 Rapid traverse to specified coordinates in the Machine Coordinate System.
(e.g. G53X0Y0Z0 rapids to machine reference point)

G54 Use coordinate system one.

G55 Use coordinate system two.

G56 Use coordinate system three.

G57 Use coordinate system four.

G58 Use coordinate system five.

G59 Use coordinate system six.

G80 Canned cycle cancel.

G81 Canned cycle drilling.

G82 Canned cycle straight drilling with dwell.

G83 Canned cycle peck drilling.

G84 Canned cycle tapping.

G85 Canned cycle boring.

G86 Canned cycle boring with spindle off (dwell optional).

G89 Canned cycle boring with dwell.

G27 Check reference point: This code moves the tool to its home position on the
Machining Center to check the calibration of the axes. Compares reported
position against zero to see if position has been lost.

G28 Set reference point: This code moves the tool and calibrates the axes. The
Machine Coordinate System origin is located at this home position.

G29 Return to reference point: Moves the tool to a coordinate specified by XYZ.
Typically used after a G27 or G28 code.

G92 Set position: This code works like the Set Position function under the Setup
Menu (see Section E). The X, Y and Z coordinates following a G92 code
define the new current position of the tool.

G98 Rapid move to initial tool position after canned cycle complete (Section G).

G99 Rapid move to point R (surface of material or other reference point) after
canned cycle complete (Section G).

G17 Select the X,Y plane for circular interpolation. This is the default plane for
circular interpolation. Use this code to switch back to the X,Y plane after cir-

Polar Programming
Group

Coordinate System Group

Canned Cycle
Group

Preset Position
Group
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cular moves on the X,Z or Y, Z planes. The arc center coordinates are given
by I for the X axis and J for the Y axis.

G18 Select the X,Z plane for circular interpolation. Use this code to perform circu-
lar interpolation on the X,Z plane. The arc center coordinates are given by I
for the X axis and K for the Z axis.

G19 Select the Y,Z plane for circular interpolation. Use this code to perform circu-
lar interpolation on the Y,Z plane. The arc center coordinates are given by J
for the Y axis and K for the Z axis.

G50 Cancel scaling.

G51 Invoke scaling. Use this code to scale axes by a single factor, or by indepen-
dent factors around a fixed origin. The default scale factor is 1.

G68 Invoke rotation. Use this code to rotate geometry an arbitrary angle around a
specified point. Rotation works on any plane, one plane at a time.

G69 Cancel rotation.

G39 Corner offset in circular interpolation.

G40 Cancel cutter compensation.

G41 Invoke cutter compensation left.

G42 Invoke cutter compensation right.

D Specifies the offset number from the Offset Table.

G43 Shifts Z axis in a positive direction by a value specified by H.

G44 Shifts Z axis in a negative direction by a value specified by H.

G49 Cancel Tool Length Offsets.

H Specifies the offset number from the Offset Table.

G45 Increases the movement amount by the value of D.

G46 Decreases the movement amount by the value of D.

G47 Increases the movement amount by twice the value of D.

G48 Decreases the movement amount by twice the value of D.

D Specifies the offset number from the Offset Table.

Scaling Group

Rotation Group

Cutter Compensation
Group

Tool Length Offset
Group

Tool Length Adjust
Group

Plane Selection
Group



G and M Codes J-5

  M00 Pause: Allows you to place a pause in your code. Acts like a G05 pause.

  M01 Optional Stop: Allows you to place an optional stop in your code. Place
an M01 in the block of code where you would like to pause. With Op-
tional Stop on, the M01 works like a G05. With Optional Stop off, the
M01 code is ignored, the other codes on the block are executed as
usual.

  M02 End of Program: Takes effect after all motion has stopped; turns off
drive motors, spindle and accessory outlets.

  M30 Program stop: Same as M02.

  M03 Spindle Motor On: Activated concurrently with motion specified in the
program block; remains in effect until superseded by M05.

  M05 Spindle Motor Off: Activated after the motion specified in the program
block; remains in effect until superseded by M03.

  M06 Tool Change: Used in conjunction with a T code to perform multiple
tool operations. See Section H.

  M08 ACC1 On: Turns on accessory ACC1 outlet concurrently with the motion
specified in the program block; remains in effect until superseded by
M09.

  M09 ACC1 Off: Turns off accessory ACC1 outlet after the motion specified
in the program block; remains in effect until superseded by M08.

  M10 Clamp ACC2: Turns on ACC2. Closes air vise accessory concurrently
with the motion specified in the program block; remains in effect until su-
perseded by M11.

  M11 Unclamp ACC2: Turns off ACC2. Opens air vise accessory after the
motion specified in the program block; remains in effect until super-
seded by M10.

 M25 Set robot output: Used for robot synchronization. Used in conjunction
with H code to specify output number.

  M26 Set robot output: Used for robot synchronization. Used in conjunction
with H code to specify output number.

Program Stop/End Group

Spindle Group

Tool Change Group

Accessories
On/Off Group

M Codes by Group
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  M20 Chain to Next Program: This code appears at the end of a part program
and is followed on the next line by the file name of another program
which is executed when all motion stops. Here’s an example of a part
program chain to another program:

N37Z.2
N38M20
PROGRAM TWO

If the two programs you are chaining are not in the same directory,
you must specify the full pathname for each file. If the specified file is
not found, the Open dialog box appears so you can locate it.

  M22 Output to file: Outputs information to a file. The first time the Control
Program encounters an M22 code, it opens the specified file. You must
enclose the name of the file in parentheses for the Control Program to
recognize it.

  M47 Rewind: Restarts the currently running program; takes effect after all
motion comes to a stop. Use the L code to repeat a finite number of
times. The L code defines the number of times to run. For example,
M47L2 rewinds once, to run the program twice.

  M98 Call to subprogram

  M99 Return from subprogram: Returns you to the block following the initial
M98 command.

Go to: Used with P code. P code defines N code destination. Goes to
first occurrence of N code within the main program. The N code can
not follow any subprogram (O code).

Program Management Group
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Robotic Integration

Reference Guide: Section K



Reference Guide: Section KK-2

Robotic Integration
The Benchtop CNC Router has a simple interface for interacting with com-
mon robots, like those used for automatic part loading between machining
operations. The machine and the robot communicate by way of an interface
connector (labeled I/0) located on the rear panel of the router.

How it Works
The method of communication between the router and robot is very basic.
They are both able to transmit and receive high or low signals. Since commu-
nication signals are typically 0 and 5 volts, a high signal is 5 volts (or 3.5
volts or greater); and a low signal is 0 volts (or 1.5 volts or less). See the fig-
ure below.

There are NC codes that you can place in a part program to instruct the
router to transmit a high or low signal to the robot. There are also codes that
instruct the router to wait for a high or low signal from the robot.

User Input Voltage
+5 to +24 VDC

+3.5 VDC

'Illegal Zone' Undefined Logic State

+1.5 VDC

Zero Volts

Logical 'Zero' state

Logical 'One' State
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Signals sent out are referred to as outputs, while signals coming in are
called inputs. Any signals that the router transmits to the robot are trans-
mitted through an output pin on the interface connector. Outputs can
drive a maximum load of 1mA. Any signals that the router receives from
the robot come in through an input pin on the interface connector.

Examples of input and output wiring are shown in the schematic below.

INPUT (X) H

Vcc

Input Configuration

OUTPUT to Robot 

Output Configuration

INPUT (X) from Ro b

Vcc

ROUTER



Reference Guide: Section KK-4

The Interface Connector
The 9 pin I/O connector on the controller box rear panel provides a number
of ways for the router to communicate with robots and other external mecha-
nisms, such as an additional limit switch. Most of the controller inputs and
outputs are located on this connector.

Some of the inputs and outputs are not free for robotic interfacing, they al-
ready have dedicated uses; inputs 7 and 8 for example. The inputs and out-
puts on the router are designated as follows.

Pin 9

You can check the status of each
input and output by using the
toolbars  in the Control Program.

The Robotic Interface Connector

Pin 1

Pin Funtion I/O Levels Name

1 Input 1 +5V INP 1L

2 External Limit 0 or +5V ELim

3 Output 2 +1V to +3.5V OUTPUT 2

4 Output 1 +1V to +3.5V OUTPUT1

5 Common GND

6 Input 2 0 or +5V INPUT 2

7 Input 1H See Note INPUT 1H

8 Input 2H See Note INPUT 2H

9 Common GND

Notes: Grounding pins 1 and 6 will
cause the input to be true.

Inputs 1H and 2H are only  used in
isolated input mode, and the
Controller Box must be specifically
configured.

Other Input/Output Notes:

u All User outputs are disabled by an ESTOP condition.

u Never apply a negative voltage or an AC voltage to an input.

u Do not connect to pins 7 or 8. These are for special applications.

u Outputs are set to source current only. Max load on each output is 1mA.

u Do not operate relays, motors or other inductive loads with the
I/O outputs. This will damage the machine. You may however, run an
optical relay.
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The NC Codes
The NC codes used in robotic communication are:

G25 - wait for High signal
G26 - wait for Low signal
M25 - transmit High signal
M26 - transmit Low signal
H# - specifies the input or output (default is H5)

The H code is used in conjunction with the wait codes and transmit codes.
For example, G25H3 tells the router to wait until the state at input #3 goes
high.

Assuming the robot’s initial output state is low, if you place this line of code
at the beginning of your program, the router waits until input #3 goes high,
then executes the next line of code.

If the external device sends a low signal, nothing happens because the router
is waiting for a high signal. If there’s no change to a high signal, the router
does not execute the next line of NC code in the program.

When the robot sends a high signal, the router responds by continuing with
the NC program. If the router does not respond to the robot as you have
programmed it to, check that you have correctly wired the robot to the inter-
face, and that the robot’s initial output state was not changed to high during
the connection of the robot.
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1.  The router opens the air vise
(M11), transmits a high signal
(M25) to the robot, and waits for a
high (on) signal (G25).

A Sample of Router/Robot Communication
As previously explained, communication between the router and robot is
very simple. They only use and recognize high or low signals. Once the
router sends a signal to the robot, it goes into a wait state and continues to
wait until the robot sends the appropriate signal back. When the signal is
recognized, the router executes the next instruction in the part program. Af-
ter executing the instruction, it sends a signal to the robot. The robot, which
has been in a wait state since its last transmission, receives the signal, per-
forms as it has been programmed, then again signals the router.

This reciprocal system of communication is made possible by the placement
of G and M codes in the part program. The G codes provide the wait
instructions to the inputs, while the M codes provide the transmit
instructions to the outputs.

The following sequence is typical of communication between the router and
a robot. Since the robot’s initial output state is low, the routers inputs have
already been pulled down to a low state.

Transmit High (G25)

Wait for High (M25)
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5.  The router receives the low
signal from the robot and begins
to router the part.

4.  The robot releases the work
piece and leaves the work area. It
transmits a low signal when it is
away from the work area.

3.  The router receives the signal,
closes the air vise (M10), then
signals (M26) the robot that the
vise is closed. The router then
waits (G26) for a low signal from
the robot.

2.  The robot places a work piece
in the vise and transmits a high
signal to the router indicating
that it is okay to close the vise.

Transmit Low (M26)

Wait for Low (G26)
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10.  At this point, the cycle begins
again (M47).

7.  When the robot receives the
signal, it approaches the router,
grasps the part and sends the high
signal to the router.

9.  The robot removes the finished
part from the work area, and
places the part in another area
according to its own program.
When the robot has cleared the
router�s work area, it sends a low
signal to the router.

8.  When the router receives the high
signal, it opens the vise (M11) to
release the finished part, signals the
robot (M26) and waits (G26, low).

6.  When the router has finished
the part, it signals the robot
(M25) to come take the part and
waits (G25) for a high signal.

Transmit High (M25)

Wait for High (G25)

Transmit Low (M26)

Wait for Low (G26)
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Robot
Handshaking

Robot
Handshaking

NC Program

N0M11;OPEN VISE

N1M25H5;TRANSMIT HIGH SIGNAL TO ACC2

N2G25H5;WAIT FOR HIGH SIGNAL FROM ACC2

N3M10;CLOSE VISE

N4M26H5;TRANSMIT LOW SIGNAL TO ACC2

N5G26H5;WAIT FOR LOW SIGNAL THROUGH INPUT 1

N0;THIS FILE FOR BENCHTOP ROUTER

N1;USE 5.5" X 5.5" PINE

N2G05

N3S1500M03

N4G0Z0.0700

N5G0X1.0000Y0.3140

N6G0Z0.0050

N7G1Z-0.1000F4.0

N8G3X1.5830Y1.3330I-0.5990J1.0190F12.0

N9X0.4170I-0.5830J-1.0190

N10X1.0000Y0.3140I1.1820J0.0000

N11G0Z0.0700

N12S1500.00

N13G0X0.8000Y0.7330

N14G0Z0.0050

N15G1Z-0.1000F4.0

N16G3X0.9330Y0.6670I0.1330J0.1010F12.0

N17G1X1.0670

N18G3Y1.0010I0.0000J0.1670

N19G1X0.9330Y1.0000

N20G2Y1.3340I0.0000J0.1670

N21G1X1.0670Y1.3330

N22G2X1.1997Y1.2668I0.0000J-0.1660

N23G0Z0.0700

N24M02

N26M25H5;TRANSMIT HIGH SIGNAL TO ACC2

N27G25H5;WAIT FOR HIGH SIGNAL FROM ACC2

N28M11;OPEN VISE

N29M26H5;TRANSMIT LOW SIGNALTO ACC2

N30G26H5;WAIT FOR LOW SIGNAL FROM ACC2

N31M47L3;CYCLE BACK TO N0

N32M2;END OF PROGRAM

This program illustrates one way
to use G, M and H codes to
interface with a robot. The codes
inserted for robot interfacing are
in bold.
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Index 1

Index

A

About BenchRouter  E-51
Absolute coordinate programming code  J-2
Accessories  I-4
Accessory Kit  B-3
Accessory off code  J-5
Accessory on code  J-5
Address character  F-2
Administrator Mode  E-48
Alter existing tool  E-32
Arc Centers Incremental  E-37
Arrange Icons  E-49
Auto-refresh  E-40
AutoCAD  B-2. See also CAD programs
AutoSave  E-47

B

Backlash  E-46
Ball screw

lubricant  B-6
Benchtop CNC Router

components  B-2
Control Program  B-2

Benchtop Router Interface  E-2
Blocks

maximum number per program  F-2
of NC code  F-2

Boring cycle  G-11
Boring cycle code  G-7
Boring cycle with dwell code  G-7
Boring cycle with spindle off code  G-7
Buttons  E-41

C

CAD
programs  B-2

Call to subprogram code  G-13
Canned cycle

boring  G-11
cancel  G-7
codes  J-3
dwell  G-9
G codes  G-7
peck drilling  G-9
programming  G-7
straight drilling  G-8
tapping threads  G-10

Cascade  E-49
Centerline Options  E-40
Chain to next program  J-6
Check Home  E-41
Circular interpolation  B-2, G-4, H-14

clockwise, code for  J-2
counterclockwise, code  J-2

Circular interpolation programming  G-3
Clamp ACC2 code  J-5
Clear  E-19
Close Command  E-13
CNC. See NC programming
compensation offset  E-44
Computer System Requirements  A-9
Context Help  E-6
Control Program

Installation  A-9
screens  C-4
starting  C-2

Controller Box  B-9
Coordinate System

codes  J-3
Command  E-42

Coordinate Systems, understanding  H-27
Copy  E-18
Corner offset circular interpolation  H-14
Corner offset code  J-4
Crosspad  E-9
Ctrl+C  E-56
Ctrl+F  E-56
Ctrl+G  E-56
Ctrl+H  E-56
Ctrl+L  E-56
Ctrl+N  E-56
Ctrl+O  E-56
Ctrl+P  E-56
Ctrl+R  E-56
Ctrl+S  E-56
Ctrl+Shift+Z  E-56
Ctrl+Space  E-56
Ctrl+T  E-56
Ctrl+V  E-56
Ctrl+X  E-56
Ctrl+Y  E-56
Ctrl+Z  E-56
Customer Service Department  A-3
Cut  E-18
Cutter compensation  H-6

canceling  H-15
codes  J-4
IJK vectors  H-10
setting offsets  H-11
starting  H-6, H-7

D

Default Values for Speed  E-35
Delete  E-19
Diameter Offset  E-31
docked screen component  E-60
Door Interlock Switch  D-3
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Door, safety  I-2
Dwell code  J-2
DXF files  B-2

E

Edit Menu  E-17
Edit Tool Materials  E-31
Edit Window  C-8

moving  E-59
Editor Preferences  E-47
EIA RS-274D NC codes  B-2
Emergency Stop  D-3

button
location of  B-5

Emergency Stop Button  D-3
Enable Soft Limits  E-46
Enable Subprograms  E-37
Enclosure

Door, Interlock Switch  B-4
End of program  J-5
Estimate Runtime  E-28, E-53
Exit command  E-16

F

F1  E-56
F3  E-56
F5  E-56
F6  E-56
F8  E-56
Feed Rate Override  E-10
Feedhold  E-29
File Default  E-47
File Menu  E-12
Find  E-19
floating screen component  E-60
Font Settings  E-24
fuses  B-5

G

G92  E-43
General Panel  E-62
Glasses  I-2
Go to code  J-6
Goto Line  E-20
Goto Position  E-42

H

H code  K-5
Hardware Installation  A-4
Helical interpolation  G-5
Help Index

Menu, Command  E-50
Home  E-41
Homing

commands  H-3
Hot Keys  E-56

I

Inch programming code  J-2
Incremental coordinate programming code  J-2
Initial Tool Position  E-40
Inputs Toolbar  C-7, E-7
Insert N Codes  E-21
Insert or Remove Spaces  E-22
Interface Card

Installing  A-4
Interface Card Panel  E-62
interlock switch  D-3
Interpolation  B-2

circular  G-3
linear  G-2

J

Jog Control  E-25
Jog Control Panel  E-9

Pop-up Menu commands  E-55
Jog Distance  E-35
Jog Settings  E-35
Jog Speed  E-35

K

Key Lock switch  B-5

L

L code  G-13
Limit switches

location of  B-4
limit switches  D-3
Linear interpolation

code  J-2
programming  G-2

Linear motion code  J-2
Lock  E-23
Loop counter code  G-13

M

Machine Coordinates  H-27
Machine Info Window  E-4
Maximum blocks per program  F-2
Menu Bar  C-4, E-12
Message Bar  E-3
Metric code  J-2
Multiple Coordinate  Systems  H-27
Multiplier  E-31

N

NC code
for robotic communication  K-5

NC part programs  F-2
negative limit  D-4
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New Command  E-12
Num Teeth  E-31

O

O code  G-13
Offset

number  E-44
number code  J-4
sides, changing  H-13
values, changing  H-12

Offset Table  E-44, J-4
Open Command  E-13
Opening a Recent Program  E-16
Operator Panel  E-10, E-25
Optional

Skip  E-36
Stop  E-10, E-37, J-5

Options Panel  E-40
Origin  E-39
Output to file code  J-6
Outputs Toolbar  C-6, E-8

P

P code, calling subprograms  G-13
Password

changing, creating  E-49
Paste  E-18
Pause  E-29

G code for  J-5
Pause code  J-2
Peck drilling code  G-7
Peck drilling cycles  G-9
Plane selection codes  J-4
Polar programming  H-2

cancel code  J-3
polar programming

code  J-3
Pop-Up Menu  E-52
Position  E-24
Position Readout  C-10
Position Window  E-5

Pop-up menu commands  E-53
Positioning Information Areas  E-58
Positioning Toolbars  E-58
positive limit  D-4
Preferences  E-47

exiting  E-48
Security  E-48

Preset View  E-39
Preview Window  E-40
Print  E-15
Print Setup  E-15
Program Edit Window  E-3

Pop-up Menu commands  E-52
Program Menu  E-26
Program stop code  J-5

Programming
suggestions  F-23

Q

Quick Home  E-41
QuickRun  E-53
QuickVerify  E-53

R

Rapid motion codes  J-3
Rapid to initial position code  G-7
Rapid to point R code  G-7
Rapid traverse

code  J-2, J-3
programming  G-6

Redraw  E-54
Remove Comments  E-23
Remove N Codes  E-23
Renumber  E-21
Renumbering and Subprograms  E-22
Replace  E-20
Reset Override  E-45
Restore Settings  E-51
Restore Unit Mode  E-37
Return from subprogram code  G-13
Return to reference point code  J-3
Rewind  J-6
robot synchronization codes  J-2
Rotation

and scaling  H-23
codes for  H-21

Rotation codes  J-4
Rules, Safety  I-1, I-2
Run Settings  E-27, E-36
Run/Continue  E-26, E-29
Running a Sample NC Program  D-5, D-14
Running a sample NC program  B-8

S

Safety  D-2
Safety Door  I-2

interlock switch  D-3
Safety Glasses  I-2
Safety Rules  D-2, I-1, I-2
Save As ...  E-14
Save As Dialog Box  E-14
Save Command  E-14
Save Settings  E-50
Scaling

and rotation  H-23
codes for  H-18
creating mirror images with  H-20
each axis  H-19

Scaling codes  J-4
select an existing coordinate system  E-42
Select Font  E-24
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Select Tool  E-32
Selecting Commands

Pop-up Menus  E-52
Set

robot output  J-5
Set Position  E-34
Set reference point code  J-3
Set/Check Home  E-41
Setting

offsets  H-11
soft limits  H-4

Setup Library  E-30
Setup Menu  E-33
Setup Program  E-61
Setup Tool  D-8
Shift Z axis code  J-4
Show Tool  E-40
Simulation Mode  E-63
Single Step  E-10, E-36
slider bars  E-40
slider button  E-40
Soft Limits  E-46
Solid Options  E-40
Specify depth of cut code  G-7
Specify starting reference point code  G-7
spectraCAM  B-2
Spindle  E-45

motor off code  J-5
motor on code  J-5
speed

control switch, location of  B-5
Spindle Speed Override  E-10
Standard Toolbar  C-4, E-6
Starting Block  E-26
Status Bar  E-11
Stock Dimensions  E-39
Stock Panel  E-39
Stop  E-10, E-29
Stop Redraw  E-54
Straight drilling  G-8
Straight drilling code  G-7
Straight drilling with dwell code  G-7
Style  E-38
Subprogram

call to  J-6
Subprogram reference block code  G-13
Subprogram, return from code  J-6
Subprograms  G-13

nested  G-13

T

Tapping threads  G-10
Technical Support  A-11
Tile  E-49
Tip of the Day  E-51
Tool

change code  J-5
length offset  H-29
length offset code  J-4
offset adjust  H-29

Tool Library  E-31
Tool Type  E-31
Tool Wizard  E-32
Toolbars  E-25
Tools  I-3

Creating  E-30
Tools Menu  E-30

U

Unclamp air chuck code  J-5
Undo  E-17
Uniform scaling  H-18
Units  E-42
Unpacking  A-3
Using Help  E-50

V

Verify  E-27
While Running  E-38

Verify Settings  D-6, E-27, E-38
Verify Type  E-41
Verify Window  C-11, E-4, E-25

Pop-up Menu commands  E-54
View Menu  E-24
View Panel  E-38

W

Warnings as Errors  E-37
Warranty  A-11
Window List  E-50
Window Menu  E-49
Words, NC  F-2
Work Area  B-2
Work Coordinates  H-27
Wrenches  I-2

Z

Zero Position  E-34
Zoom  E-39


	Table of Contents
	Section A: Installation 
	Getting Ready for Installation 
	Check Your Shipment 
	Register Your Benchtop Router 
	Prepare Your Work Place 
	Unpack the Benchtop Router 
	Set Up the Benchtop Router 
	Hardware Installation 
	Installing the Interface Card in the PC  
	Opening the PC Chassis  
	Unpacking the Interface Card  
	Inserting the Interface Card  
	Checking Your Installation  
	Connecting the Benchtop Router 
	Interface Connections 
	Hardware Connections 
	Optional Connections 
	Computer System Requirements  
	Software Installation 
	Installing the Control Program 
	Uninstalling the Control Program 
	The Setup Program 
	Technical Support 
	Before Calling 
	Warranty 
	Section B: System Hardware 
	The Benchtop CNC Router 
	Features 
	Machine Specifications 
	The Accessory Kit 
	The Router Components 
	The Front Panel 
	The Rear Panel 
	Maintaining the Benchtop Router  
	Cleaning and Lubrication 
	Ballscrews  
	The Dust Collection System 
	Maintaining the Controller Box  
	Maintaining the PC in a Shop Environment 
	Caring for the Computer 
	Caring for Floppy Disks  
	Benchtop Router Options 
	Section C: Getting to Know the  Control Program 
	Starting the Control Program 
	Starting the Control Program in Simulate Mode 
	If You Need Help... 
	Exploring the Control Program Screen 
	Menu Bar 
	Standard Tool Bar 
	Outputs Tool Bar 
	Inputs Tool Bar 
	Edit Window 
	Status Bar 
	Position Readout 
	Machine Info Panel 
	Verify Window 
	Tutorial 
	Safely Running the Benchtop Router 
	Safety Rules 
	Making Emergency Stops 
	Stopping with the Emergency Stop Button 
	Stopping with the Computer Keyboard 
	Stopping with a Limit Switch  
	Stopping with the Safety Interlock Switch 
	Running a Sample NC Program 
	Open ROUTER1.NC 
	Adjust the Verify Settings 
	Adjust the View 
	Adjust the Stock 
	Define the Tool 
	Add the Tool to the Library 
	Select the Tool for Verification 
	Installing a Tool 
	Verify ROUTER1.NC 
	Dry Run the NC Program 
	Mount the Workpiece  
	Run the Program 
	Control Program Reference 
	The Benchtop Router Interface 
	Using the Message Bar 
	Using Windows 
	Program Edit Windows 
	Verify Window 
	Machine Info Window 
	The Position Window 
	Using Tool Bars 
	Standard Toolbar 
	Inputs Toolbar 
	Outputs Toolbar 
	Panels 
	Jog Control Panel 
	Operator Panel 
	Status Bar 
	Menu Bar 
	File Menu 
	New Command 
	Open Command 
	Close Command 
	Save Command 
	Save As ... Command 
	Print Command 
	Print Setup Command 
	Opening a Recent Program 
	Exit Command 
	Edit Menu 
	Undo Command 
	Redo Command 
	Cut Command 
	Copy Command 
	Paste Command 
	Clear Command 
	Delete Line Command 
	Find Command 
	Replace Command 
	Goto Line Command 
	Renumber Command 
	Insert N Codes 
	Insert or Remove Spaces 
	Remove Comments 
	Remove N Codes 
	Lock Command 
	Select Font Command 
	Font Settings 
	View Menu 
	Position Command 
	Machine Info Command 
	Jog Control Command 
	Operator Panel Command 
	Verify Window Command 
	Toolbars Command 
	Program Menu 
	Run/Continue Command 
	Verify Command 
	Estimate Runtime Command 
	Pause Command 
	Feedhold Command 
	Stop Command 
	Tools Menu 
	Setup Library Command 
	Setup Tool Wizard Command 
	Select Tool Command 
	Setup Menu 
	Set Position Command 
	Zero Position Command 
	Jog Settings Command 
	Run Settings Command 
	Verify Settings Command 
	Verify Type Command 
	Set/Check Home Command 
	Goto Position Command 
	Units Command 
	Coordinate Systems Command 
	Offsets Command 
	Spindle Command 
	Backlash Command 
	Soft Limits Command 
	Preferences Command 
	Window Menu 
	Cascade Command 
	Tile Command 
	Arrange Icons Command 
	Window List Command 
	Help Menu 
	Help Command 
	Index Command 
	Using Help Command 
	Save Settings Command 
	Restore Settings Command 
	Tip of the Day Command 
	About BenchRouter ... Command 
	Selecting Commands 
	Select a Command Using Pop-Up Menus 
	Program Edit Window Pop-up Menu 
	Position Window Pop-up Menu 
	Verify Window Pop-up Menu 
	Jog Control Panel Pop-up Menu 
	Select a Command Using Hot Keys 
	Select a Command Using Toolbars 
	Positioning Screen Components 
	Positioning Toolbars 
	Positioning Information Areas 
	Positioning Program Edit Windows 
	Saving the Window Positions 
	Docking and Floating Windows and Toolbars 
	Docked Screen Components 
	Floating Screen Components 
	The Setup Program 
	Welcome Panel 
	Interface Card Panel 
	General Panel 
	Offset Table 
	Working in Simulation Mode 
	Basic CNC Programming  
	The Elements of an NC Part Program 
	Categories of NC Code  
	Incremental Arc Center (%)  
	Absolute Arc Centers ($) 
	Skip (\) and Optional Skip (/) 
	Compensation Offset Value (D Code) 
	Feed Rate (F Code) 
	Preparatory Codes (G Codes)  
	The Interpolation Group 
	The Units Group 
	The Plane Selection Group 
	The Wait Group 
	The Canned Cycle Group 
	The Programming Mode Group 
	The Preset Position Group 
	The Compensation Functions Group 
	The Coordinate System Group 
	The Polar Programming Group 
	Input Selection Number/Tool Length Offset (H Code) 
	X Axis Coordinate of Center Point (I Code) 
	Y Axis Coordinate of Center Point (J Code) 
	Z Axis Coordinate of Center Point (K Code) 
	Angle of Arc Resolution, Loop Counter (L Code) 
	Miscellaneous Codes (M Codes) 
	M22: Output Current Position to File 
	M99: Return from Subprogram, Goto 
	M105: Operator Message 
	Block Number (N Code) 
	Subprogram Block Number (O Code)  
	Subprogram Reference Number (P Code) 
	Peck Depth (Q Code) 
	Radius of Arc, Drilling Start Location (R Code) 
	Spindle Speed (S Code) 
	Tool Selection (T Code) 
	X Axis Coordinate (X or U Code) 
	Y Axis Coordinate (Y or V Code) 
	Z Axis Coordinate (Z or W Code)  
	Comment Codes 
	General Programming Suggestions 
	Section G: More CNC Programming  
	Linear Interpolation Programming 
	Circular Interpolation Programming 
	Circular Interpolation on Other Planes 
	Helical Interpolation Programming 
	Rapid Traverse Programming  
	Canned Cycle Programming 
	Using G80 
	Using G81 
	Using G82 
	Using G83 
	Using G84 
	Using G85 
	Using G86 
	Using G89 
	Subprogram Programming 
	A Sample NC Subprogram 
	Advanced CNC Programming  
	Using Polar Programming 
	Using the Homing Commands 
	Using G28 
	Using G28 in an NC Program 
	Using G28 Before Setting Soft Limits 
	Using G27 
	Using G29 
	Using Cutter Compensation 
	Starting Cutter Compensation (G41/G42) 
	Cutter Compensation with IJK Vectors 
	Setting Cutter Compensation Offsets (D) 
	Changing Offset Values  
	Changing Offset Sides  
	Using Corner Offset Circular Interpolation (G39) 
	Canceling Cutter Compensation 
	Methods 1 and 4 
	Methods 2 and 5 
	Methods 3 and 6 
	Using Scaling and Rotation Codes 
	Scaling 
	Uniform Scaling  
	Scaling Each Axis 
	Creating Mirror Images with Scaling 
	Rotation Codes 
	Combining Scaling and Rotation Codes 
	Multiple Tool Programming 
	Using Multiple Tool Codes 
	Establishing the Reference Tool 
	Establishing Tool Offsets 
	Testing Your Multiple Tool Program 
	Understanding Coordinate Systems 
	Machine Coordinates 
	Work Coordinates 
	Multiple Coordinate  Systems 
	Using Tool Length Offset Codes 
	Using Tool Offset Adjust Codes 
	G45 
	G46 
	G47 
	G48 
	Safe Router Operation 
	Safety Rules 
	Emergency Stops 
	Safety Checklist 
	Lista de Seguridad 
	Section J: G and M Codes  
	G Codes by Group 
	M Codes by Group 
	Robotic Integration 
	Robotic Integration 
	How it Works 
	The Interface Connector 
	The NC Codes 
	A Sample of Router/Robot Communication 
	Index 


